No me detecta el escaner de la multifunción HP PHOTOSMART 5510 (Solucionado)

Imagen de EvaEvaEva
0 puntos

Tengo una impresora multifunción nueva HP PHOTOSMART 5510 y Ubuntu 10.04 64 bits.

La he instalado sin problemas e imprime bien, pero al cargar Simple Scan para escanear no detecta el escanner, sale el siguiente mensaje: Ninún escáner detectado.

He probado también con el programa gscan2pdf pero tampoco la detecta.

Hasta ahora he tenido una multifunción HP psc 1210 y la detectaban bien tanto Simple Scan como gscan2pd

¿Como puedo solucionar este problema?

Un saludo.

Imagen de EvaEvaEva
+1
0
-1

He averiguado que la HP PHOTOSMART 5510 necesita una versión más reciente de HPLIP que la que viene en los repositorios, por lo que me he bajado e instalado la última que creo que es HPLIP-3.11.12.run
Ahora si que me detecta el escaner, pero con Simple Scan al intentar escanear se queda como que está intentando el escaneo pero no hace nada.
Con gscan2pdf empieza y al poco da un error que pone "Error no identificado" y tampoco puedo hacer nada.

Alguna idea mientras sigo investigando.

Gracias.

+1
0
-1
Imagen de EvaEvaEva
+1
0
-1

Me sigo respondiendo...

Probando desde el lápiz USB Ubuntu 12.04 vi que si que me detecta el escaner.
Probé de nuevo con Ubuntu 10.04 y cual fue mi sorpresa que funcionó. Entonces descubrí lo que ocurre.

Resulta que tengo 1 puerto USB 3.0 y 3 puertos USB 2.0, y si conecto la impresora al USB 3.0 me reconoce el escaner (después de haber instalado la nueva versión de HPLIP), pero me da un error y no puedo escanerar, en cambio si conecto la impresora a cualquier puerto USB 2.0 funciona perfectamente.

No se por qué pero es así.

+1
0
-1
Imagen de EvaEvaEva
+1
0
-1

Además de instalar la última versión de HPLIP, he conectado la impresora inalámbricamente (sin cable), y ahora funciona todo perfectamente, la impresora y el escaner.

Un saludo.

+1
0
-1