Ubuntu Server 10.04 no reconoce Realtek RTL 8187

Imagen de Death_Doc
0 puntos

Hola, estaba intentando instalar Ubuntu Server 10.04, pero al llegar el momento de detectar el Hardware de red parece que no detecta el interface wifi, lo que se me hace raro ya que en ubuntu desktop lo detecta sin problemas.

Estuve mirando por foros y me llevaron a mirar en la libreria de modulos del instalador y ahi aparecen algunos modelos de realtek pero no el 8187, por lo que supongo que esta distro no los trae por lo que creo que tengo que encontrar esa libreria y volver a compilar el ubuntu incluyendola, aunque no estoy muy seguro de todo esto, alguien me puede hechar una mano.

Imagen de Gabriel_M
+1
0
-1

Instala el paquete build essential
apt-get install build-essential

Descarga el driver para el chipset rtl8187
wget http://dl.aircrack-ng.org/drivers/rtl8187_linux_26.1010.zip

Descromprime el archivo
unzip rtl8187_linux_26.1010.zip

Cambia de directorio
cd rtl8187_linux_26.1010.0622.2006/

Descarga el parche del driver
wget http://patches.aircrack-ng.org/rtl8187_2.6.27.patch
tar xzf drv.tar.gz
tar xzf stack.tar.gz

Edita el archivo beta-8187/r8187.h
gedit ./beta-8187/r8187.h
Busca la linea:

#include <asm/semaphore.h>

Modificala para que quede asi:

#include <linux/semaphore.h>

Instala el paquete patch
apt-get install patch

Si no lo encuentras, lo puedes descargar desde aquí
http://packages.ubuntu.com/search?keywords=patch&searchon=names&suite=al...

Aplica el parche
patch -Np1 -i rtl8187_2.6.27.patch

Agrega rtl8187 a la lista negra:
gedit /etc/modprobe.d/blacklist
y agrega lo siguiente “blacklist rtl8187” al final del archivo sin comillas) en una nueva linea.

Remueve el driver que pueda estar presente:
ifconfig wlan0 down
rmmod rtl8187

Instala el driver descargado
make
make install

Reinicia
reboot

+1
0
-1
Imagen de Death_Doc
+1
0
-1

gracias por la respuesta! ademas increiblemente rapido. lo probare lo antes posible y comento como me fue. Ahora mismo estoy haciendo pruebas en una maquina virtual que si me detecta la tarjeta sin problema a traves de NAT y de paso voy mirando ayudas en internet. todavia estoy muy verde en esto.

+1
0
-1
Imagen de Layo
+1
0
-1

buenas tardes, soy nuevo en Ubuntu..Si se supone q no tengo salida a internet como voy a bajar el parche con el comando WGET..? hay alguna manera de descargarlo y posteriormente instalarlos?

Gracias1

+1
0
-1