Bluetooth en ubuntu 11.10

Imagen de KDL
KDL
0 puntos

Hola a todos buenas noches.

Tengo un portátil Sony Vaio VPCCB3C5E con Windows 7 Home Premium y Ubuntu 11.10 Oneiric Ocelot ambos de 64 bits conviviendo sin problemas. El portátil tiene una tarjeta bluetooth interna atheros 3012 que me da algunos problemillas en Ubuntu.

El caso es que cuando arranco el ordenador si selecciono Ubuntu el bluetooth no me funciona, no me detecta dispositivos (ni teléfonos, no ratón, ....) y aunque tanto blueman, como gnome no muestran ningún problema en el funcionamiento del bluetooth, este no detecta nada, como si estuviese dormido.

Si arranco con Windows no hay problema, el bluetooth funciona correctamente y aquí viene lo curioso, si reinicio (no apagar, reiniciar) y arranco Ubuntu entonces si detecta el ratón y los demás dispositivos.

En fin que el bluetooth funciona en ubuntu cuando previamente arranco windows y reinicio

A ver si alguien puede ayudarme que estoy intentando migrarme a ubuntu y esto me tiene un poco parado.

~$ sudo hciconfig hci0 -a
hci0: Type: BR/EDR Bus: USB
BD Address: 94:39:E5:AF:99:CE ACL MTU: 1022:8 SCO MTU: 183:5
UP RUNNING PSCAN ISCAN
RX bytes:3896 acl:0 sco:0 events:161 errors:0
TX bytes:4365 acl:0 sco:0 commands:156 errors:0
Features: 0xff 0xfe 0x0d 0xfe 0xd8 0x7f 0x7b 0x87
Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
Link policy: RSWITCH HOLD SNIFF
Link mode: SLAVE ACCEPT
Name: 'Portatil'
Class: 0x5a0100
Service Classes: Networking, Capturing, Object Transfer, Telephony
Device Class: Computer, Uncategorized
HCI Version: 3.0 (0x5) Revision: 0x102
LMP Version: 4.0 (0x6) Subversion: 0x1
Manufacturer: Atheros Communications, Inc. (69)

Imagen de furtaxi
+1
0
-1

He encontrado ésto:
http://www.ubuntu-es.org/node/60216
Haz un
sudo hciconfig
Para ver si lo detecta.

Con

man hciconf,

tienes más opciones, a ver si alguna te lo activa.

Y, aunque es información algo antigua,
http://www.ubuntu-es.org/node/131410

sudo /etc/init.d/bluetooth start

Para iniciar el servicio.

Es muy posible que su activación dependa de algún programa sólo para Windows, por lo que si está en OFF cuando inicia Ubuntu, no lo reconoce. Si lo dejas en ON, ya si se detecta.

Si con éstas soluciones, u otras que encuentres, consigues activarlo, podrías poner el comando adecuado en una combinación de teclas, o añadirlo a "programas al inicio".

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de KDL
+1
0
-1

Gracias por tu pronta respuesta.

~sudo /etc/init.d/bluetooth status
* bluetooth is running

~$ sudo hciconfig hci0 -a
hci0: Type: BR/EDR Bus: USB
BD Address: 94:39:E5:AF:99:CE ACL MTU: 1022:8 SCO MTU: 183:5
UP RUNNING PSCAN ISCAN
RX bytes:1549 acl:0 sco:0 events:57 errors:0
TX bytes:1463 acl:0 sco:0 commands:57 errors:0
Features: 0xff 0xfe 0x0d 0xfe 0xd8 0x7f 0x7b 0x87
Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
Link policy: RSWITCH HOLD SNIFF
Link mode: SLAVE ACCEPT
Name: 'Portatil'
Class: 0x5a0100
Service Classes: Networking, Capturing, Object Transfer, Telephony
Device Class: Computer, Uncategorized
HCI Version: 3.0 (0x5) Revision: 0x102
LMP Version: 4.0 (0x6) Subversion: 0x1
Manufacturer: Atheros Communications, Inc. (69)

El adaptador está detectado e inicializado pero por alguna razón Ubuntu no llega a levantarlo, le hafo un "sudo hciconfig hci0 up" pero nada ni se inmuta, no detecta ningún dispositivo.

+1
0
-1
Imagen de fromanv
+1
0
-1

Me pasa exactamente lo mismo que a ti. Hace poco tenia windows 7 y ubuntu 11.10 en particiones diferentes y en ubuntu el bluetooth no me funcionaba a menos que reiniciará windows y entrará en ubuntu. Pensé que windows me daba el error por lo que lo elimine y deje solo ubuntu como sistema operativo. El resultado es el mismo o peor incluso ya que ahora no hay forma activarlo. Si encuentras alguna solución ruego compartirla.

Gracias

+1
0
-1
Imagen de IPAD
+1
0
-1

Que tal compañeros, solo quiero decirles que tengo una HP 420 en la cual tengo el windows7 ultimate y el ubuntu 11.10
Mi problema es que el bluethoo no funciona, no encuentra dispositivos y mi telefono no encuentra el bluethoo de ubuntu pasa hasta 20 minutos sin encontrar dispositivos quisiera saber que puedo hacer al respecto para que el bluethoo me funcione.
Gracias, espero pronta respuesta.

+1
0
-1
Imagen de IPAD
+1
0
-1

Que tal compañeros, solo quiero decirles que tengo una HP 420 en la cual tengo el windows7 ultimate y el ubuntu 11.10
Mi problema es que el bluethoo no funciona, no encuentra dispositivos y mi telefono no encuentra el bluethoo de ubuntu pasa hasta 20 minutos sin encontrar dispositivos quisiera saber que puedo hacer al respecto para que el bluethoo me funcione.
Gracias, espero pronta respuesta.

+1
0
-1
Imagen de Norber_OK
+1
0
-1

A mi mujer le instalé ubuntu 11.04 en su portátil y el bluetooth unas veces le funcionaba y otras no.
Al final lo que funcionó fue añadir a /etc/rc.local la siguiente línea:

hciconfig hci0 up

Cabe decir además de lo anterior, que para que funcione la navegación por las carpetas de los dispositivos bluetooth hay que instalar el paquete de compartición de archivos de gnome:

sudo apt-get install gnome-user-share

Y luego no está de más elegir bien las opciones al hacer click en el icono del bluetooth y desde ahí en preferencias -> compartir archivos.

Espero que sirva.
Saludos.

+1
0
-1
Imagen de Coco.conejo
+1
0
-1

A mi me dio resultado esta solucion! http://www.ubuntu-es.org/node/179623

+1
0
-1

"Pero no moriré, pues soy eterno;

y soy como los loros, que remudan

su plumaje, que cambian con los siglos

y prolongan su vida en los milenios."

Imagen de bean
+1
0
-1

Ubuntu, con Unity; y Olivia 15 Linux Mint con Mate, reconocen de inmediato mis auriculares Creative WP 450 Headset, vía Bluetooth - incluso la doble vía telefónica - con adaptador Kensington diminuto vía USB.
Voy a probar en un rato más la conectividad con un teclado inalámbrico del Mac Mini desde esas buenas distro.
Saludos.

+1
0
-1
Imagen de Odraude66
+1
0
-1

Buenas, tengo una laptop vaio VPCCB2M y llevo varios dias intentando activar el bluetooth de la laptop.
Me he descargado el Blueman pero no activa el bluetooth y tampoco por configuracion del sistema lo logro levantar. he probado el codigo que pusieron aqui en este foro y me suelta algo distinto. aqui les dejo lo que me arrojo el terminal:
sudo hciconfig hci -a
hci0: Type: BR/EDR Bus: USB
BD Address: CC:AF:78:BA:18:96 ACL MTU: 1022:8 SCO MTU: 121:3
UP RUNNING
RX bytes:1427 acl:0 sco:0 events:58 errors:0
TX bytes:954 acl:0 sco:0 commands:55 errors:0
Features: 0xff 0xfe 0x0d 0xfe 0x98 0x7f 0x79 0x87
Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
Link policy: RSWITCH HOLD SNIFF
Link mode: SLAVE ACCEPT
Name: 'Azure:Feb 20 2012,03:23:11'
Class: 0x000000
Service Classes: Unspecified
Device Class: Miscellaneous,
HCI Version: 3.0 (0x5) Revision: 0x9999
LMP Version: 3.0 (0x5) Subversion: 0x9999
Manufacturer: Atheros Communications, Inc. (69)

Por favor si tienen alguna solución a este problema respondan ;)
Por Cierto tengo instalado el ubuntu 13.04

+1
0
-1