[Solucionado]70GB perdidos en disco duro!!

Imagen de jpedroapa
0 puntos

Hola a todos, es la primera vez que posteo algo y espero que este sea el lugar adecuado para hacerlo. El foro me ha sido útil muchas veces, o sea que aprovecho para dar las gracias.

El caso es que tenía xp y ubuntu 10.04 funcionando perfectamente hasta que modifiqué el tamaño de las particiones desde xp con partition magic, momento en que ubuntu comenzó a hacer cosas raras: tardaba mucho en iniciarse y en cerrarse con mucha actividad del disco y daba mensajes de error sobre los controladores del mismo.
El caso es que llegó un momento en que no arrancaba el grub y no podía acceder a ninguno de los dos sistemas.
Intenté recuperarlo haciendo una nueva instalación de ubuntu 10.04 que no funcionó al dar error de disco duro durante la misma. Al final reinstalé con xp eliminando todas las particiones anteriores, pero me encontré con la sorpresa de que habían desaparecido 70 GB del disco (un western digital de 1TB que tiene 3 meses), instalé ubuntu 11.10 sobre xp y seguía el problema. El último movimiento a sido hacer una instalación nueva de ubuntu 11.10 como único sistema operativo usando todo el disco, pero la cosa sigue igual.

Gparted muestra dos particiones de 929.51y 2 GB, mientras que el volumen que muestra la utilidad de discos es de 998GB (se perdieron 2GB en el camino?) Os adjuntaría un pantallazo pero no se cómo hacerlo..

¿Alguien puede ayudar?

Imagen de Scorpyo82
+1
0
-1

El caso es que tenía xp y ubuntu 10.04 funcionando perfectamente hasta que modifiqué el tamaño de las particiones desde xp con partition magic

Deberías haber usado un live CD de linux con Gparted o usar Gparted-livecd

Abre una terminal y pon:

sudo fdisk -l

Y pega aquí lo que te sale.

Un saludo.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de jpedroapa
+1
0
-1

Gracias Scorpyo82, me lo apunto para la próxima. Esto es lo que devuelve fdisk

Disco /dev/sda: 1000.2 GB, 1000203804160 bytes
255 cabezas, 63 sectores/pista, 121601 cilindros, 1953523055 sectores en total
Unidades = sectores de 1 * 512 = 512 bytes
Tamaño de sector (lógico / físico): 512 bytes / 4096 bytes
Tamaño E/S (mínimo/óptimo): 4096 bytes / 4096 bytes
Identificador del disco: 0x000f0f34

Dispositivo Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 2048 1949331455 974664704 83 Linux
/dev/sda2 1949333502 1953521663 2094081 5 Extendida
La partición 2 no se inició en el limite físico del sector
/dev/sda5 1949333504 1953521663 2094080 82 Linux swap / Solaris

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Según fdisk te reconoce el espacio que tienes en el disco

Si quieres mirar como está repartido has:

df -h

Y te mostrará cuanto tienes asignado y ocupado en cada partición, exepto en la swap que no te lo muestra, pero calculo que será 1 Gb

Mira y me cuentas

PD: Ten en cuenta, que los discos lo venden mostrando capacidad decimal, cuando en realidad, la equivalencia de un giga son 1024 megas y no 1000 megas.
Por esa regla de tres tu disco duro no debe de tener más de 976,5 Gb reales.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de jpedroapa
+1
0
-1

Esta es la salida de df -h

S.ficheros Tam. Usado Disp. % Uso Montado en
/dev/sda1 915G 3,1G 866G 1% /
udev 1000M 4,0K 1000M 1% /dev
tmpfs 403M 792K 402M 1% /run
none 5,0M 0 5,0M 0% /run/lock
none 1007M 1,3M 1006M 1% /run/shm

No me cuadran los números: 915GB+1000MB+1007MB+403M=917,35GB todavía faltan 14.16GB para llegar a los 931.51 que aparecen en gparted.

Según gparted la partición de swap es de 2 GB y el tamaño de /dev/sda de 931.51GB, aún con el tema de la capacidad decimal faltarían mas de 40GB, ¿tú que piensas?

Gracias

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Por favor, cuando pegues código, márcalo como tal, para que cueste menos trabajo leerlo:

Puede que tengas espacio sin particionar:
La verdad, estoy mirando sobre el tema porque estoy liado con los tamaños....

Tampoco lo comprendo, ¿será que hay espacio sin particionar?

Un saludo

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de jpedroapa
+1
0
-1

ok lo marco en negrita la próxima vez. No creo que haya espacio sin particionar sino en el gparted se vería no?
Sabes como puedo hacer para subir un pantallazo? Creo que viendo lo que muestran gparted y la herramienta de discos te harías una idea mejor. La verdad es que yo tampoco entiendo qué pasa

Gracias

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Huy, mucha gente sube imagenes a los servers.... pero no se cuales son, aunque googleando seguro que hay mas de uno.

Por otro lado no es el hecho de que esté en negrita, es con el botón de "cod" Código.

Esque no es lo mismo leer:

S.ficheros         Bloques de 1K   Usado    Dispon Uso% Montado en
/dev/sda5             17300888   5603204  10818836  35% /
none                   1982632       320   1982312   1% /dev
none                   1989252       224   1989028   1% /dev/shm
none                   1989252       292   1988960   1% /var/run
none                   1989252         0   1989252   0% /var/lock
none                   1989252         0   1989252   0% /lib/init/rw
/dev/sda9            304997656 241661960  47842628  84% /home

que leerlo así:

S.ficheros Bloques de 1K Usado Dispon Uso% Montado en
/dev/sda5 17300888 5603204 10818836 35% /
none 1982632 320 1982312 1% /dev
none 1989252 224 1989028 1% /dev/shm
none 1989252 292 1988960 1% /var/run
none 1989252 0 1989252 0% /var/lock
none 1989252 0 1989252 0% /lib/init/rw
/dev/sda9 304997656 241661960 47842628 84% /home

Vamos, que no es por capricho....

Un saludete a ver si puedes subir la imagen a algún sitio.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de jpedroapa
+1
0
-1

aaaaaaaaah vale, ya lo sé para la próxima. He subido el pantallazo aquí

http://www.subirimagenes.com/imagen-pantallazodel20120-7477311.html

a ver si te sirve de algo....

Gracias

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Yo creo que está todo bién, porque te pongo mi caso.
Yo tengo un disco de 500 Gb
Y según gparted el tamaño total es de:
465.76 Gb
Si lo multiplicas por dos, da tu capacidad... exactamente me sale a mí 931,52 Gb

Así que supongo que será el tamaño que se pierde al crear el sistema de archivos, igual que pasa con Fat y con Ntfs...

El caso es que se junta con que el tamaño real del disco no es en decimal y parece que falta espacio, pero no falta.

Es lo que pienso.

Hay tienes el mío:
http://www.subirimagenes.com/imagen-pantallazo-7477379.html

Un saludo.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de jpedroapa
+1
0
-1

Vaya parece demasiada casualidad como para que no sea así... pero aunque fuera como dices esto me tiene mosca ¿estará el disco dañado?

http://www.subirimagenes.com/imagen-pantallazodel20120-7478984.html

y una cosa que me llama la atención del pantallazo que has subido es que dejas 1mb entre particiones... si no es mucho preguntar ¿para qué? ¿es mejor hacerlo así?

Gracias

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Ese espacio me lo hacen automáticamente los instaladores... y aunque lo quite, me vuelven a salir, será como un margen de seguridad para seperar las particiones...

Por otro lado, lo de los sectores erroneos es cuestión de estar pendiente de vez en cuando.

Si sube mucho es malo, significa que el disco duro está muriendo.

Como dato te diré, que nada más comprarme el portatil a los dos meses ya tenía un sector defectuoso, pero según me dijeron los de WD, no importa mientras no aparezcan muchos, aunque el dísco sea nuevo.

Y esos dos sectores que te aparecen a ti, aún no se consideran erróneos, el disco le da una especie de oportunidad, si vuelve a fallar al leer o escribir en uno de esos sectores, será entonces cuando lo considere como sector defectuoso y quedarán menos secotres pendientes de revisión.

Por eso no creo que te tengas que preocupar, pero sí echarle un ojo de vez en cuando, aunque supuestamente el sistema te avisará cuando el disco empiece a fallar.

Un saludete.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de jpedroapa
+1
0
-1

Bueno pues ahora a instalar xp de nuevo y otra instalacion de ubuntu después para dejarlo todo arregladito. Si luego necesito modificar las particiones usaré un live de ubuntu. Muchísimas gracias por todo, he aprendido un montón.

Salud!!

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

De nada, si consideras que el hilo está solucionado añade "Solucionado" al título.

Un saludo.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de jpedroapa
+1
0
-1

Pues mi gozo en un pozo.... al intentar instalar xp salió una pantalla azul de error de disco duro. Desde el live de ubuntu gparted dice que la partición (única) de 931GB está "misaligned" en 512bytes. Luego de formatear todo el disco a ntfs desde un live de xp e podido instalar windows, la sorpresa ha venido cuando e intentado instalar ubuntu, ya que el instalador no me da la opción de instalar ubuntu junto con windows, sólo me da dos opciones: sustituir windows y usar todo el disco ó gestionar las particiones de forma manual.
En gparted aparece la recomendación de, sobre windows, usar chkdsk y luego redimensionar el disco con "ntfs resize". Estoy con la segunda pasada de chkdsk, si no funciona intentaré particionar con partition magic e instalar ubuntu en esas particiones (no puedo usar el particionador del instalador ya que no me da opción de modificar el tamaño de la partición existente para crear otras nuevas, sólo eliminarla ó formatearla).

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Solo eliminarla o formatearla.... eso es porque el disco no está informando bien de su tamaño.

Hazle un chkdsk (en windows eliges scanear el disco y reparar errorres, te pedirá reiniciar)
Tras el reinicio hará el escaneo y luego intenta de nuevo.

Creo haberme topado una vez con ese problema y era algo de eso.

Un saludo.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de jpedroapa
+1
0
-1

Bueno pues no iban por ahí los tiros. Resulta que los discos Western Digital de gran capacidad tienen un tipo de formato que no es compatible con xp, a menos que se ejecute un programa que se descarga desde su web que "alinea" las particiones virtuales que xp construye en el disco con la superfice real del disco.

Después de dar mil vueltas con cds live de linux y windows la cosa se solucionó así: pasé una herramienta de comprobación y reparación de disco específica de Western Digital (Data Lifeguar Diagnostic) que encontré en un disco de utilidades muy completo (Hiren's Boot), aunque también se puede descargar desde su página. Este programa detectó y solucionó "23 problemas" en el disco. Luego formateé desde el cd live de ubuntu (el cd de instalación de xp seguía sin reconocer el disco) el disco completo a ntfs, después instalé xp (manteniendo la estructura de datos porque imagino que si hubiera formateado en ese momento hubiera vuelto a desalinear la partición) y desde la instalación limpia ejecuté el software de Western Digital WD Align. Una vez hecho esto instalé ubuntu 11.10 junto con windows (ahora sí que me daba la opción) y, por fin, pude ver desde la herramienta de gestión de discos el mensaje de "el disco está sano" POR FINNNNNN.

Según WD este problema no se presenta con SOs nuevos que ya tienen soporte para este tipo de disco duro (win7, vista, etc... y ubuntu desde la versión 10.04).
Ahora sólo me queda instalar el Assassin's Creed y reventalooooooooooooooo que es para lo único que quería tener el güindowssssssss

Muchas gracias por tu ayuda ¡Hasta otra!

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Fenomenal explicación, enhorabuena.

Muchas gracias por compartirlo, mi disco WD y yo seguramente te lo agredeceremos en un futuro..... jejeje

Un saludo.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.