Como activar lector de tarjetas SD en un Pavilion DV5 1022la

Imagen de alvaro_feria
0 puntos

Hola,

Quisiera saber como puedo activar el lector de memorias en un HP Pavilion dv5 1022la ya que al insertar este tipo de memorias no las reconoce. Tengo instalado UBUNTU 10,04 LTS y he intentado lo que se explica en la web pero no he tenido suerte.
De antemano gracias por su colaboracion.

Les dejo mi lsusb y mi lspci por si sirve de ayuda

...$ sudo lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge
00:01.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (int gfx)
00:04.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 0)
00:05.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1)
00:06.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 2)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3a)
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] Mobile K10 [Turion X2, Athlon X2, Sempron] HyperTransport Configuration (rev 40)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 11h [Turion X2, Athlon X2, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Mobile K10 [Turion X2, Athlon X2, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Mobile K10 [Turion X2, Athlon X2, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Mobile K10 [Turion X2, Athlon X2, Sempron] Link Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics]
01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller
08:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)

...$ lsusb
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 138a:0001 DigitalPersona, Inc Fingeprint Reader
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 03f0:171d Hewlett-Packard Wireless (Bluetooth + WLAN) Interface [Integrated Module]
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0bda:0158 Realtek Semiconductor Corp. Mass Storage Device
Bus 001 Device 002: ID 064e:c107 Suyin Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Al parecer es este Bus 001 Device 003: ID 0bda:0158 Realtek Semiconductor Corp. Mass Storage Device

Saludos!!

Imagen de alvaro_feria
+1
0
-1

Hola.

Olvidé comentar que descargué el driver de la pagina oficial pero no me permite instalarlo, anexo la secuencia:
...:~/rts_pstor$ sudo make
sed "s/RTSX_MK_TIME/`date +%y.%m.%d.%H.%M`/" timestamp.in > timestamp.h
cp -f ./define.release ./define.h
make -C /lib/modules/2.6.32-38-generic-pae/build/ SUBDIRS= modules
make[1]: se ingresa al directorio «/usr/src/linux-headers-2.6.32-38-generic-pae»
CHK include/linux/version.h
CHK include/linux/utsrelease.h
SYMLINK include/asm -> include/asm-x86
make[2]: *** No hay ninguna regla para construir el objetivo «kernel/bounds.c», necesario para «kernel/bounds.s». Alto.
make[1]: *** [prepare0] Error 2
make[1]: se sale del directorio «/usr/src/linux-headers-2.6.32-38-generic-pae»
make: *** [default] Error 2

Gracias!!

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

¿crees que te van a contestar más rápido ahí?
¿sabes leer? en el mismo foro hay un apartado que dice que este foro sólo esta reservado para publicar tutoriales y guías, NO dudas.

y tampoco puedes preguntar en los tutoriales, los comentarios solo se hacen para mejorar los tutoriales.

Por favor, lee bien y publica las preguntas en el lugar correspondiente. Gracias.

Tu hilo ha sido movido.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de alvaro_feria
+1
0
-1

Jose Luis,

No se quien eres pero te falta tacto para tratar a la gente. hay mil y una maneras para expresar las cosas y no se porque los moderadores o las personas que llevan un poco mas de tiempo en esto escogen el peor camino.

¿crees que te van a contestar más rápido ahí?
No, no decidí publicarlo aquí porque me fuesen a contestar más rápido sino porque me parece que el activar este dispositivo es más un truco de configuración que otra cosa.

¿sabes leer?
José esta pregunta sobra y mide la intención de tu respuesta, no se que quieres demostrar, que eres el mas pilo, que yo soy un imbécil, no se, pero me parece una respuesta mal intencionada desde el principio.
Si me equivoqué ?orque no he leído las normas en su totalidad pues que me lleven preso, aunque creo que no soy el único a nivel mundial que lo ha hecho, ya que no todos los que entramos aquí somos programadores simplemente queremos encontrar una solución a un problema especifico y de paso aprender algo mas de este hermoso sistema operativo, lamentablemente llevados por la premura de solucionar nuestro problema omitimos leer las normas en su totalidad y nos vamos al buscador de una. Como te dije antes hay mil y una formas de decir las cosas y los moderadores siempre escogen la peor, con palabras denigrantes, sarcásticas, ofensivas, o preguntas como las tuyas que llevan su toque de sobrades, etc.
Pido disculpas a todas las personas de este foro por no haber leído en la totalidad las normas del foro, espero que comprendan que soy un humano que comete errores y no una maquina casi perfecta como algunas personas...

....como Platon, Aristoteles, Eintein, etc.

saludos!!

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Digo, si te fijas, a nadie nos pagan para eso, simplemente lee las normas y punto.

Tienes todo el tiempo del mundo para hacer una publicación adecuada, ¿Estas en un entorno de producción y tienes problemas con el Sistema de tal manera que interfiere con tu trabajo? es tu problema, no el de nadie más.

Pero si quieres apoyo, soporte, entonces pon de tu parte. Eso es todo lo que he dicho.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de alvaro_feria
+1
0
-1

Jose,

Te entiendo y no volverá a suceder.
Simplemente siento un tono hostil de parte de los moderadores en la mayoría de los casos y me parece que la comunidad debería ser un poco mas amable sobretodo con personas que tenemos algunas limitaciones intelectuales con respecto a estos temas. Es bastante triste sentirse agredido en un lugar de recibir advertencias mas amables, eso es todo.

Estoy infinitamente agradecido con la comunidad que me ha hecho tomarle un profundo aprecio a este lugar y me ha ayudado a solucionar, de manera casi inmediata, los problemas que se me han presentado con mi sistema o simplemente con dudas para enriquecer mis conocimiento, de verdad mil gracias.

Un caluroso abrazo desde Barranquilla Colombia.

+1
0
-1
Imagen de alvaro_feria
+1
0
-1

les comento que estuve investigando en la siguiente pagina:
http://www.cs.sfu.ca/~ggbaker/personal/cf-linux

Y hay una parte que me llamó la atención.
hay un titulo en negrita, Checking it out. en la que dice:
Si usted hechcha un vistazo a traves de /proc/bus/usb/devices, usted verá......
el problema es que en bus no hay carpeta usb/devices

Hay otra parte que me llamó la atención un poco mas abajo en el mismo Checking it out. en la que dice:
"Para chequear tus dispositivos SCSI, ejecute el comando sg_scan -i . usted verá algo como esto:

/dev/sg0: scsi0 channel=0 id=0 lun=0 [em] type=0
eUSB Compact Flash 5.09 [wide=0 sync=0 cmdq=0 sftre=0 pq=0x0] "

Pero al colocar: sg_scan -i
me sale lo siguiente:
...~$ sg_scan -i
sg_scan: Error opening /dev/sg0 : Permission denied
/dev/sg1: scsi3 channel=0 id=0 lun=0 [em]
HL-DT-ST DVDRAM GSA-T50L SC04 [rmb=1 cmdq=0 pqual=0 pdev=0x5]
sg_scan: Error opening /dev/sg2 : Permission denied

Como sale esto sg_scan: Error opening /dev/sg2 : Permission denied
decidí escribir sudo sg_scan -i y me arroja esto:

...~$ sudo sg_scan -i
/dev/sg0: scsi2 channel=0 id=0 lun=0 [em]
ATA Hitachi HTS54252 BBFO [rmb=0 cmdq=0 pqual=0 pdev=0x0]
/dev/sg1: scsi3 channel=0 id=0 lun=0 [em]
HL-DT-ST DVDRAM GSA-T50L SC04 [rmb=1 cmdq=0 pqual=0 pdev=0x5]
/dev/sg2: scsi8 channel=0 id=0 lun=0 [em]
Generic- Multi-Card 1.00 [rmb=1 cmdq=0 pqual=0 pdev=0x0]

Supongo que esta Generic- Multi-Card 1.00 [rmb=1 cmdq=0 pqual=0 pdev=0x0]
es el dispositivo pero por algún motivo esta bloqueado.

Luego dice:
Esto indica que el dispositivo “raw” SCSI asociado con su lector es /dev/sg0. Esta ruta si existe pero tiene una X en la parte superior del icono.
En el mismo parrafo de arriba dice: También se puede confirmar que el controlador está funcionando mirando el archivo /proc/scsi/scsi pero la segunda carpeta scsi no existe.

mas adelante dice que ejecute sg_map
y me arrojo
Error opening /dev/sg0 : Permission denied
Error opening /dev/sg2 : Permission denied
Error opening /dev/sda : Permission denied
Error opening /dev/sdb : Permission denied
/dev/sg0 some error
/dev/sg1 /dev/scd0

Asi que escribí
~$ sudo sg_map
y me arrojó
/dev/sg0 /dev/sda
/dev/sg1 /dev/scd0
/dev/sg2 /dev/sdb

Pero lo mas preocupante es que encontre otro titulo Multi Card Readers (creo que es la que tengo instalada) en el que se explica que busque en la ruta /etc/modules.conf pero el archivo modules.conf no existe en esa ruta.

Despues dice que ejecutemos para una solución temporal
echo 8 > /sys/module/scsi_mod/parameters/max_luns

El dispositivo aun debe aparecer en su /proc/bus/usb/devices como se describe arriba.
El problema al igual que arriba es que en bus no hay carpeta usb/devices

Espero que sirva de algo esta información...

+1
0
-1
Imagen de alvaro_feria
+1
0
-1

Hola a todos,

Instalé de cero el 11.10 y listo!!!

Gracias por la ayuda!

Saludos

+1
0
-1