[solucionado, por ahora] Problemas con iptables?

Imagen de Lustorgan
0 puntos

Hola
Tengo una maquina con dos tarjetas de red conectadas a distintas redes.
En el caso del ubuntu las direcciones son 192.168.1.4 y 192.168.2.4 la primera sale a internet y la segunda es la red de casa donde tengo la impresora.

El caso es que parece que no puedo acceder a dicha segunda red. No funciona el ping ni por el navegador acedo a la configuración de la impresora.
Estoy seguro que el problema no es hard ni de cableado ya que un equipo virtual con Windows usa ambas redes y sí accede sin problemas

CReo que viene de algo que he visto con iptables:
target prot opt source destination
ACCEPT tcp -- 192.168.1.4 192.168.2.1 tcp dpt:domain
ACCEPT udp -- 192.168.1.4 192.168.2.1 udp dpt:domain

Me da que aquí debería ser 192.168.2.4 y no 192.168.1.4 pero no sé como cambiarlo. ¿Alguien me puede ayudar?

Imagen de Gabriel_M
+1
0
-1

1- Configura la tarjeta que se comunica a internet, en forma manual con:
address 192.168.1.4
gateway 192.168.1.x (la del router)
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255

2- Configura la tarjeta que se comunica a la red interna, en forma manual con:
address 192.168.2.4
sin gateway
netmask 255.255.255.0
network 192.168.2.0
broadcast 192.168.2.255

Respecto de iptables, si lo has configurado, postea el script, si no lo has configurado no esta activo.

+1
0
-1
Imagen de Lustorgan
+1
0
-1

He cambiado para tratar de abrir unos puertos segun encontré por ahí los aprametroa para que en un puerto concreto acepte todas las conexioones, pero no he hecho nada más.

+1
0
-1

------------------------------------------

Imagen de Firecold
+1
0
-1

Bueno lo que tienes que hacer es editar las interfaces de red, eso lo puedes hacer desde consola tecleando:
sudo gedit /etc/network/interfaces, que es el archivo de configuracion para tus tarjetas de red tanto interna como externa, tal como te dijo Gabriel_M, dejandolo mas o menos asi:

1- Configura la tarjeta que se comunica a internet, en forma manual con: Ejemplo lo adaptas segun tu configuracion:

auto eth0
iface eth0 inet static
address 192.168.1.4
gateway 192.168.1.x (la del router)
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255

2- Configura la tarjeta que se comunica a la red interna, en forma manual con:
auto eth1
iface eth1 inet static
address 192.168.2.4
sin gateway
netmask 255.255.255.0
network 192.168.2.0
broadcast 192.168.2.255

Y como dice Gabriel_M si no tienes bien configuradas tus interfaces de red, no creo que esten funcionando tus reglas de iptables, postealas talvez se te puede echar una manita a tu problema. Saludos

+1
0
-1
Imagen de Lustorgan
+1
0
-1

El caso es que el otro día al reinciar tras instalar las actualizaciones volvía a funcionar todo.
Sinceramente debo reconocer que desconozco la causa y la solución, pero de momento funciona y con eso me voy a conformar.

+1
0
-1

------------------------------------------