[Solucionado] Grave problema al intentar utilizar virtualbox

Imagen de ceso
0 puntos

Primero que nada un saludo a todos.
Bueno, vengo a plantear un problema que tengo al intentar utilizar virtualbox.
Bueno primero les digo, la maquina que tiene ubuntu, tiene la version 10.04 LTS, las maquina me la dieron en la UTU atraves del plan ceibal, y ya menciono que no nos permiten formaterlas ¬¬ ademas estan conectadas a un servidor, de forma que si pasa X tiempo sin conectarse al mismo se bloquean.
Bueno empiezo con la descripcion del problema:

Primero que nada, este es el error que me tira:

http://i40.tinypic.com/24mx2z6.jpg

Despues, agarre y lo desinstale, y lo instale desde la terminal, pero ahora el problema es este:

http://i44.tinypic.com/iyfx9x.jpg

Despues probe solucionar ese problema con esto:

sudo apt-get install dkms y me dice que ya esta en su version más reciente.
sudo apt-get install virtualbox-ose-dkms y me sale lo mismo que el de arriba
probe reinstalar virtualbox con
sudo apt-get install --reinstall virtualbox y me dice "El paquete virtualbox no
está disponible, pero algún otro paquete hace referencia a él. Esto puede significar
que el paquete falta, está obsoleto o sólo se encuentra disponible desde alguna otra fuente
E: El paquete virtualbox no tiene candidato para su instalación"
y nada dio resultado.
Lo desinstale y probe instalando desde synaptic, pero al intentar entrar a el me sale este error:

http://i42.tinypic.com/osewat.jpg

y despues, cuando selecciono los paquetes del virtualbox y intento instalarlo sale lo siguiente:

http://i42.tinypic.com/27zx85t.jpg

Aviso también, NUNCA MODIFIQUE el source.list , porque nisiquiera se que es y no tengo conocimientos de el.

Despues al probar
sudo /etc/init.d/vboxdrv setup

me sale esto

* Stopping VirtualBox kernel modules [ OK ]
* Uninstalling old VirtualBox DKMS kernel modules [ OK ]
* Trying to register the VirtualBox kernel modules using DKMS
Error! Your kernel headers for kernel 2.6.32-21-generic cannot be found at
/lib/modules/2.6.32-21-generic/build or /lib/modules/2.6.32-21-generic/source.

* Failed, trying without DKMS
* Recompiling VirtualBox kernel modules
* Look at /var/log/vbox-install.log to find out what went wrong

Y ahi me quede, no encuentro aun solucion alguna, PORFAVOR, diganme como puedo arreglar esto, quiero usar virutal box T_T gracias de antemano.

Imagen de Jose Luis 1320
+1
0
-1

esas etiquetas de [code] y de [img] aqui no te sirven para nada y dificulta la lectura de tu problema.

Vamos en orden.

  1. Desinstala todo rastro de virtualbox.
  2. aptitude purge virtualbox virtualbox-ose virtualbox-ose-dkms
     
  3. Quizás no hayas hecho nada al archivo sources.list en /etc/apt/ pero habrás agregado otros repositorios extraños de otras maneras, o los de tu U lo hicieron, por eso Checa el contenido que hay en /etc/apt/sources.list.d/
  4. Para descartar que en realidad tu o los de tu U no hayan hecho nada al archivo sources.list, presiona Alt + F2 y escribe gksudo gedit /etc/apt/sources.list
  5. , te pedirá tu contraseña, escribela.

  6. Deberías tener algo como esto: http://pastebin.com/MFq4cah4, no te desorientes cuando leas cosas como amd64 o mx.archive.ubuntu.com, esas son variaciones del archivo sources.list de acuerdo a la arquitectura del sistema operativo y el país en donde vives.
  7. Borra lo que tengas en la carpeta mencionada y/o edita el sources.list y haz:
    sudo apt-get update
     
  8. Checa que tengas instalados los siguientes paquetes, lo puedes hacer desde Synaptic:
  • dkms
  • linux-headers-Versión de tu kernel actual*
  • En Ubuntu 10.04 esos paquetes no se instalan por default, en mi experiencia así fue, tal vez me equivoque.
  • * Para checar tu versión del kernel, lo haces de la siguiente manera:

    uname -r
    

    Habrán cosas que deberás hacer con privilegios de root, si no tienes la clave, entonces pideselas a los de tu U, diles que necesitas usar virtualbox y no necesitas esos repositorios raros como los que se ven en tus imágenes (esta: http://i42.tinypic.com/osewat.jpg, kondr.ic.cz), haber si te pueden ayudar, si te dicen que no, bueno, sabes que no necesitas sus computadoras.

    +1
    0
    -1

    "Yo sólo se que no se nada"
    -Sócrates, filósofo griego.
    -Normas del foro

    Imagen de ceso
    +1
    0
    -1

    Bueno, primero que nada, muchas gracias por tu respuesta, bueno, emm mira este es mi source.list

    # deb cdrom:[Ubuntu-Netbook 10.04 _Lucid Lynx_ - Release i386 (20100429.4)]/ lucid main restricted
    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    # newer versions of the distribution.

    deb http://archive.ubuntu.com/ubuntu lucid main restricted
    deb-src http://archive.ubuntu.com/ubuntu lucid main restricted

    ## Major bug fix updates produced after the final release of the
    ## distribution.
    deb http://archive.ubuntu.com/ubuntu lucid-updates main restricted
    deb-src http://archive.ubuntu.com/ubuntu lucid-updates main restricted

    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Ubuntu security team.
    deb http://archive.ubuntu.com/ubuntu lucid universe
    deb-src http://archive.ubuntu.com/ubuntu lucid universe
    deb http://archive.ubuntu.com/ubuntu lucid-updates universe
    deb-src http://archive.ubuntu.com/ubuntu lucid-updates universe

    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team, and may not be under a free licence. Please satisfy yourself as to
    ## your rights to use the software. Also, please note that software in
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    deb http://archive.ubuntu.com/ubuntu lucid multiverse
    deb-src http://archive.ubuntu.com/ubuntu lucid multiverse
    deb http://archive.ubuntu.com/ubuntu lucid-updates multiverse
    deb-src http://archive.ubuntu.com/ubuntu lucid-updates multiverse

    ## Uncomment the following two lines to add software from the 'backports'
    ## repository.
    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    # deb http://uy.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
    # deb-src http://uy.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse

    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    deb http://archive.canonical.com/ubuntu lucid partner
    # deb-src http://archive.canonical.com/ubuntu lucid partner

    deb http://archive.ubuntu.com/ubuntu lucid-security main restricted
    deb-src http://archive.ubuntu.com/ubuntu lucid-security main restricted
    deb http://archive.ubuntu.com/ubuntu lucid-security universe
    deb-src http://archive.ubuntu.com/ubuntu lucid-security universe
    deb http://archive.ubuntu.com/ubuntu lucid-security multiverse
    deb-src http://archive.ubuntu.com/ubuntu lucid-security multiverse
    deb http://kondr.ic.cz/deb lucid main
    deb http://kondr.ic.cz/deb lucid main
    deb http://kondr.ic.cz/deb lucid main
    deb http://kondr.ic.cz/deb lucid main

    Bueno, me tranque en el paso 5, con editar, te refieres a eliminar TODO el contenido del archivo source.list ? Gracias de antemano!!

    +1
    0
    -1
    Imagen de Jose Luis 1320
    +1
    0
    -1

    Te di un archivo de referencia, mi sources.list, el tuyo debe estar igual al mío. Es decir, que borres esto:

    deb http://kondr.ic.cz/deb lucid main
    deb http://kondr.ic.cz/deb lucid main
    deb http://kondr.ic.cz/deb lucid main
    deb http://kondr.ic.cz/deb lucid main
    

    Esos repositorios al parecer te estan ocasionando problemas, en tus imagenes lo ví y son lineas duplicadas.

    En cuanto al problema del repositorio de Launchpad, te dije que checaras el contenido de /etc/apt/sources.list.d/ (Es un directorio) borra los archivos que tengas ahí.

    Vas a instalar los kernel headers del kernel 2.6.32-21-generic.

    El paquete se llama linux-headers-2.6.32-21-generic, te va a instalar otro paquete que se llama linux-headers-2.6.32-21, es normal.

    +1
    0
    -1

    "Yo sólo se que no se nada"
    -Sócrates, filósofo griego.
    -Normas del foro

    Imagen de ceso
    +1
    0
    -1

    aa si, y en caso de editar, que es lo que tengo que editar? Osea que información debo remplazar por X nueva información? gracias de antemano!!!

    Edicion: Perdon por no editar mi primera respuesta, no habia visto dicha opcion.
    Emm, en synaptic recien mire lo de dkms, dkms si figuraba, pero mire en la termina la version de mi kernel que era "2.6.32-21-generic" puse lo que me dijistes en synaptic, y los paquetes del kernel (salieron 5) no estaban instalados.
    A y al teclear "sudo apt-get update" despues de todo el codigo que sale sale el mensaje
    "W: Error de GPG: http://ppa.launchpad.net lucid Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 9BDB3D89CE49EC21"

    +1
    0
    -1
    Imagen de berarma
    +1
    0
    -1

    Lo único que tenías que hacer para solucionar tu problema inicial era instalar el paquete linux-headers correspondiente a tu kernel. Todo lo demás es complicarte y posiblemente crear otros problemas.

    Es peligroso para un novato manipular esos archivos a mano, deberías estar haciéndolo desde el centro de software. Busca en el menú Orígenes del Software y elimina repositorios que no sean oficiales si crees que no son necesarios.

    +1
    0
    -1
    Imagen de ceso
    +1
    0
    -1

    Bueno, veamos
    ya edite el archivo source.list y elimine las lineas repetidas.
    Despues, respcto a entrrar a "/etc/apt/sources.list.d/" y eliminar los archivos contenidos dentro, bueno entre, hay 3 archivos:
    - "jd-team-jdownloaderlucid.list"
    - "jd-team-jdownloader-lucid.list.save"
    - "mozillateam-firefox-stable-lucid.list"

    NInguno de esos 3 archivos, los puedo borrar, selecciono apreto supr y no sucede nada, le doy click derecho, y no sale ningua opcion de eliminar, o mover a la papelera.
    Y al intentar sudo apt-get update, como mencione me sale este error
    "W: Error de GPG: http://ppa.launchpad.net lucid Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 9BDB3D89CE49EC21"

    Aun tengo problemas con virtualbox, sigo sin poder iniciar la mv.
    Y no, ya instale los paquetes esos del kernel, y igual sigo teniendo errores.
    Que es lo siguiente que puedo hacer?

    PD: la contraseña del root no es problema la tengo.

    +1
    0
    -1
    Imagen de Jose Luis 1320
    +1
    0
    -1

    a edite el archivo source.list y elimine las lineas repetidas.
    Despues, respcto a entrrar a "/etc/apt/sources.list.d/" y eliminar los archivos contenidos dentro, bueno entre, hay 3 archivos:
    - "jd-team-jdownloaderlucid.list"
    - "jd-team-jdownloader-lucid.list.save"
    - "mozillateam-firefox-stable-lucid.list"

    presiona Alt + F2 y escribe gksudo nautilus /etc/apt/sources.list.d/ te va a abrir una ventana de nautilus como root en esa ubicación.

    También tienes un modo más sencillo, no borrará esos archivos, en su lugar los dejará inoperables. Abre Orígenes del software, como el compañero Berama te dijo.

    Sistema> Administración> Orígenes del software.

    +1
    0
    -1

    "Yo sólo se que no se nada"
    -Sócrates, filósofo griego.
    -Normas del foro

    Imagen de berarma
    +1
    0
    -1

    Desinstala el virtualbox que tengas instalado e instala el de ubuntu. Los paquetes son virtualbox-ose y virtualbox-ose-dkms. Si te sale algún error en el proceso ponlo aquí.

    +1
    0
    -1
    Imagen de ceso
    +1
    0
    -1

    Bueno aver, ya instae virtualbox-ose y virtualbox-ose-dkms pero me dice que falta un achivo a instalar:
    virtualbox-ose-qt

    +1
    0
    -1
    Imagen de berarma
    +1
    0
    -1

    ¿Quién te dice eso? ¿Después de hacer qué? Especifica un poco más o es difícil ayudarte. Instalando virtualbox-ose se deberían haber instalado ya los paquetes necesarios. ¿Cómo lo has instalado?

    +1
    0
    -1
    Imagen de ceso
    +1
    0
    -1

    jaja, no esque en synaptic, cuando seleccione virtualbox-ose se me seleccionaron los 3 pero como solo dijistes 2 deseleccione el que no mencionastes xD , y lo de quien lo dice la terminal , sale que no se encontro noseque que se use sudo apt-get install virtualbox-ose-qt.

    Bueno, ya lo instale y ya funciona de maravilla, MIL GRACIASSSSS!!!
    Bueno, este problema en si ya ni se como se soluciono, jaja, se soluciono por editar el source.list? Porque instalar como acabo de hacer lo probe y tampoco dio resultados.

    Bueno, ya que estoy, para no hacer spam al abrir otro hilo les pregunto otra cosa.
    Mi version es 10.04 LTS como hago para actualizar a la version más reciente? vi que esta 11.10

    Bueno, despues lo del error del launchpad eso de pubkey noseque, lo solucione así, googleando me tope conque tenia que poner:

    "$gpg --keyserver keyserver.ubuntu.com --recv 9BDB3D89CE49EC21
    $gpg --export --armor 9BDB3D89CE49EC21 | sudo apt-key add - "

    Estando como usuario, no me permitia, me tiraba error apenas la primera linea, en cambio, escribi "su" me "logue" como root, volvi a escribir, bien me acepto, escribi la segundo y la acepto y ya esta, problema solucionado.

    Jajaa, en fin gracias por su ayuda, y antes de cerrar esto, me gustaria si podrian decirme como actualizar, y alfinal como fue que se termino reparando virtualbox xD!
    A y una boludes, el empathy, como hago para usarlo? Porque NUNCA, me conecta T_T y si no me sale el error "no se especificó ninguna razón"

    +1
    0
    -1
    Imagen de berarma
    +1
    0
    -1

    El archivo /etc/init.d/vboxdrv es de una versión de VirtualBox que no es de Ubuntu, alguien lo habría instalado previamente. Es un resto de una instalación manual. Puede que eso tenga que ver.

    Abre un tema por cada problema.

    +1
    0
    -1
    Imagen de Jose Luis 1320
    +1
    0
    -1

    Si ya está solucionado el tema, marcalo como solucionado, Edita el título de tu hilo, pestaña "Editar".

    para lo de Empathy, abre un tema nuevo, y para actualizar virtualbox, bueno como instalaste el OSE, ese va actualizar de acuerdo a los repositorios de Ubuntu.

    Para actualizar a Ubuntu 11.10, lo puedes hacer, pero ese ya es otro tema, pero te aconsejo a que esperes a la siguiente versión LTS que falta poco para actualizarse, unos dos meses como mucho, Se lanzará en Abril, pero es recomendable actualizar un mes después puesto que en ese tiempo se arreglan los errores naturales en un lanzamiento, será tu decisión. dudas? abre un nuevo tema.

    +1
    0
    -1

    "Yo sólo se que no se nada"
    -Sócrates, filósofo griego.
    -Normas del foro

    Imagen de berarma
    +1
    0
    -1

    Para actualizar a Ubuntu 11.10, lo puedes hacer, pero ese ya es otro tema, pero te aconsejo a que esperes a la siguiente versión LTS que falta poco para actualizarse, unos dos meses como mucho, Se lanzará en Abril, pero es recomendable actualizar un mes después puesto que en ese tiempo se arreglan los errores naturales en un lanzamiento, será tu decisión. dudas? abre un nuevo tema.

    Suscribo lo dicho, yo no me plantearía otra cosa para el poco tiempo que falta.

    +1
    0
    -1