(Solucionado) Imposible instalar Samba en Ubuntu 11.10

Imagen de darkween
0 puntos

Hola! Estoy haciendo ya hace 2 horas intentando instalar samba en mi ubuntu 11.10, siguiendo varios tutoriales, pero ninguno funciona...
Y el error principal es el siguiente:

dkwn@dkwn-laptop:~$ sudo apt-get install samba
Leyendo listas de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
El paquete samba no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente
Sin embargo, los siguientes paquetes lo reemplazan:
  samba-common-bin samba-common winbind

E: El paquete «samba» no tiene un candidato para la instalación

Mi ubuntu no reconoce ningun paquete llamado "Samba". sin embargo samba-common-bin samba-common si pude instalarlos, pero no puedo utilizarlo porque "samba" no esta presente.

Todo esto ocurre por querer compartir una carpeta en ubuntu (a ser leida posteriormente en windows xp mediante virtualbox)
luego de poner compartir salirme "Necesita instalar el servicio de compartición de redes Windows para poder compartir sus carpetas." al que le doy instalar... aparece

Falló la instalación del servicio de compartición
La instalación del servicio de compartición ha fallado. ¿Desea volverlo a intentar?

Pero sin resultado, por ello quise intentar instalar samba de forma manual, pero nada... :(

Podrían darme una mano por favor?
Muchas gracias desde ya!

Imagen de Gabriel_M
+1
+1
-1

Abre una terminal
Ejecuta en ella:

sudo su
nano etc/apt/sources.list

En el archivo que se abre, borra su contenido y pega este

deb http://archive.ubuntu.com/ubuntu oneiric main restricted
deb-src http://archive.ubuntu.com/ubuntu oneiric main restricted
deb http://archive.ubuntu.com/ubuntu oneiric-updates main restricted
deb-src http://archive.ubuntu.com/ubuntu oneiric-updates main restricted
deb http://archive.ubuntu.com/ubuntu oneiric universe
deb-src http://archive.ubuntu.com/ubuntu oneiric universe
deb http://archive.ubuntu.com/ubuntu oneiric-updates universe
deb-src http://archive.ubuntu.com/ubuntu oneiric-updates universe
deb http://archive.ubuntu.com/ubuntu oneiric multiverse
deb-src http://archive.ubuntu.com/ubuntu oneiric multiverse
deb http://archive.ubuntu.com/ubuntu oneiric-updates multiverse
deb-src http://archive.ubuntu.com/ubuntu oneiric-updates multiverse
deb http://archive.ubuntu.com/ubuntu oneiric-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu oneiric-backports main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu oneiric-security main restricted
deb-src http://archive.ubuntu.com/ubuntu oneiric-security main restricted
deb http://archive.ubuntu.com/ubuntu oneiric-security universe
deb-src http://archive.ubuntu.com/ubuntu oneiric-security universe
deb http://archive.ubuntu.com/ubuntu oneiric-security multiverse
deb-src http://archive.ubuntu.com/ubuntu oneiric-security multiverse
deb http://archive.canonical.com/ubuntu oneiric partner
deb-src http://archive.canonical.com/ubuntu oneiric partner
deb http://extras.ubuntu.com/ubuntu oneiric main
deb http://archive.ubuntu.com/ubuntu oneiric-proposed restricted main multiverse universe
deb-src http://extras.ubuntu.com/ubuntu oneiric main

Guarda el archivo
Cierra nano
Ejecuta en la misma terminal

apt-get update
apt-get upgrade
apt-get install samba samba-common-bin samba-common smbclient smbnetfs winbind
+1
+1
-1
Imagen de darkween
+1
0
-1

Finalmente pude hacerlo!
Muchisimas gracias por tu ayuda!

Al abrir el archivo, me llamó muchiiisimo la atención que este estaba vacío, no se que habré tocado anteriormente... pero al menos ya lo dejé con la lista de repositorios impresindibles de ubuntu!

+1
0
-1
Imagen de sisprotec
+1
-1
-1

Comparte todo el proceso pos amigo para todos gracias

+1
-1
-1
Imagen de aldobelus
+1
0
-1

Yo no pude. Iba siguiendo estas instrucciones y nano no me deja guardar el documento aunque le he cambiado los permisos (de momento, para guardarlo) a 777. Nada, me dice que no existe el directorio o el archivo y que no lo guarda. ¿Sabe alguien de qué va eso? Gracias por la posible respuesta

+1
0
-1
Imagen de sisprotec
+1
-1
-1

Al guardar no se puede reescribir el archivo
gracias por fa ayuda.....

+1
-1
-1
Imagen de sisprotec
+1
-1
-1

apt-get install -f

E: No se pudo abrir el fichero de bloqueo «/var/lib/dpkg/lock» - open (13: Permiso denegado)
E: No se encontró un archivo de réplica «/var/lib/dpkg/»
sisprotec@sisprotec:~$ sudo su
[sudo] password for sisprotec:
Sorry, try again.
[sudo] password for sisprotec:
root@sisprotec:/home/sisprotec# apt-get install -f
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
linux-headers-3.2.0-63-generic-pae junit linux-headers-3.2.0-31
linux-headers-3.2.0-29 linux-headers-3.2.0-61 linux-headers-3.2.0-63
linux-headers-3.2.0-64 linux-headers-3.2.0-64-generic-pae
linux-headers-3.2.0-29-generic-pae default-jdk
linux-headers-3.2.0-61-generic-pae linux-headers-3.2.0-31-generic-pae
libjsch-java openjdk-7-jre-lib
Utilice «apt-get autoremove» para eliminarlos.
Se instalarán los siguientes paquetes extras:
mysql-server-5.5
Paquetes sugeridos:
tinyca
Se actualizarán los siguientes paquetes:
mysql-server-5.5
1 actualizados, 0 se instalarán, 0 para eliminar y 207 no actualizados.
2 no instalados del todo o eliminados.
Necesito descargar 8.721 kB de archivos.
Se utilizarán 5.120 B de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? s
Des:1 http://pe.archive.ubuntu.com/ubuntu/ precise-updates/main mysql-server-5.5 i386 5.5.38-0ubuntu0.12.04.1 [8.721 kB]
Descargados 8.721 kB en 25seg. (338 kB/s)
dpkg: problemas de dependencias impiden la configuración de mysql-server-5.5:
mysql-server-5.5 depende de mysql-server-core-5.5 (= 5.5.37-0ubuntu0.12.04.1); sin embargo:
La versión de `mysql-server-core-5.5' en el sistema es 5.5.38-0ubuntu0.12.04.1.
dpkg: error al procesar mysql-server-5.5 (--configure):
problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de mysql-server:
mysql-server depende de mysql-server-5.5; sin embargo:
El paquete `mysql-server-5.5' no está configurado todavía.
dpkg: error al procesar mysql-server (--configure):
problemas de dependencias - se deja sin configurar
No se escribió un informe «apport» porque el mensaje de error indica que es un mensaje de error asociado a un fallo previo.
No se escribió un informe «apport» porque el mensaje de error indica que es un mensaje de error asociado a un fallo previo.
Se encontraron errores al procesar:
mysql-server-5.5
mysql-server
W: Duplicate sources.list entry http://download.virtualbox.org/virtualbox/debian/ precise/contrib i386 Packages (/var/lib/apt/lists/download.virtualbox.org_virtualbox_debian_dists_precise_contrib_binary-i386_Packages)
W: Tal vez quiera ejecutar «apt-get update» para corregir estos problemas
E: Sub-process /usr/bin/dpkg returned an error code (1)

+1
-1
-1