Se cierra la sesión solo

Imagen de christianmrtnz
0 puntos

Hola a todos, espero que puedan ayudarme con el siguiente problema que me lleva loco.

Tenía instalado Windows 7 y Ubuntu 11.10 en el mismo disco duro, en sus respectivas particiones y funcionando perfectamente. Como bien sabéis, hace unos 3 días salió la nueva versión de Ubuntu, la 12.04 (Precise Pangolin), y me dispuse a descargarla. Decidí realizar una instalación limpia, borrando el antiguo Ubuntu e instalando el nuevo, todo salió perfectamente. Y cuando ya tenía de nuevo instalados programas, dependencias, extras y todo a mi gusto, me pasa algo que jamás me había ocurrido; mientras estoy haciendo cualquier cosa, se cierra la sesión, perdiendo absolutamente todo lo que estaba haciendo. Pasa continuamente, en intervalos de tiempo no definidos, es decir, a veces pasa cada minuto, a veces cada hora, o a veces cada 10 horas (por poner unos ejemplos). Me ha ocurrido en diferentes casos:

  • Navegando en Chromium
  • Navegando en Firefox
  • Reproduciendo un vídeo mediante VLC
  • Escuchando música desde Clementine
  • Etcétera

De esto saco en blanco que el problema no reside en uno de estos programas, quizás sea de Compiz o Unity. Paso a informaros sobre mi ordenador y demás:

  • Procesador: Intel i7 960 (3.2 Ghz)
  • Memoria RAM: 12 GB DDR3
  • Disco Duro: 2 TB ATA
  • Tarjeta Gráfica: NVidia 9800 GT (1GB DDR3)
  • Versión de Kernel: 3.2.0-24 generic (x86_64)
  • Resolución: 1360x768 (en Ubuntu)
  • Sistemas Operativos instalados: Windows 7 (32 bits) y Ubuntu 12.04 (64 bits)
  • Drivers NVidia instalados (los típicos recomendados por el sistema tras instalar Ubuntu)
  • Ningún software de gran peso (estilo Blender, etc.) corriendo cuando se cerraba la sesión
  • Conectado al monitor mediante HDMI (con el S/PDIF realizado correctamente, o eso creo, funcionaba perfectamente en Ubuntu 11.10 y en Windows 7)

Espero que sea este el foro adecuado para exponer el problema, muchísimas gracias de antemano.

Imagen de mbadilla
+1
0
-1

Tengo exactamente el mismo problema

+1
0
-1
Imagen de sergi99
+1
0
-1

en Pychess, en el navegador, ...
cierra la sesión y pierdo los programas abiertos

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Por la aleatoriedad del problema, es muy probable que sea un problema con el servidor X, sin iniciar sesión gráfica (en la pantalla de acceso dale Ctrl +Alt + F1 o F2) abre el archivo .Xsession-errors;

less .Xsession-errors

Busca mensajes de error, que hagan referencia al sistema, no a los programas.

También abre el archivo X.org.0.log

less /var/log/Xorg.0.log

busca por mensajes que comienzen con (EE).

La consola es sensible a las mayúsculas.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de noglan
+1
0
-1

Yo tengo el mismo problema y ya revisé cuestiones de memoria y la lógica me lleva a pensar que es con los usuarios que nuestros equipos cuentan con tarjeta de gráficos NVidia, si fuera general este post estaría repleto. Espero que alguien pueda ayudar...

+1
0
-1

nOglAn

Imagen de cimarron-argento
+1
0
-1

No es solo con las placas nVidia... normalmente me sucede usando firefox y libreoffice calc, que luego de reiniciar la sesion avisa que el sistema se recupera de un fallo con en ../../libreoffice.bin

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Yo también tengo una tarjeta gráfica nvidia y no tengo ese problema, jamás se cierra la sesión, a menos que yo lo especifique.

Como quiera tu premisa no deja de ser válida, puesto que a lo mejor este problema se presenta en sólo un tipo o familia de tarjetas nvidia.

Mi PC es de escritorio y tengo una Nvidia GeForce de la serie 7.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de christianmrtnz
+1
0
-1

La he liado, encontré un tutorial para arreglar el problema, que consistía en instalar una versión del driver más antigua (no mucho más), abrí el modo terminal ctrl+alt+f* y paré lightdm:

sudo lightdm stop

después ejecuté el driver, lo instalé y reinicé el ordenador, me cargó en modo terminal, por lo que hice un:

sudo startx

Y me dio error, pensé que sería por lightdm:

sudo lightdm start

Y volví a ejecutar las x, pero nada. Reinicié y por fin se ejecutó lightdm, pero al introducir mis datos (en cualquier tipo de escritorio) vuelve a aparecer el lightdm, es decir, no aparece el escritorio, tan solo si entro en modo de usuario invitado, alguna idea??

gracias por vuestras contestaciones!

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Reinicia, pero antes de iniciar sesión;

dale a Ctrl+Alt +F1 ó F2 y escribe:

sudo dpkg-reconfigure lightdm

y elige gdm como predeterminado.

luego:

sudo service lightdm stop
sudo service gdm start

Ahora tendrás a gdm como la pantalla de acceso.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de christianmrtnz
+1
0
-1

Ha funcionado a la perfección, ya puedo volver a utilizar Ubuntu, pero eso sí, además de que no quiero gdm, sino lightdm persiste el problema de los gráficos.. he probado a reinstalar lightdm y sigue el error de antes.. alguna idea?

gracias!

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

acostúmbrate con gdm, o en su caso instala kdm, pero para tener ese talvez necesites instalar todo el escritorio KDE.

Y sobre tu problema gráfico, no se que problema tengas, no mencionas que problema tienes, como quiera es otro tema, abre otro hilo.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de christianmrtnz
+1
0
-1

es el tema principal del hilo, el primer post es el mio indicando mi problema ^^... te comento.

He decidido reinstalar, ahora que puedo acceder respaldo mis archivos y reinstalo desde CD (para evitar problemas con usb), ahora mi duda está en.. qué driver instalo al instalar Ubuntu? gracias!

+1
0
-1
Imagen de Axelsan
+1
0
-1

¿Al final asolucionaste el problema? He reinstalado 5 veces y no hay manera.
Tengo la misma gráfica, seguramente tenga que ver con eso... ¿instalando una versión más antigua del driver se soluciona? ¿de dónde la podría descargar?

Gracias.

+1
0
-1
Imagen de christianmrtnz
+1
0
-1

al final no he solucionado nada, voy a reinstalar Ubuntu y aguantar sin drivers gráficos hasta nuevo aviso.. :S

+1
0
-1
Imagen de geniohm
+1
0
-1

Tengo una nvidia gforce 9800gt un procesador AMD Phenom x3 una RAM 1066 MHz nunca havia tenido problemas con ubuntu hasta esta versión tan chafa y no creo que sean los drivers de nvidia porque ya le puse varios hasta los mas viejos . Esto debe ser una falla en el kernel o algún otro problema ojala y se solucione esto porque estoy muy decepcionado ya intente de todo lo que dicen en los foros para solucionarlo y nada. Esto es un problema muy fuerte y yo que le decía a las personas que ubuntu linux era mucho mejor y mas estable que windows creo que me equivoque, al menos mi windows vista con sp2 no me ha dado problemas ni windows 7 solo es cuestión de tener un buen antivirus y no bajar porquerías de programas de la red.

Ojala y arreglen los problemas de este ubuntu 12.04 64bit nuevo que se me cuelga cuando navego en la red de internet con cualquier explorador, que no me gusta usar windows pero si no me dejan mas remedio ni modo, si así mi esposa no le gusta ubuntu por feo ahora que se le cierra la sesión menos le gusta y me tira en la cara ¿no me dijiste que era mejor que windows?. :(

+1
0
-1
Imagen de vgmonsalvo
+1
0
-1

Hola a todos:
De igual manera que ustedes, ubuntu 12.04LTS cierra la sesión solo y por tanto pierdo todo lo que estaba haciendo.

Por lo visto el problema esta relacionado con la placa de video nvidia.
Recomiendo actualizar el driver.
La manera mas sencilla de lograrlo es actualizando todo el sistema mediante el gestor de actualizaciones, y posteriormente ir a "drivers adicionales" alli aparecerá un driver nuevo bajo el código
NVIDIA accelerated graphics driver (post-release updates) (version current-update)

Ahora lo estoy probando.
Exitos a todos.

+1
0
-1

No le temas al pingüino

Imagen de vgmonsalvo
+1
0
-1

Hola:
Provee y revise. pero no funciono la actualizacion del driver. sigo buscando la respuesta correcta

+1
0
-1

No le temas al pingüino

Imagen de sergi99
+1
0
-1

**/Moderado/**

Dirígete con respeto a los demás usuarios.

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

No vengas aquì a condicionar respuestas, este problema no a todo el mundo le sucede, busca por reportes de bug o en otros foros como Ubuntu forums.

y NADIE va a adivinar que modelo de tarjeta nvidia tienes, por que el problema no se presenta en todas.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de sergi99
+1
0
-1

moderador, no hay falta de respeto. nI groserias.
Si en lugar de responderme a una pregunta un usuario me recrimina al correcion tecnica de la pregunta ??, no me responde y dice un en un estribillo que no sabe nada. Considero lo dicho, mejor que no responda y se dedique a lo que le interesa

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Si abres un nuevo hilo, explicando con detalle tu problema, con gusto se te ayudará en lo que uno pueda, pero si viene diciendo a manera de queja que una reinstalación no le funciono, dudo que alguien le pueda ayudar, sobre todo en un hilo que no le pertenece.

¿No sabe obtener la información de su hardware? Sencillo, lea la documentación del funcionamiento básico de Ubuntu, eso es un requerimiento básico para participar en el foro.

No sé si los demás se hayan documentado con anticipación, pero al menos ellos proveen información básica sobre su hardware y aportan algo al hilo, eso es básico si desea obtener una respuesta que a usted le sea útil.

De otra manera usted se frustra y ocasiona molestias a los demás usuarios.

Por cierto una disculpa si me sentí agresivo con usted, quizás me exprese sin notarlo.

Un Saludo.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Jose Luis 1320
+1
0
-1

El driver 295.49 no tiene mucho tiempo que ha sido publicado, y lo puedes instalar agregando el repositorio de X-swat-updates.

No te voy a decir como hacerlo, busca en internet como.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Samoano
+1
0
-1

El problema nos afecta a muchos como veo.

El caso es que yo tengo una NVIDIA GeForce 8600 GT, Ubuntu 12.04 64bits y justo como comentan ustedes la sesión se cierra de forma aleatoria.
He intentado instalar/quitar drivers, configuraciones diversas... incluso probar con el kde. Justo cuando crees que va bien PLOF - la sesión se cierra - pierdes los datos de los programas y seguimos...

Es una lástima porque el sistema es maravilloso. A ver si entre cierre y cierre de sesión conseguimos entre todos dar con la solución.

saludos

+1
0
-1
Imagen de sergi99
+1
0
-1

Por si os puede ser de utilidad
Ayer descubri que de anteiores intalaciones el programa desktop-nova me habia quedado en aplicaciones de inicio, lo tenia configurado de la version anterior para cambiar fondo de pantalla cada 3 minutos. Lo he desintalado y parece que han desaparecido los logout de usuario.

saludos

+1
0
-1
Imagen de danieldlo09
+1
0
-1

Todavía no han podido solucionar el problema??? si alguien ya lo solucionó por favor postearlo...

+1
0
-1