No se pudo instalar GRUB en /dev/sda

Imagen de Benchi
0 puntos

Buenas tardes a tod@s:

Soy nuevo y completamente novato en el mundo de Linux. Estoy instalando el ubuntu 12.04 64 bits en mi portátil. He seguido los pasos de instalación como se comenta en la web oficial pero, en medio de la instalación me sale un error como el del asunto "No se pudo instalar GRUB en /dev/sda" no sé qué significa ni nada, por lo que he entendido es el gestor de arranque, puede ser???

Que puedo hacer para solucionarlo, qué pasos he hecho mal. Sólo quiero en mi portatil el ubuntu, nada de windows, sólo quiero este SO.

MUCHAS GRACIAS

Imagen de .doc
+1
0
-1

si, GRUB es el gestor de arranque, y /dev/sda es como se debería llamar tu primer disco duro (dev/sda1, 2, 3... las particiones de ese disco)

Mira a ver cómo reconoce, exactamente, tu disco, a lo mejor lo llama de otra forma. (O has hecho algo raro durante la instalación. eso no podemos saberlo si no das más pistas que lo de que has seguido los pasos de un manual).

O inténtalo de nuevo, fijándote bien en lo que haces cuando particionas, y cuando se instala el grub

+1
0
-1
Imagen de Benchi
+1
0
-1

He seguido los pasos básicos,

1) Elegí idioma
2) me salen tres opciones. Instalarlo junto a windows 7, instalarlo de 0, eliminando windows 7 y otras opciones
3) Elegía la segunda opción
4) Empezó a instalarse y en medio de ella me saltó el error

+1
0
-1
Imagen de Joseina
+1
0
-1

GRUB es el gestor de arranque, si.

Lo que puedes hacer es meter el Live CD de Ubuntu y cuando arranque y lo estés probando, ejecutar el terminal y tecleas los siguientes comandos:

sudo fdisk -l
(Con este comando verás las particiones de disco duro)

Después veras cual es la partición donde tienes Ubuntu y la montas en /mnt (es donde instalamos UBUNTU que es en la Particion /, escoge el numero donde instalaste esta particion. En la mayoría de los casos esta partición será sda1, el ejemplo lo haré con esa partición pero mira cual es tu partición con el comando fdisk o con el Editor de Particiones GParted):

sudo mount /dev/sda1 /mnt

(sda1 es si tienes Ubuntu por defecto, pero si tienes Windows u otro Linux puede cambiar (sda2, sda3..). Como digo, asegurate antes de cual es la que usa ubuntu y con este comando la montas. Si eres novato, te recomiendo Gparted, que viene en el LiveCD y tiene entorno gráfico. Así quizá te aclares mejor)

Ahora, monta el resto de los dispositivos:

sudo mount --bind /dev /mnt/dev
sudo mount --bind /dev/pts /mnt/dev/pts
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys

Y ejecuta el comando chroot de forma que accedemos como root al sistema de archivos de nuestro antiguo Ubuntu:

sudo chroot /mnt

Por último carga el Grub en el MBR ejecutando el siguiente comando:

grub-install --recheck /dev/sda

(sda lo debemos substituir por el disco duro que utilizamos para arrancar los sistemas operativos, casi siempre es sda. ¡¡Ojo!! no poner el número de partición, solo sda).

Ajustar en el menú del GRUB automáticamente con el siguiente comando:

sudo update-grub2

Si el comando no te funciona, quizás necesites instalar el paquete grub2:

sudo apt-get install grub2

Despues reinicias el ordenador. Y Listo

** En negrita tienes los comandos. Introdúcelos en orden y debería funcionar. Este último, es solo si el anterior no te funciona.

+1
0
-1
Imagen de Benchi
+1
0
-1

Perfecto me funcionó....MUCHAS GRACIAS A TOD@S.......espero tener buenas experiencia en ubuntu y sepa ver que es mejor SO que windows.

+1
0
-1
Imagen de rufysimo
+1
-1
-1

no consigo instalar xubuntu 13.10 por mas que lo intento.

durante la instalacion me salta un error
no se pudo instalar el paquete grub-efi-amd64-signed en /target/ . el sistema instalado no podra arrancar sin el cargador de arranque de GRUB

tengo 4 particiones
/dev/sda1 2048 2050047 1024000 82 Linux swap / Solaris
/dev/sda2 2050048 53250047 25600000 83 Linux
/dev/sda3 * 53250048 200706047 73728000 7 HPFS/NTFS/exFAT
/dev/sda4 200706048 625141759 212217856 7 HPFS/NTFS/exFAT

sigo los pasos bien asta
sudo chroot /mnt
que me responde
source_dir doesn't exist. Please specify --target or --directory

no se que hacer.
porque...?
es necesaria la particion de sistema de 100m ke genera por defecto windows 7?
la quite por que necesitaba las 4 particiones.

muchas gracias!!

+1
-1
-1
Imagen de cuentos
+1
0
-1

el problema es que este hilo es anterior y se refiere a particionados tipo ms-dos. Y tu sistema según comentas:

es necesaria la particion de sistema de 100m ke genera por defecto windows 7?
la quite por que necesitaba las 4 particiones.

Es el nuevo particionado GPT, y esa partición que borraste es la nueva partición de boot o algo similar al grub
En particionados GPT ya no hay el limite de 4 particiones primarias, ya todas son primarias (las que hagas).
Volvamos al punto de: Si borraste la primera, el tipo de particionado GPT no tiene donde iniciar.
Prueba con boot-repair, lo ejecutas y este te da los comandos para tratar de arreglar esto.
Y otro punto muy importante, según recuerdo solo sistemas de 64 bits traen soporte para para particionado GPT.
https://help.ubuntu.com/community/Boot-Repair
http://diariodebian.wordpress.com/2013/04/10/recuper-tu-grub-con-boot-re...

AGREGO:
Mejor abre un hilo, ya que estas invadiendo uno, y de esta forma tu problema puede recibir mas ayuda, y si lo solucionas, sirve para otros usuarios.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos