(Solucionado) Error fatal al actualizar Ubuntu 12.04

Imagen de Pedro Lobo
0 puntos

Desde ayer me salta un error fatal al ejecutar el gestor de actualizaciones y no me deja instalar las actualizaciones que están disponibles para mi distribución. He buscado por todos lados la solución y no di con ella. Aunque hay muchas parecidas, ninguna igual, no funcionan para los Detalles que me da con el error en los paquetes. También he tratado de actualizar desde la consola y nada.
El error que me da al tratar de instalar o desintalar un paquete es:
installArchives() failed:
Extrayendo plantillas para los paquetes: 96%%
Extrayendo plantillas para los paquetes: 100%%
Preconfigurando paquetes ...

Extrayendo plantillas para los paquetes: 96%%
Extrayendo plantillas para los paquetes: 100%%
Preconfigurando paquetes ...

Extrayendo plantillas para los paquetes: 96%%
Extrayendo plantillas para los paquetes: 100%%
Preconfigurando paquetes ...

Extrayendo plantillas para los paquetes: 96%%
Extrayendo plantillas para los paquetes: 100%%
Preconfigurando paquetes ...
(Reading database ...
dpkg: warning: files list file for package `linux-headers-generic-pae' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `linux-headers-3.2.0-23-generic' missing, assuming package has no files currently installed.

(Reading database ... 5%%
(Reading database ... 10%%
(Reading database ... 15%%
(Reading database ... 20%%
(Reading database ... 25%%
(Reading database ... 30%%
(Reading database ... 35%%
(Reading database ... 40%%
(Reading database ... 45%%
(Reading database ... 50%%
(Reading database ... 55%%
(Reading database ... 60%%
(Reading database ... 65%%
(Reading database ... 70%%
(Reading database ... 75%%
(Reading database ... 80%%dpkg: unrecoverable fatal error, aborting:
reading files list for package 'linux-headers-3.2.0-24-generic-pae': Input/output error

Espero no estar repitiéndome en la consulta. Desde ya agradezco en lo que me puedan ayudar. Desde hace tres años que me pasé a Ubuntu, estoy muy contento y siempre pude arreglar los problemas que se me presentaron desde Ubuntu 9.04, consultando en los foros. Mi equipo es una Dell Inspiron 1525, de nuevo muchas gracias.

Imagen de cuentos
+1
0
-1

cuando realizas un update que error te arroja:
sudo apt-get update

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Pedro Lobo
+1
0
-1

Cuando realizo sudo apt-get update no arroja ningún error.

+1
0
-1
Imagen de cuentos
+1
0
-1

y si actualizas el sistema desde la consola con:
sudo apt-get upgrade

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Pedro Lobo
+1
0
-1

Muchas gracias por responderme con tanta rapidez. El error que reporta es:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Los siguientes paquetes se han retenido:
software-center
Se actualizarán los siguientes paquetes:
at-spi2-core fonts-opensymbol gir1.2-atspi-2.0 libasound2 libatspi2.0-0
libnautilus-extension1a libsnmp-base libsnmp15 libssl1.0.0 libutouch-geis1
linux-headers-3.2.0-24 linux-headers-3.2.0-24-generic
linux-headers-3.2.0-24-generic-pae linux-image-3.2.0-24-generic
linux-libc-dev nautilus nautilus-data openssl python-gi python-gi-cairo
python-gobject resolvconf ttf-opensymbol uno-libs3 ure vino xserver-common
xserver-xorg-core xserver-xorg-input-synaptics
29 actualizados, 0 se instalarán, 0 para eliminar y 1 no actualizados.
Se necesita descargar 0 B/62,2 MB de archivos.
Se liberarán 102 kB después de esta operación.
¿Desea continuar [S/n]? s
Preconfigurando paquetes ...
(Leyendo la base de datos ...
dpkg: aviso: falta el fichero de lista de ficheros del paquete `linux-headers-generic-pae', se supondrá que el paquete no tiene ningún fichero actualmente instalado.

dpkg: aviso: falta el fichero de lista de ficheros del paquete `linux-headers-3.2.0-23-generic', se supondrá que el paquete no tiene ningún fichero actualmente instalado.
(Leyendo la base de datos ... 80%dpkg: error fatal irrecuperable, abortando:
leyendo lista de archivos por paquete «linux-headers-3.2.0-24-generic-pae»: Error de entrada/salida
E: Sub-process /usr/bin/dpkg returned an error code (2)

Puse todo por las dudas. Saludos

+1
0
-1
Imagen de Pedro Lobo
+1
0
-1

Sigo sin encontrar solución a mi problema. ¿Será que tengo que esperar a que salga Ubuntu 12.10?

+1
0
-1
Imagen de cuentos
+1
0
-1

prueba con las instrucciones de este hilo que serian:
Elimina todos los archivos contenidos en
/var/lib/apt/lists/
/var/lib/apt/lists/partial/
Ejecuta en consola

sudo su
dpkg --configure -a
apt-get install -f
apt-get clean
apt-get update
apt-get upgrade
http://www.ubuntu-es.org/node/166829

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Pedro Lobo
+1
0
-1

Cuentos:
Hice lo que me dijiste y realizaron en la línea que enviaste, pero sigue saltando el mismo error del que hablo arriba

+1
0
-1
Imagen de cuentos
+1
0
-1

que kernel tienes actualmente, en una actualización de días atrás me actualizo a el kernel 3.2.0-24
también puedes probar con los comandos:
sudo apt-get upgrade -f

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Pedro Lobo
+1
0
-1

No sé que kernel tengo, como soy un poco duro todavía con ubuntu, tampoco sé como saberlo. Pero me parece que todavía no tengo el tuyo, porque está entre los paquetes que quiere actualizar:
Se actualizarán los siguientes paquetes:
at-spi2-core fonts-opensymbol gir1.2-atspi-2.0 gnome-orca libasound2
libatspi2.0-0 libnautilus-extension1a libsnmp-base libsnmp15 libssl1.0.0
libutouch-geis1 linux-headers-3.2.0-24 linux-headers-3.2.0-24-generic
linux-headers-3.2.0-24-generic-pae linux-image-3.2.0-24-generic
linux-libc-dev nautilus nautilus-data openssl python-gi python-gi-cairo
python-gobject resolvconf ttf-opensymbol uno-libs3 ure vinagre vino
xserver-common xserver-xorg-core xserver-xorg-input-synaptics
xserver-xorg-video-vmware
Probé con el comando que dijiste y tampoco funcionó...

+1
0
-1
Imagen de Pedro Lobo
+1
0
-1

Ya van 41 actualizaciones que no se pueden instalar, muchas de ellas de seguridad. Sigo navegando buscando alguna solución y nada. Creo que tendré que volver a instalar de cero, que porquería. Pensaba que esto nunca me iba a suceder con mi querido Ubuntu.

+1
0
-1
Imagen de Pedro Lobo
+1
0
-1

Cuentos:
Pude averiguar que kernel tengo actualmente, haciendo que me apareciera el grub al iniciar la máquina -teniendo apretada mayúscula mientras lo hacía- y me da 3.2.0-24. Sigo buscando una solución antes de reinstalar.

+1
0
-1
Imagen de Pedro Lobo
+1
0
-1

Ya son 61 actualización disponibles que no puedo instalar. Me niego tener que reinstalar el sistema operativo y todo lo que con ello lleva consigo, pero no puedo solucionar el problema. Alguien me puede decir ¿hasta cuándo comenzará a ser peligroso tener así el OS?

+1
0
-1
Imagen de cuentos
+1
0
-1

Buenas, y si cambias de servidor de actualizaciones, a otro, en el gestor de actualizaciones, configuración, en la primera pestaña, Software de ubuntu, donde dice descargar desde: puedes seleccionar otro, y buscar o descargar desde el principal.
lo cambias y luego intenta actualizar.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Pedro Lobo
+1
0
-1

No sabía esta opción, ahora la pruebo y reporto...

+1
0
-1
Imagen de Pedro Lobo
+1
0
-1

No funciona, sigue saltando error. No se podría evitar el linux-headers-3.2.0-24-generic-pae, no tengo ni idea que es, pero si se lo elimina, puentea o algo por el estilo...

+1
0
-1
Imagen de Pedro Lobo
+1
0
-1

Estuve viendo que, linux-headers-3.2.0-24-generic-pae, es para los sistemas con más de 4 gb de ram, lo cual yo no tengo ¿por qué se habrá instalado?
Leí en: help.ubuntu.com/community/EnablingPAE que pueden ser instalados o eliminados si son necesarios o no funcionan. Probé hacerlo desde synaptic y cuando quiero marcar linux-headers-3.2.0-24-generic-pae, para desintalarlo se me bloquea el gestor de paquetes, quiero quitar los otros y después de un rato me dice:
leyendo lista de archivos por paquete «linux-headers-3.2.0-24-generic-pae»: Error de entrada/salida
E: Sub-process /usr/bin/dpkg returned an error code (2)
Un paquete no se pudo instalar. Tratando de recuperarlo:
Y ahí se queda. Por favor AYUDA.... PLEASE

+1
0
-1
Imagen de Pedro Lobo
+1
0
-1

Alguno que sepa me podría decir si el error que tengo es por tener instalado los drivers para nvidia, quizás lo hice por error, pero no tengo ningún recuerdo.
Para disintalarlos sólo basta con marcarlos para desintalar en synaptic

+1
0
-1
Imagen de Pedro Lobo
+1
0
-1

Descargue finalmente Ubuntu 12.04 y realice una reistalación de todo el sistema. No me quedó otra. Saludos

+1
0
-1