Unidades samba en Thunar

Imagen de aevora
2 puntos

Hola a tod@s.
Os cuento, monte hace unos días Xubuntu 12.04 (vengo de Ubuntu 10.04). Todo va correctamente a excepción de un pequeño detalle: al montar usando samba, la unidad montada no aparece por ningún lado. Me explico, en Ubuntu cuando montaba una unidad de red desde Nautilus (smb://direccionIP) esta aparecía como un icono en el escritorio y el panel lateral (sitios), sin embargo desde Thunar puedo hacerlo igualmente pero en el escritorio no aparece la unidad montada (cosa que si ocurre si meto un CD/DVD, PenUSB, ...), solamente tengo acceso mediante la carpeta .gvfs de mi usuario. Ademas no me deja desmontarla haciendo umount (me dice que no esta montado segun mtab)

Esto es realmente un problema o algo hago mal.

Un saludo y muchas gracias por anticipado.

Imagen de Gabriel_M
+1
0
-1

Estas aplicaciones:

sudo su
apt-get install system-config-samba pyneighborhood smbnetfs

Luego en Menu -- sistema -- samba
configura los dispositivos y su acceso
Al reiniciar en Thunar a la izquierda parecerá la red para navegar.

Ahora, si lo que quieres es convertir al navegador de archivos de xfce en un
administrador de recursos de red para:
Habilitar compartición de directorios
Eliminar compartición de directorios
además de ver directorios compartidos

Instala además estas aplicaciones:

sudo su
apt-get install gvfs-fuse libsmbclient smbclient python-smbc 

Edita el archivo smb.conf:

sudo su
nano /etc/samba/smb.conf

Busca la línea:
[global]

Inserta estas dos dos líneas:

usershare allow guests = yes
map to guest = Bad user

Guarda el archivo
Cierra el editor
ejecuta

service samba restart
gpasswd -a (Tu-Usuario) sambashare

Esto irá agregando el registro y opciones de los directorios a compartir en la ruta:
/var/lib/samba/usershares/

Todo directorio a compartir será añadido en esta ruta en un archivo de texto plano.

En Thunar se pueden habilitar estas opciones:

Público sólo lectura:
net usershare add %n %f "" Everyone:R guest_ok=y

Público lectura/escritura:
net usershare add %n %f "" Everyone:F guest_ok=y && chmod 777 %f

Privado sólo lectura:
net usershare add %n %f "" Everyone:R guest_ok=n

Privado lectura/escritura:
net usershare add %n %f "" Everyone:F guest_ok=n && chmod 777 %f

Eliminar compartición:
net usershare delete %n && chmod 755 %f

Par ello cargas Thunar y pulsas
Editar --- Configurar Acciones Personalizadas.
Agregas las acciones.

Acción Compartir Directorio.
Pulsas en el signo más para agregar una nueva acción:
Nombre: Habilitar Directorio Compartido
Comentario: Habilitar compartición de directorio
Comando: net usershare add %n %f "" Everyone:R guest_ok=y
Pestaña Condiciones de apariencia: Seleccionas únicamente Directorios

Acción Eliminar Compartir Directorio.
Pulsas en el signo más para agregar una nueva acción:
Nombre: Deshabilitar Compartir Directorio
Comentario: Deshabilitar compartición de directorio
Comando: net usershare delete %n && chmod 755 %f
Pestaña Condiciones de apariencia: Seleccionas únicamente Directorios

Acción Ver Directorios Compartidos.
Pulsas en el signo más para agregar una nueva acción:
Nombre: Ver Directorios Compartidos
Comentario: Visualizar los recursos de red
Comando: xfce4-terminal -H -x net usershare info --long
Pestaña Condiciones de apariencia: Seleccionas únicamente Directorios

Reinicia y tendras un Thunar con esteroides para redes

+1
0
-1
Imagen de aevora
+1
0
-1

Hola Gabriel,
Primeramente gracias por la respuesta (y perdón por la tardanza en responder). Ayer probe la primera parte del post y no es lo que buscaba. En cuanto a la segunda parte del post tampoco es lo que busco (esto seria para poder trabajar directamente con carpetas compartidas). Lo que busco es algo parecido a lo que tenia en Ubuntu. En este (Ubuntu) lo que ocurre al abrir Nautilus, pulsaba Ctrl+L y en la direccion ponia: smb://direccionip/recursocompartido. Despues de aceptarlo un icono del recurso compartido aparecia en el escritorio y en Nautilus en el panel lateral tambien mostraba las unidades de red montadas. Ahora en Xubuntu en el panel lateral me aparece la red pero no las unidades montadas, solamente tengo acceso a el recurso compartido accediendo mediante la carpeta .gvfs (una vez que he cerrado la ventana original con la que abri el recurso por primera vez).

Espero haberme explicado bien, si no es asi aclaro (o intento) lo que necesiteis.

Un cordial saludo y gracias.

+1
0
-1