Error apt-get en el area de notificaciones (Terminado)

Imagen de gledof
0 puntos

Hol@, como podran ver en la IMAGEN aparecio un icono de alerta y este despliega un mensaje advirtiendo sobre un error.
Ya tuve antes errores de I/O (entrada y Salida) todavia esto no se si se debe a un error de archivos o del controlador del disco rigido (espero que no!).
Corri en un terminal apt-get autoremove por el paquete dcraw que aparecia para remover pero se cuelga por un rato y devuelve:

sudo apt-get autoremove
[sudo] password for equis:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Los siguientes paquetes se ELIMINARÁN:
dcraw
0 actualizados, 0 se instalarán, 1 para eliminar y 0 no actualizados.
Se liberarán 427 kB después de esta operación.
¿Desea continuar [S/n]? s
dpkg: error: leyendo el archivo de información del paquete «/var/lib/dpkg/status»: Error de entrada/salida
E: Sub-process /usr/bin/dpkg returned an error code (2)

Despues, desde el terminal en el que estaba ejecute Synaptic y tampoco pude desinstalarlo, se puso todo gris y despues mostro el error de arriba. Cuando cerre Synaptic en el terminal aparecieron las siguientes lineas:

sudo synaptic
[sudo] password for equis:
Traceback (most recent call last):
File "/usr/sbin/update-apt-xapian-index", line 106, in
indexer.incrementalUpdate()
File "/usr/lib/python2.7/dist-packages/axi/indexer.py", line 683, in incrementalUpdate
self.updateIndex(dbpath)
File "/usr/lib/python2.7/dist-packages/axi/indexer.py", line 643, in updateIndex
cache = self.aptcache()
File "/usr/lib/python2.7/dist-packages/axi/indexer.py", line 418, in aptcache
self.apt_cache = apt.Cache(memonly=True, progress=aptprogress)
File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 102, in __init__
self.open(progress)
File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 145, in open
self._cache = apt_pkg.Cache(progress)
SystemError: E:Read error - read (5: Input/output error), E:The package lists or status file could not be parsed or opened.
Discarding: 14 over 15

Seguido ejecute:

sudo dpkg --configure -a
[sudo] password for equis:
dpkg: error: leyendo el archivo de información del paquete «/var/lib/dpkg/status»: Error de entrada/salida

El icono aun sigue en el panel, agradeceria cualquier ayuda.

Imagen de gledof
+1
0
-1

lo que se me ocurrio y no puedo sacr el icono de error del panel, sigue mostrando el error en dpkg: error: leyendo el archivo de información del paquete «/var/lib/dpkg/status»: Error de entrada/salida
E: Sub-process /usr/bin/dpkg returned an error code (2)

....seguire buscando no quiero volver a reinstalar 12.04

+1
0
-1

Saludos.----

Imagen de Gabriel_M
+1
0
-1

El archivo /var/lib/dpkg/status contiene los datos de la selección de paquetes del sistema Debian.
Si por alguna razón se inutiliza, se perderán los datos de la selección de paquetes y resultará enormemente afectado el sistema.
Busca el archivo /var/lib/dpkg/status anterior en /var/lib/dpkg/status-old o /var/backups/dpkg.status.*.
Si es que existen, reemplaza el archivo por uno anterior sin errores.
Si el archivo /var/lib/dpkg/status anterior no se encuentra disponible, antes de reinstalar el sistema puedes intentar traer el archivo de alguna otra instalación similar, no quedará correcto pero te permitirá seguir instalando y actualizando.

+1
0
-1
Imagen de gledof
+1
0
-1

Ahora la cosa esta peor, hoy intente entrar y despues del grub me aparecio el prompt de "initramfs"
Ya no puedo ni siquiera entrar, y no se como pasar esta pantalla, se que initramfs es como un minisistema oprerativo que se carga antes del S.O. pero no se que hacer con el. Ayer intente esto:

$ sudo echo "force-all" >/etc/dpkg/dpkg.cfg
$ sudo apt-get -f install

Y como dije, hoy ya no pude entrar. Ahora estoy en Trisquel voy a montar la particion de 12.04 en /tmp y buscar en el directorio a ver si hay una copia de respaldo del archivo o el .old
Te pregunto: Si copio otro archivo "status" de otro sistema tiene que ser si o si de 12.04?

+1
0
-1

Saludos.----

Imagen de Gabriel_M
+1
0
-1

Si
Tiene que ser del mismo.
Estimo que tienes problemas de sistema de archivos
O algo lo daño o el disco se está dañando.

+1
0
-1
Imagen de gledof
+1
0
-1

si puedo copiar el archivo del sistema de un amigo, solo tengo instalado un 12.04 puesto que desde el principio no funciono bien solo me limite a una instalacion por eso te pregunte si podia ser de otro Linux (10.10 o Trisquel)
Hay alguna forma de chequear si es el disco el que tiene problemas, en instalaciones anteriores de 12.04 tuve errores de I/O al mover o copiar archivos.

+1
0
-1

Saludos.----

Imagen de gledof
+1
0
-1

pero no hubo forma de acceder a la particion en la que estaba 12.04. Ya no podia entrar al sistema y no logre montarla desde otro sistema ni desde un LiveCD. Decidi formatear y reinstalar pero no pude, 12.04 se cuelga a mitad de la instalacion, probe ademas con Trisquel, 10.10, BrainOS, Mint y BackTrack no pude instalar ninguno, ahora la particion sda1 esta formateada NTFS. Te vuelvo a preguntar Gabriel o a cualquier otro que me pueda decir si hay forma de testear el disco para ver si solo era un problema de archivos o mi disco duro esta dañado. Gracias desde ya.

+1
0
-1

Saludos.----

Imagen de Gabriel_M
+1
0
-1

sudo su
badblocks -n /dev/sda  (encuentra sectores dañados)
e2fsck -c  /dev/sda[/i] (marca como inusables los dañados)

Si esta dañado, se puede intentar reparar con

sudo su
dd if=/dev/zero of=/dev/sda

Y se repiten los anteriores para ver si sirvió de algo.

+1
0
-1
Imagen de gledof
+1
0
-1

Vine a ver si habia alguna respuesta y veo lo del comando "badblocks", hace mas de tres horas que esta corriendo. Cuando termine voy a aplicar el segundo comando "e2fsck" (que no conocia).
Cuando termine te comento que como resulto y si pude instalar algo en sda1. Muchas gracias.

¿...?= Que es "zero" en el ultimo comando? Tengo que reemplazarlo por algo?

+1
0
-1

Saludos.----

Imagen de gledof
+1
0
-1

e2fsck -c /dev/sda[/i] (marca como inusables los dañados)

Comence a correr este comando de esta forma "e2fsck -c /dev/sda1" y lo pare porque me quedo la duda sobre este atributo (creo?) "[/i]"
Para la particion sda1 como seria exactamente la sintaxis?

+1
0
-1

Saludos.----

Imagen de gledof
+1
0
-1

badblocks despues de casi 5 horas:

......
51038842done, 4:57:26 elapsed
51038843done, 4:57:41 elapsed
hecho
Paso terminado, se encontraron 521 bloques dañados.

Encontro 521 bloques dañados en una particion de 50gb.

+1
0
-1

Saludos.----

Imagen de Gabriel_M
+1
0
-1

zero es cero, sobre escribe el disco con ceros, para intentar dar un formateo simil bajo nivel, y ver si se recupera algo.

+1
0
-1
Imagen de gledof
+1
0
-1

12.04, instalado y ahora mismo mientras escribo, actualizando. Por ahora no hay error visible, voy a tratar de llevarlo a como estaba antes del fallo y voy a hacer copias periodicas del archivo "status", por si las dudas.
En adelante ire pegando en este hilo los errores que vayan saliendo (particion y operacion). Gracias por la ayuda y veremos que pasa.

+1
0
-1

Saludos.----

Imagen de gledof
+1
0
-1

Media hora de vida, se instalo, se actualizo, instale build-essential y aplique el ya conocido "sudo reboot" cierra.....inicia pantalla del mobo......grub.....pantalla negra que dice "presione cualquier tecla para continual _" y las tres luces de mi teclado titilando. no hay forma de pasar eso salvo con el boton reset.
Pero eso no es todo, entre al 2do. sistema (Trisquel) y paso algo extraño, la primera vez no monto las otras particiones y se reinicio solo, a la segunga pude entrar pero Firefox estaba como si recien lo hubiera instalado, me pidio configurar unos complementos que ya tenia instalados desde hace tiempo, las configuracion esta como la que viene por defecto y los marcadores no estaban. Los sistemas no tienen cuentas compartidas.

+1
0
-1

Saludos.----

Imagen de gledof
+1
0
-1

en el segundo sistema(Trisquel) que mencione creo que estan relacionados con GConf. Abri el visor de escritorios remotos para ver otra maquina y en la ventana donde tenia las IPs de mi red y otras ahora se ve esto IMAGEN

+1
0
-1

Saludos.----

Imagen de Gabriel_M
+1
0
-1

.... ha llegado la mala hora (justo cuando valen una fortuna) de descartar el disco y utilizar otro en su reemplazo.

+1
0
-1
Imagen de gledof
+1
0
-1

tienes razon. Voy a seguir usando este disco con el sistema que todavia funciona y pasare los datos a uno nuevo. Todavia no probe de correr "dd if=/dev/zero of=/dev/sda1" y ver que pasa, solo para probar, no voy a confiarle nada a esa particion. Gracias Gabriel por tu ayuda si hay alguna novedad la subo aqui, el post le servira a otro mas adelante.

Saludos.

+1
0
-1

Saludos.----