Programa que usa librerias gtk2 puede funciona en ubuntu 12.04 o 11.10?

Hago esta pregunta por el programa xvideoservicethief instalado des del repositorio getdeb.

Lo curioso es que un ubuntu 11.04 funciona a las mil maravillas.
Lo instale en lubuntu 11.10 y de repente dejo de funcionar. Pensé que era pq le habia hecho muchas trastadas al sistema operativo.
Formatee Lubuntu e instale Xubuntu 12.04 Y me daba el mismo error que Lubuntu. Creo que quizás el motivo es pq este soft utiliza librerias gtk2.

El error que me da es que dice que el plugin flvstreamer no esta instalado. Pero si lo está. Así que ya me pierdo.

Imagen de Jose Luis 1320
+1
0
-1

Ese programa esta escrito en su totalidad con C++, usa librerías Qt. Entonces ese problema que estas teniendo, puede ser por la presencia de un bug en las librerías Qt que incluye Ubuntu 11.10 y 12.04 ó un bug del programa en sí que no soporta o llama a una función no presente en las librerías Qt que llevan Ubuntu 11.10 y 12.04.

Inclusive tuve un error al estarlo compilando en Ubuntu 12.04.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de jccall80
+1
0
-1

Bueno. Creo que será difícil que alguien hallé la solución del problema ya que quizás no sea algo simple y tampoco este es un programa usado por grandes masas de gente.

También estoy pensando que el motivo puede ser pq no tenga instaladas las librerias Qt necesarias ya que ni en xubuntu ni lubuntu he instalado programas que usen librerias qt.

En cambio en ubuntu instale amarok, k3b y no se si algo más. No crees que puede ser este el motivo?

En la página web pone: (y por los comentarios deduzco que quizás sea este el motivo)
Compressed Package (dynamic version)
This archive contains only the files you need to run xVideoServiceThief and needs to be unzipped. This version requieres the Qt 4.6.x toolkit installed in your O.S.
Ubuntu package (dynamic version)
This version is not mantained by Xesc & Technology

Si instalo las librearias qt imagino que mi sistema se hará más lento, no?
Con la mencion que hace "Qt 4.6.x toolkit" cuales son las librerías que debería instalar?

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

El paquete debe de tener las librerías Qt que necesita, o si lo instalas desde playdeb, te debe indicar que dependencias necesita el programa, y si no lo hace, es por que ya las incluye.

Puedes incluso instalar Qt sin Amarok ni k3b ni nada de esos programas.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de jccall80
+1
0
-1

Quizás no tenga sentido lo que diga. Pero el programa no lo instale de un paquete deb.
Lo instale del repositorio getdeb con un sudo apt-get install xvst. Des de synaptic miro el repositorio y la verdad es que no incluye ninguna librería adicional.

Cuando instale amarok se me instalaron las librerias QT. Lo instalé a través de un repositorio ya que durante el año y medio que tengo ubuntu se me ha actualizado. (Versión de las librerías es la 4.7.2)

Además en la web pone estas notas:
The ffmpeg lib is not included in any package! To enable the video conversions you should install the ffmpeg lib.
"Por lo tanto ffmpeg lo debes instalar tu manualmente"
"This version requieres the Qt 4.6.x toolkit installed in your O.S"
(Aunque esta última nota no está en la opción de instalación que elegí yo)

Después de todo lo que te digo sigues pensando que es completamente imposible mi teoría?

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Acabo de compilar el programa, y funciona a pleno en Ubuntu 12.04, en Unity: imagen

Salvo que no descarga videos de YouTube, no se por que, tal vez por el error que dices al principio. pero que funciona, funciona.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Jose Luis 1320
+1
0
-1

El programa me abre y todo, incluso instalé los plugins. Sin embargo no tengo idea de como usarlo, no me baja los vídeos de Youtube.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de jccall80
+1
0
-1

Por los comentarios creo que no lo has instalado de un repositorio deb.
Has bajado el tar y lo has instalado.

Te cuento como descargar un video por ejemplo de la página de tv3.

Abres el programa (XVST)
le das click a añadir video
pegas esta link que te paso:
http://www.tv3.cat/3alacarta/#/videos/4108330
le das a aceptar
Y te deberia empezar la descarga. (o te deberia dar error como me pasa a mi)

Este programa si funciona es muy potente... :)

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

En el dialogo me marca como "Unsupported video Service".

Y si lo abro desde Terminal no me da ningún mensaje de error semejante al tuyo.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de jccall80
+1
0
-1

raro.
prueba dandole al botón de buscar actualizaciones (parte superior derecha "no esta en texto, es un icono")
repite el proceso.

Acabo de probar con un video de youtube y si me funciona. Si quieres probar con youtube copias la url del video y listo. A ver si te funciona con youtube.

El mensaje de error exacto que obtengo es el siguiente:

El vídeo tiene el siguiente error:

Falta el flvstreamer (sin él es imposible bajar desde los servidores rtmp)

flvstreamer si está y los videos de la pagina de tv3 también me los puedo descargar introduciendo un comando en la terminal.

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Instalé los plugins, que era lo que faltaba, pego los enlaces y me da la información y todo, pero no descarga nada, no me da un porque, simplemente una ventana para reportar el bug.

Me da a pensar que este programa no funciona bien por alguna razón, no tengo idea cual, pero lo que si te puedo decir es que el problema con este programa no se relaciona en lo absoluto con las librerías Gtk, puesto que usa Qt en su totalidad.

El problema es otro.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro