Busco programadores para rehabilitar driver ATI

Imagen de steev_666
0 puntos

Hola pues eme aquí con mi historia

Estoy entre los que tienen una PRE HD, osease todas las radeon x1xxx, y anteriores, cuya AMD nos dejo con el culito al aire, y no hemos tenido mas que problemas e inconvenientes con los drivers gráficos, teniendo mal rendimiento, caídas, y demás que seguro a mas de uno nos ha llevado a la locura y que seguramente en algún momento vimos la estabilidad de los privativos

Bueno abro el post para aquellos valientes que quieran intentar ayudarme a hacer que el driver privativo de ATI 9.3 pueda instalarse en versiones actuales y futuras

En teoría el binario viene dentro del controlador que proporciona ATI, el cual se puede extraer fácilmente con:

sh ./ati-driver-installer-9-3-x86.x86_64.run  --extract ./ati

La verdad sé un pepino, osease NADA de programación, pero se leer y entiendo cosas lógicas, y la verdad de menos he visto que los archivos que usa para compilar entre versiones son exactamente los mismos, y el lenguaje no se ve tan complejo

La verdad no sé que es lo que imposibilita al driver instalarse en versiones superiores a Ubuntu 9.04 por ejemplo

Solo se que el driver Xorg se actualizo y AMD ya no quiso actualizar sus scripts

Ahora si alguien me ayuda a comprender como trabaja el instalador, y como podría solucionarse, yo estoy dispuesto a quemarme un poco las pestañas, y no me importa si a AMD le gusta o a CANONICAL diga que no se debe, o los puristas de solo usa software abierto no les parece

Creo que la filosofía de Linux es todos tenemos derecho a decidir como queremos las cosas

Quiero saber si lo que pido es simplemente imposible o es algo lunático pero posible de hacer y quien me apoya

Realmente no creo que sea la gran cosa, solo ha de ser cuestión de hacer un par de simbólicos y algún parchesito por aquí y por aya, estoy mirando algunos de los scripts y aparte de que detecte X version no veo que existan diferencias en los archivos de una versión y de otra

así que.... que dicen?