(SOLUCIONADO) no puedo reinstalar chromium y smplayer

Imagen de npais
0 puntos

Máquina con procesador celerón 2.550 y 2gb. De ram
Ubuntu 11.04

Desinstalé totalmente smplayer y chromium stable porque no podía actualizarlos

Cuando intento instalarlos nuevamente desde synaptic me pone: No se pudieron aplicar los cambios.
Arregle los paquetes rotos primero.
Cuando intento hacerlo desde consola sale lo siguiente: (agrego la información que sale cuando intento desde el centro de software)
ya he intentado con reconfigure -a y otras cosas que saqué de problemas parecidos en el foro

nevi@nevi-desktop:~$ sudo apt-get install smplayer
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución

Encontré la solución: instalar con aptitude, no aceptar el mantenimiento de los paquetes actuales, luego aceptar la instalación de paquetes nuevos.
Saludos
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
smplayer : Depende: libqtgui4 (>= 4:4.8.0) pero 4:4.7.2-0ubuntu6.3 va a ser instalado
E: Paquetes rotos
o tiene un candidato para la instalación

Los siguientes paquetes tienen dependencias incumplidas:

smplayer: PreDepends: dpkg (>= 1.14.12ubuntu3) pero 1.16.0~ubuntu7.1 no está instalado
Depends: libc6 (>= 2.4) pero 2.13-0ubuntu13.1 no está instalado
Depends: libgcc1 (>= 1:4.1.1) pero 1:4.5.2-8ubuntu4 no está instalado
Depends: libqt4-network (>= 4:4.5.3) pero 4:4.7.2-0ubuntu6.3 no está instalado
Depends: libqt4-xml (>= 4:4.5.3) pero 4:4.7.2-0ubuntu6.3 no está instalado
Depends: libqtcore4 (>= 4:4.7.0~beta1) pero 4:4.7.2-0ubuntu6.3 no está instalado
Depends: libqtgui4 (>= 4:4.8.0) pero 4:4.7.2-0ubuntu6.3 no está instalado
Depends: libstdc++6 (>= 4.1.1) pero 4.5.2-8ubuntu4 no está instalado
Depends: zlib1g (>= 1:1.1.4) pero 1:1.2.3.4.dfsg-3ubuntu3 no está instalado

nevi@nevi-desktop:~$ sudo apt-get install chromium-browser
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
chromium-browser : Depende: libgcrypt11 (>= 1.5.0-0) pero 1.4.6-4ubuntu2 va a ser instalado
Depende: libstdc++6 (>= 4.6) pero 4.5.2-8ubuntu4 va a ser instalado
E: Paquetes rotos

intento instalar desde consola y ya están instalados en su versión más reciente.
nevi@nevi-desktop:~$ sudo apt-get install libgcrypt11
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
libgcrypt11 ya está en su versión más reciente.
0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
nevi@nevi-desktop:~$ sudo apt-get install libstdc++6
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
libstdc++6 ya está en su versión más reciente.
0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.

Ya no tengo idea de que otras cosas hacer.
Un cordial saludo a todos.

Imagen de npais
+1
0
-1

Encontré la solución de esta forma:
Instalé con aptitude, no acepté el mantener los archivos que me indicaba y luego acepté instalar los archivos nuevos.
Saludos

+1
0
-1

nevi