Problema con Wifi en Ubuntu 12.04

Imagen de ggeloisa
0 puntos

Tengo una Dell INSPIRON mini a la cual le instalé Fedora 16 y todo funcionaba bien hasta que desactivé el wifi por medio de la tecla de función F2.
Después de esto no pude volver a encenderla, después cambié a Ubuntu 12.04 (es la primera vez que lo instalo) y desde que quedó instalado tuve el mismo problema. Al tratar de activarla hay un mensaje que dice "la red inalámbrica está desactivada por el interruptor físico".

Ubuntu si detecta el econtrolador Wifi:
Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n Wifi Adapter (rev 01)

Los detalles son los siguientes:
Subsystem: Dell Device 8194
Flags: bus master, fast devsel, latency 0, IRQ 17
I/o ports at 300 [size=256]
Memory at f0100000 (64-bit, non-prefetchable) [size=16K]
Capabilities: < acces denied >
Kernel driver in use: rtl8192ce
Kernel modules: rtl8192ce

He buscado mucho en los foros de ayuda y he probado todo esto:

1. Probé con:
sudo modprobe rtl8192ce
sudo ifconfig wlan0 up

Y aparece el siguiente mensaje:
SIOCSIFFLAGS: Operación imposible por estar la radiofrecuencia desactivada.

2. Revisé también y en "Controladores Adicionales" no existe ningun software privativo

3. Busqué en la documentación y encontré esto, pero no lo entiendo del todo, el fabricante si tiene el controlador pero no sé si sea ese el problema.
https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetwo...

3. Seguí buscando y al ejecutar el comando rfkill list la consola muestra lo sig:
0: dell-wifi: Wireless LAN
Softblocked: yes
Hardblocked : yes
1: phy0: Wireless LAN
Softblocked: no
Hardblocked : yes

Ejecuté también el comando sudo rfkill unblock all y no muestra nada.

He llegado a la conclusión que el problema es el Hardware pero no tengo idea de como resolverlo, para empezar no sé ni como abrir la Netbook y si la tarjeta de red tiene algun interruptor físico para activarlo..... u_u necesito ayuda, acabo de empezar a usar Ubuntu y no quiero dejarlo.

Imagen de Lacasito
+1
+1
-1

Prueba con el comando rfkill por si está bloqueada

http://xenodesystems.blogspot.com.es/2011/05/rfkill-paquete-indispensabl...

Perdona, no presté atención al final de tu post.
Imagino que miraste con rfkill list all para ver cómo estaban de bloqueados. Si es que lo estaban.

+1
+1
-1

*** ### ***
Ubuntu User #11237

Imagen de ggeloisa
+1
0
-1

Lo leí pero era lo que ya había hecho, lo volvi a probar y reinicié una y otra vez, el resultado es el mismo:

0: dell-wifi: Wireless LAN
Softblocked: yes
Hardblocked : yes
1: phy0: Wireless LAN
Softblocked: no
Hardblocked : yes

Seguiré buscando, muchas gracias por interesarte.

+1
0
-1

ggelois@

Imagination is more important than knowledge :)
Imagen de raptor74
+1
0
-1

Que tal ggeloisa... No soy ningun experto pero cabe destacar que a veces lo mas absurdo puede ser la solucion!!! Ya Probaste con el demas teclado para tratar de activarlo???

Las teclas de funcion cambian de teclado a teclado y en algunos casos tienes una tecla para subir volumen y otra para bajar y en otros con la misma tecla y la flechas subes o bajas!!!

Acabo de instalar ubuntu 12.04lts en una lap presario y me asigno el teclado de funciones como le dio su gana, asi que pudiera ser tu caso, una tecla para apagar y otra para encender...

Prueba con convinaciones de teclas y las flechas...

Suerte y que soluciones tu problema pronto...

+1
0
-1
Imagen de ggeloisa
+1
0
-1

Es buena idea intentar con algo simple que a veces puede resolverlo pero en este caso no funcionó u_u presioné todas las teclas de función con varias combinaciones y nada!... Al parecer todas las teclas de función hacen la función correcta, menos esa, es algo muy extraño mi problema.
De cualquier modo gracias :)

+1
0
-1

ggelois@

Imagination is more important than knowledge :)
Imagen de Scorpyo82
+1
0
-1

Las teclas de función que yo sepa son transmitidas como eventos ACPI.
Podrías intentar a instalar el resto de soporta para acpi:
sudo apt-get install acpi-support acpitool

Luego reinicia e intenta ver si ya funciona.

Si no funciona, intenta buscar un programa para reasignar teclas FN, que seguro los hay, o encontrar el key code que activa y desactiva tu wifi, seguro que tiene que haber una lista con los keyCodes para las Funciones de DELL.
Un saludo y suerte.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de ggeloisa
+1
0
-1

Instalé el paquete pero no funcionó, después de vagar y navegar por la red encontré un post en esta página http://www.geekmind.net/2011/01/linux-wifi-operation-not-possible-due.html , y probé varias opciones que pusieron en los comentarios.
Hice esto

sudo rmmod dell_laptop
sudo rfkill unblock all
sudo rmmod dell_laptop

sudo rmmod -f rtl8192ce
sudo rfkill unblock all
sudo modprobe rtl8192ce

Y el ejecutar rfkill list hubo este cambio:

4: phy0: Wireless LAN
Soft blocked:no
Hard blocked: yes

Seguí leyendo y encontré la solución: resetear la BIOS :) esto a mi me funcionó y ya después de que se activó el Wifi sólo agregué la conexión desde el network manager n_n.

El problema es que si la desactivo, desde la barra negra en la parte superior (ignoro su nombre) queda como antes y tengo que volver a ejecutar todo lo anterior y resetear la BIOS, si no ejecuto los comandos o no reseteo no funciona. El problema principal quedó resuelto pero me gustaría resolverlo completamente.

+1
0
-1

ggelois@

Imagination is more important than knowledge :)
Imagen de Scorpyo82
+1
0
-1

Humm ¿no habrá nada en la BIOS para anular la desconexión del wifi?

En realidad, como bien dices es un historia grande el tener que resetear la BIOS cada vez que por lo que sea, anules el wifi.

El caso es que si lo anulas por soft, no entiendo porqué tienes que reiniciar la BIOS.... valiente historia.
Yo uso ese driver mismo para mi tarjeta, la rtl8191Se
Pero no entiendo como usas tu ese mismo para tu tarjeta.... cuando el que hay en la página oficial para tu tarjeta es el:
http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=48&...

Fíjate bién, es el primero que sale en el enlace que te pongo, el primero de arriba no, el primero que sale... esque es un enlace de esos que te apunta a un lugar en concreto de la página.

Es el modelo tuyo exacto.
Si ubuntu te adjudicó el que tienes, supongo que será genérico, si lo bajaste tu, desinstálalo y compila el nuevo.
Si quieres probar este otro módulo, coloca en la lista negra al módulo rlt8192 y compila el nuevo.

Otra cosa no se me ocurre ahora mismo.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.