¿¿Instalar compat-wireless para kernel 3.2.0-25??

Imagen de aullidos
0 puntos

Buenas tardes, a ver si alguien puede hecharme una mano que no soy ningun experto y me meto en cada lio...

Estoy intentando hacer funcionar el aircrack que ya había utilizado varias veces desde otras versiones linux más antiguas, me surgio el (parece que típico) error de Fixed channel mon0 -1. He seguido este tuto que parece sencillo:
http://www.ubuntu-es.org/node/161399

1.- Escribimos en la terminal sudo apt-get install linux-headers-$(uname -r) para saber nuestro kernel.

2.- Bajamos el paquete que corresponde a nuestra versión (3.02 en mi caso), ----en mi caso sería
3.2.0-25 ---

http://wireless.kernel.org/en/users/Download/stable/ y lo descomprimimos en nuestra carpeta personal.

3.- Escribimos en la terminal, cd compat-wireless-3.0-2. imagino aqui tengo que escribir la carpeta que me bajo y extraigo,

4.- Después, wget http://patches.aircrack-ng.org/channel-negative-one-maxim.patch

5.- Luego, sudo apt-get install patch

6.- Seguimos, patch ./net/wireless/chan.c channel-negative-one-maxim.patch

7.- make

8.- sudo make install

9.- sudo make unload

10.- Y finalmente, sudo reboot.

Pero a la hora de descargarme el compat-wireless me doy cuenta que no existe para mi versio? concreta, y lo he buscado por otros lares pero no se como seguir... he probado la version 3.2.5 pero no consigo nada y el error en aircrack-ng sigue apareciendo.

A ver si alguien puede echarme una manita y me ayuda...