problema al intentar instalar paquete gcc-4.6_4.6.3-1ubuntu5_i386.deb (solucionado)

Desde el gestor de paquetes tengo un problema, así que decidí instalar uno de los que no se me actualiza manualmente, uno de ellos es el paquete : gcc-4.6_4.6.3-1ubuntu5_i386.deb

lo baje y procedí a instalarlo pero me da el siguiente mensaje

sudo dpkg -i gcc-4.6_4.6.3-1ubuntu5_i386.deb
dpkg: error al procesar gcc-4.6_4.6.3-1ubuntu5_i386.deb (--install):
gcc-4.6:i386 4.6.3-1ubuntu5 (Multi-Arch: no) is not co-installable with gcc-4.6:amd64 4.6.3-1ubuntu5 (Multi-Arch: no) which is currently installed
Se encontraron errores al procesar:
gcc-4.6_4.6.3-1ubuntu5_i386.deb

Luego obtuve una lista de los paquetes gcc que tengo instalados

sudo dpkg -l | grep gcc

ii gcc 4:4.6.3-1ubuntu5 GNU C compiler
ii gcc-4.5 4.5.3-12ubuntu2 The GNU C compiler
ii gcc-4.5-base 4.5.3-12ubuntu2 The GNU Compiler Collection (base package)
ii gcc-4.6 4.6.3-1ubuntu5 GNU C compiler
ii gcc-4.6-base 4.6.3-1ubuntu5 GCC, the GNU Compiler Collection (base package)
ii gcc-4.7-base 4.7.1-5 GCC, the GNU Compiler Collection (base package)
ii lib32gcc1 1:4.6.3-1ubuntu5 GCC support library (32 bit Version)
ii libgcc1 1:4.7.1-5 GCC support library

¿como solucionar el problema?

saludos,

Imagen de LyingB
+1
0
-1

Tienes una arquitectura de 64 bits (amd_64) y estás intentando instalar un x86 (i686).

Puedes intentar desintalar el gcc que ya tienes e instalar el paquete que bajaste. Aunque no sé para qué usas un paquete descargado de esa manera.

Sería más conveniente arreglar los problemas que tengas en el gestor para evitarte problemas.

+1
0
-1


Agrega al final del título del post (solucionado) si has arreglado tu problema.

Imagen de William Hernández
+1
0
-1

hay que comentar la siguiente linea en foreign-architecture i386 en /etc/dpkg/dpkg.cfg, de esa menara el gestor de actualizaciones no ofrecerá paquetes i386.

saludos.

+1
0
-1

Will