problemas con instalación de Teamviwer7 y skype 4 en Ubuntu 12.04 amd64 [solucionado]

Hola,

He estado peleando con instalar estos paquetes y al parecer es problemas de dependencias, y he reducido la probables paquetes que se necesitan hasta acá: ya verifique y al menos ya no tengo paquetes rotos. ¿alguna solución?

saludos,

/Descargas$ sudo apt-get install default-jre-headless libgcc1:i386 libc6:i386 libx11-6:i386 libxext6:i386 libxtst6:i386
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
default-jre : Depende: openjdk-6-jre (>= 6b23~pre11-1ubuntu1~) pero no va a instalarse
default-jre-headless : Depende: openjdk-6-jre-headless (>= 6b23~pre11-1ubuntu1~) pero no va a instalarse
libgcc1 : Rompe: libgcc1:i386 (!= 1:4.7.1-5) pero 1:4.6.3-1ubuntu5 va a ser instalado
libgcc1:i386 : Rompe: libgcc1 (!= 1:4.6.3-1ubuntu5) pero 1:4.7.1-5 va a ser instalado
E: Error, pkgProblemResolver::Resolve generó cortes, esto puede haber sido causado por paquetes retenidos.
whernandez@itzalco:~/Público/Descargas$ sudo apt-get install openjdk-6-jre openjdk-6-jre-headless default-jre-headless libgcc1:i386 libc6:i386 libx11-6:i386 libxext6:i386 libxtst6:i386
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
openjdk-6-jre ya está en su versión más reciente.
openjdk-6-jre-headless ya está en su versión más reciente.
fijado openjdk-6-jre-headless como instalado manualmente.
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
libgcc1 : Rompe: libgcc1:i386 (!= 1:4.7.1-5) pero 1:4.6.3-1ubuntu5 va a ser instalado
libgcc1:i386 : Rompe: libgcc1 (!= 1:4.6.3-1ubuntu5) pero 1:4.7.1-5 va a ser instalado
E: Error, pkgProblemResolver::Resolve generó cortes, esto puede haber sido causado por paquetes retenidos.

Imagen de William Hernández
+1
0
-1

Bueno me metí en un gran lío y hago mea culpa que fue con merito propio, pero agrego que paso para que alguien más no vaya a meter la pata.

Sucedió que antes de pasar de 11.10 a 12.04 vía upgrade, puse un post que el gestor de actualizaciones no me ofrecía el upgrade, luego encontré la solución vendo notas aclaratorias del upgrade donde indicaba que la linia "foreign-architecture i386" en "/etc/dpkg/dpkg.cfg.d/multiarch" había que comentarla y luego hacer correr el gestor de actualizaciones y efectivamente ahí si me apareció. Lo siguiente fue el inicio del futuro desastre, ya que al desactivar esa línea se evita que se carguen paquetes "multiarch" , que dicho de paso los paquetes adm64 utilizan y son necesarios algunos de ellos porque algunos programas aunque esten empaquetados como .deb para 64 bits, hacen uso de esos paquetes i386 (ejemplo skype y teamviewer). Lo que creo que debí hacer antes de empezar a actualizar fue des-comentar de nuevo "foreign-architecture i386", ya que en el proceso de instalación no las actualizo, y para más ya cuando tenia todo trabajando en Precise, como vi que no corría desde el lanzador Teamviewer y Skype los desinstale para volver a instalar; resultado: un completo desastre ya que al des-instalarlos borro algunos paquetes multiarch y rompio dependencias, y luego al querer des-instalarlos empecé a instalar algunas dependencia (para aumentar el desastre).

Así que como resultado de todo ese desastre el sistema empezó a desestabilizarse a tal punto que al reiniciar solo pude entrar a modo texto (a dios gracias, pude montar un disco que estaba reparando con una herramienta de “Hiren's CD”, y aunque no había terminado de reparar (le faltaban 50Gb de 500Gb, a hechos desesperados, medidas desesperadas), logre hacer backup e instalar Pricese desde cero, y de paso crear una partición home separa del raíz.

Al final tengo instalado skype y teamviewer pero tuve que instalar ia32-libs multiarch (este esta hecho para amd64 e instala los i386 necesarios para que se instalen algunos programas que dependen de ellos).

Saludos,

+1
0
-1

Will