Error al iniciar eclipse

Imagen de mu0991
0 puntos

Hola, instalé eclipse desde el centro de software de ubuntu y al terminar la instalación, al ejecutarlo me mandó un error

An error has occurred. See the log file
/home/musta/.eclipse/org.eclipse.platform_3.7.0_155965261/configuration/1342474248615.log.

Esto es lo que contiene el archivo 1342474248615.log

!SESSION 2012-07-17 10:18:03.494 -----------------------------------------------
eclipse.buildId=I20110613-1736
java.version=1.7.0_05
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=es_MX
Command-line arguments: -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.osgi 4 0 2012-07-17 10:18:08.599
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
no swt-gtk-3740 in java.library.path
no swt-gtk in java.library.path
Can't load library: /home/musta/.swt/lib/linux/x86_64/libswt-gtk-3740.so
Can't load library: /home/musta/.swt/lib/linux/x86_64/libswt-gtk.so

at org.eclipse.swt.internal.Library.loadLibrary(Library.java:285)
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:194)
at org.eclipse.swt.internal.C.(C.java:21)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
at org.eclipse.swt.widgets.Display.(Display.java:132)
at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:695)
at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
at org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(IDEApplication.java:153)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:95)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:601)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
at org.eclipse.equinox.launcher.Main.main(Main.java:1386)

Tiene que ver con al del GTK

Gracias.

Imagen de ubunuser
+1
0
-1

proba con eso, yo siempre que instalo algo de ahy me anda

+1
0
-1
Imagen de ubunuser
+1
0
-1

segun eclipse e lunico requisito es tener el paquete jre

+1
0
-1
Imagen de jorge_sat5129215
+1
+1
-1

…. y ya has solucionado el problema.

Pero bien, si alguien se encuentra en la misma situación mirar el post "sun-java6-jre no está disponible ..."

http://www.ubuntu-es.org/node/165246#.ULoQdKrWD3z

y hacer lo que pone el comentario: "No existen mas"

para así instalar el paquete de java que falta para que arranque Eclipse (supongo que si aparece este problema se trata de la versión Ubuntu 12.04 o de la sucesiva).

Otra forma de decirlo sería:

1° abrir el terminal
2° sudo su
3° apt-get install openjdk-6-jre icedtea-6-jre-cacao default-jre default-jre-headless openjdk-6-jre-lib openjdk-6-jre-headless

cuando termine el proceso abrir Eclipse y ya no saldrá el mensaje de error

Saludos

+1
+1
-1
Imagen de Diego Cuenca
+1
0
-1

a mi si me funciono con este comando...
gracias!!
x sierto soy nuevo en estos foros, aunq sin una cuenta ya m habían ayudado anteriormente..jjjj
además nunka había trabajado con Eclipse y x cuestiones d estudio m tocá, solo he usado netbeans...

+1
0
-1

D.C.