no abre synaptic ( solucionado)

Imagen de optofer
0 puntos

Hola hace unos dias que decidi dejar de usar el centro de software de ubuntu y volver a utilizar synaptic que siempre me funciono bien pero me encontre que no me abre y me tira este mensaje de error

"E: El valor «maverick» es inválido para APT::Default-Release dado que esa versión no está disponible en los orígenes
E: _cache->open() failed, please report."

Si lanzo synaptic desde el terminal sin privilegios abre pero si lo lanzo con sudo synaptic me tira el mismo error
revise mi surces.list pero no veo nada malo en ellla
la verdad no veo de donde sera el problema me dan una mano alguna idea

Imagen de mimecar
+1
0
-1

Ubuntu 10.10 es una versión que ya no tiene soporte. Deberás actualizar si quieres tener actualizaciones de seguridad y de los programas.

+1
0
-1

Web: http://www.innerzaurus.com. IRC: red Freenode, canal #ubuntu-es

Imagen de optofer
+1
0
-1

No te esplico tengo instalado ubuntu 12.04 esto es algo que quedo de mi antigua 10.10

+1
0
-1
Imagen de rioport
+1
0
-1

el archivo /etc/apt/apt.conf , o el contenido de los archivos que hay en /etc/apt/apt.conf.d.

+1
0
-1

-- GC --

Imagen de optofer
+1
0
-1

te dejo lo que encontre dentro de esoso archivos

fernanado@fernanado-System-Product-Name:/etc$ cd apt
fernanado@fernanado-System-Product-Name:/etc/apt$ ls
apt.conf.d sources.list~ sources.list.save trusted.gpg~
preferences.d sources.list.d trustdb.gpg trusted.gpg.d
sources.list sources.list.distUpgrade trusted.gpg
fernanado@fernanado-System-Product-Name:/etc/apt$ cd apt.conf.d
fernanado@fernanado-System-Product-Name:/etc/apt/apt.conf.d$ ls
00trustcdrom 10periodic 20changelog 70debconf
01autoremove 15update-stamp 20dbus 99synaptic
05aptitude 20archive 50unattended-upgrades 99update-notifier
fernanado@fernanado-System-Product-Name:/etc/apt/apt.conf.d$

+1
0
-1
Imagen de rioport
+1
0
-1

¿Y qué hay dentro de esos archivos? pues no te pedí que me listaras los archivos, busca si hay alguna linea que haga referencia a:

APT::Default-Release

+1
0
-1

-- GC --

Imagen de optofer
+1
0
-1

ok estoy en eso

+1
0
-1
Imagen de optofer
+1
0
-1

aca adentro e estos no esta

fernanado@fernanado-System-Product-Name:/etc/apt$ cd apt.conf.d
fernanado@fernanado-System-Product-Name:/etc/apt/apt.conf.d$ ls
00trustcdrom 10periodic 20changelog 70debconf
01autoremove 15update-stamp 20dbus 99synaptic
05aptitude 20archive 50unattended-upgrades 99update-notifier

dentro de preferences.d no hay nada
fernanado@fernanado-System-Product-Name:/etc/apt/preferences.d$ ls
fernanado@fernanado-System-Product-Name:/etc/apt/preferences.d$
revise los otros uno por uno pero no encontre nada parecido

+1
0
-1
Imagen de optofer
+1
0
-1

Creo que encontre la fuente de mi problema el tema es como lo arreglo borro todo este fichero ?que pongo en su lugar¿

fernanado@fernanado-System-Product-Name:/etc/apt$ cd sources.list.d
fernanado@fernanado-System-Product-Name:/etc/apt/sources.list.d$ ls
canonical-partner-maverick.list
canonical-partner-maverick.list.distUpgrade
canonical-partner-maverick.list.save
clipgrab-team-ppa-maverick.list
clipgrab-team-ppa-maverick.list.distUpgrade
clipgrab-team-ppa-maverick.list.save
dtl131-ppa-oneiric.list
dtl131-ppa-oneiric.list.distUpgrade
dtl131-ppa-oneiric.list.save
nilarimogard-webupd8-oneiric.list
nilarimogard-webupd8-oneiric.list.distUpgrade
nilarimogard-webupd8-oneiric.list.save
private-ppa.launchpad.net_commercial-ppa-uploaders_corebreach-demo_ubuntu.list
private-ppa.launchpad.net_commercial-ppa-uploaders_corebreach-demo_ubuntu.list.distUpgrade
private-ppa.launchpad.net_commercial-ppa-uploaders_corebreach-demo_ubuntu.list.save
sevenmachines-flash-oneiric.list
sevenmachines-flash-oneiric.list.distUpgrade
sevenmachines-flash-oneiric.list.save
sevenmachines-flash-precise.list
sevenmachines-flash-precise.list.save
fernanado@fernanado-System-Product-Name:/etc/apt/sources.list.d$ ls

+1
0
-1
Imagen de optofer
+1
0
-1

la verdad crei que estos archivos eran el problema pero creo que me equivoque

+1
0
-1
Imagen de rioport
+1
0
-1

Prueba lo siguiente:

sudo su
cat /root/.synaptic/synaptic.conf

+1
0
-1

-- GC --

Imagen de optofer
+1
0
-1

Esto es lo que obtuve

root@fernanado-System-Product-Name:/home/fernanado# cat /root/.synaptic/synaptic.conf
Synaptic "" {
ViewMode "2";
showWelcomeDialog "0";
update "" {
last "1305073889";
type "0";
};

vpanedPos "565";
hpanedPos "264";
windowWidth "1280";
windowHeight "744";
windowX "0";
windowY "24";
ToolbarState "2";
Maximized "1";
Install-Recommends "1";
closeZvt "true";
LastSearchType "1";
ShowAllPkgInfoInMain "false";
AskRelated "true";
OneClickOnStatusActions "false";
delAction "3";
upgradeType "1";
undoStackSize "20";
UseTerminal "false";
AskQuitOnProceed "false";
useUserFont "0";
useUserTerminalFont "0";
statusColumnPos "0";
statusColumnVisible "1";
supportedColumnPos "1";
supportedColumnVisible "1";
nameColumnPos "2";
nameColumnVisible "1";
sectionColumnPos "3";
sectionColumnVisible "0";
componentColumnPos "4";
componentColumnVisible "0";
instVerColumnPos "5";
instVerColumnVisible "1";
availVerColumnPos "6";
availVerColumnVisible "1";
instSizeColumnPos "7";
instSizeColumnVisible "1";
downloadSizeColumnPos "8";
downloadSizeColumnVisible "0";
descrColumnPos "9";
descrColumnVisible "1";
color-install "#8A8AE2E23434";
color-reinstall "#4E4E9A9A0606";
color-upgrade "#FCFCE9E94F4F";
color-downgrade "#ADAD7F7FA8A8";
color-remove "#EFEF29292929";
color-purge "#A4A400000000";
color-available "";
color-available-locked "#A4A400000000";
color-installed-updated "";
color-installed-outdated "";
color-installed-locked "#A4A400000000";
color-broken "";
color-new "";
UseStatusColors "true";
CleanCache "false";
AutoCleanCache "true";
delHistory "-1";
useProxy "0";
httpProxy "";
httpProxyPort "3128";
ftpProxy "";
ftpProxyPort "3128";
noProxy "";
DefaultDistro "maverick";
};

+1
0
-1
Imagen de rioport
+1
0
-1

Abre Synaptic y ve a:
Ajustes > Preferencias > Distribución
Y déjalo en "Siempre preferir la versión más alta" (es la primera opción).

+1
0
-1

-- GC --

Imagen de optofer
+1
0
-1

Si abro synaptic desde un terminal sin privilegios se abre y desde alli cambie a "siempre preferir la vercion mas alta"
Pero cuando entro con privilegios no abre me tira este anuncio

"E: El valor «maverick» es inválido para APT::Default-Release dado que esa versión no está disponible en los orígenes
E: _cache->open() failed, please report."

+1
0
-1
Imagen de optofer
+1
0
-1

Soy reacio a forzar soluciones pero sera la mejor opcion reinstalar synaptic

+1
0
-1
Imagen de rioport
+1
0
-1

La reinstalación no te va a servir. Si no puedes abrir Synaptic entonces has lo siguiente:

sudo su
rm -f /root/.synaptic/synaptic.conf

Y vuelve a intentar.

+1
0
-1

-- GC --

Imagen de optofer
+1
0
-1

Gracias rioport sos un genio.

+1
0
-1