Problemas con mi gestor de actualizaciones y mi centro de software en ubuntu. (12.04)

Imagen de MimoGomez
0 puntos

Buena noche,

Hoy intente descargar eclipse en el centro de software, pero me llevé una sorpresa al ver que me decía que no se podían instalar ni desinstalar elementos hasta que se repara el catalogo de paquetes, efectivamente le di reparar pero luego me arrojó el siguiente mensaje... "fallo la operación del paquete"...

Pensé en algún momento que tenía que actualizar mi centro de software en el centro de actualizaciones, ingrese y ahí me llevé otra sorpresa, le dí instalar actualizaciones y me arrojo lo siguiente...

"El paquete de sistema está roto
compruebe si esta usando repositoris de terceros. en tal caso, desactivelos ya que son una fuente habitual de problemas. Posteriormente, ejecuté el siguente comando en un terminal: apt-get install -f"

Cerré todos los programas, luego me dirigí a abrir la terminal y ejecutar el comando.

Me arrojá lo siguiente:

"E: No se pudo abrir el fichero de bloqueo «/var/lib/dpkg/lock» - open (13: Permiso denegado)
E: No se encontró un archivo de réplica «/var/lib/dpkg/» "

La verdad no se que hacer y me siento un poco confundido, que me pueden recomendar?...

Gracias!

Imagen de Jose Luis 1320
+1
0
-1

Abre Terminal y escribe:

sudo apt-get install -f

Escribe tu contraseña, no verás lo que escribes, es normal y ya.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de MimoGomez
+1
0
-1

Lo hice y pasa lo siguiente...

sudo apt-get install -f
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
libsnack2-alsa libqt4-dbg tcl-tls
Utilice «apt-get autoremove» para eliminarlos.
Se instalarán los siguientes paquetes extras:
libqt4-dbg
Se actualizarán los siguientes paquetes:
libqt4-dbg
1 actualizados, 0 se instalarán, 0 para eliminar y 70 no actualizados.
1 no instalados del todo o eliminados.
Se necesita descargar 0 B/59,1 MB de archivos.
Se utilizarán 0 B de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? S
dpkg: problemas de dependencias impiden la configuración de libqt4-dbg:
libqt4-dbg depende de libqtcore4 (= 4:4.8.1-0ubuntu4.1); sin embargo:
La versión de `libqtcore4' en el sistema es 4:4.8.1-0ubuntu4.2.
dpkg: error al procesar libqt4-dbg (--configure):
problemas de dependencias - se deja sin configurar
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
Se encontraron errores al procesar:
libqt4-dbg
E: Sub-process /usr/bin/dpkg returned an error code (1)

+1
0
-1
Imagen de Goyo
+1
0
-1

Prueba con autoremove:
sudo apt-get autoremove

+1
0
-1
Imagen de requene
+1
0
-1

1.-Esos erros de las actualizaciones me pasan a mi a diario prueba lo siguiente ingresa al Gestor Synaptic/Configuración/repositores. Este punto en la parte de abajo cambias el servidor que tengas por servidor principal creo que se guardan los cambio luego recargar, lueactualizar a mi simpre me funciona.

2.-Prueba, ingresa al GRUB/ opcion reparar paquetes rotos. haber que pasa.

3.-sudo apt-get update
y si todo va bien
sudo apt-get dist-upgrade

Espero que se soluciones

+1
0
-1

Simpre Ubuntiando

Imagen de Jose Luis 1320
+1
0
-1

También tu requene, esos problemas pasan cuando tienes repositorios extras que son conflictivos.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de requene
+1
0
-1

Bueno lo voy a tomar muy encuenta por que yo instalo todo lo que se me presente he llevado a Ubunto a sus limites.

Gracias

+1
0
-1

Simpre Ubuntiando

Imagen de MimoGomez
+1
0
-1

Siguiendo el consejo de Goyo me acerqué mucho a la solución final del problema...
sudo apt-get autoremove

Lo único que agregue de más fue un -f y todo comenzó a funcionar perfectamente...
sudo apt-get autoremove -f

A todos muchas gracias por sus consejos, buena noche...

+1
0
-1