RESUELTO: Problema Bluetooth No encuentra Dispositivos.

Imagen de darkm1st
0 puntos

Hola, tengo un Acer Aspire s3-951, que hasta el momento ha funcionado todo de manera muy buena, a excepción del bluetooth que me a dado bastante que trabajar. La cosa es que aparece como si funcionara, pero al momento de buscar o ser buscado no encuentra nada. Probé la solución indicada en este foro,
http://ubuntuforums.org/showpost.php?p=11590067&postcount=25 la cual indica que hay que parchar el kernel modificando dos archivos drivers/bluetooth/ath3k.c y drivers/bluetooth/btusb.c. para luego compilar el kernel, el primer problema con que me encuentro al aregar las lineas en estos dos archivos, es que ya existen, por lo tanto no sirve de nada copilar el kernel ya que ya estan cargadas esas lineas en el kernel que ocupo.
Estoy usando Ubuntu 12.04 3.2.0-29-generic, cualquier otra información que necesiten pidanla si es necesario obtenerla através de algún comando indiquenmelo por favor ya que soy algo novato, muchas gracias.

En terminal:
usb-devices:
T: Bus=01 Lev=02 Prnt=02 Port=03 Cnt=01 Dev#= 3 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=e0(wlcon) Sub=01 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=04ca ProdID=3004 Rev=00.01
S: Manufacturer=Atheros Communications
S: Product=Bluetooth USB Host Controller
S: SerialNumber=Alaska Day 2006
C: #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb
I: If#= 1 Alt= 0 #EPs= 2 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb

lsusb:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 04ca:3004 Lite-On Technology Corp.
Bus 001 Device 004: ID 1bcf:2c00 Sunplus Innovation Technology Inc.
Bus 002 Device 003: ID 0bda:0129 Realtek Semiconductor Corp.

EDIT: la solucion a mi problema era bastante simple, habia que seguir el tutorial en esta pagina http://ubuntuforums.org/showpost.php?p=11590067&postcount=25 y simplemente cambiar el numero de disositivo que se va a agregar, en mi caso al hacer lsusb, me reportaba que el BT era reconocido como 04ca:3004 remplzando este por el que se daba en el tutorial tuve exito haciendo andar el BT, reconociendo dispositivos, conectandose y intercambiando archivos.