No puedo instalar Skype 4 ni Google Earth en Ubuntu 12.04.1 x64

Imagen de elcam225
0 puntos

Hola, que tal?... esta es mi primer consulta en esta grandiosa pagina...
Soy usuario reciente de Ubuntu 12.04, digamos que en proceso de migración desde Windown... Ya he usado bastante a Ubuntu y leído mucha documentación que me ha ayudado a resolver variados problemas... En algunos casos la solución elegida fue reinstalar... Pero este no es el caso, ya que he instalado muy valiosos programas, lo que me ha demandado tiempo encontrarlos e instalarlos y honestamente no quiero volver a pasar por ello... En fin:

2 programas que uso habitualmente en W$ y quiero tener en Ubuntu: Skype y Google Earth
Problema: me encontré con varias trabas para instalarlos:
A Skype:
-Desde el Centro de Software me sale este mensaje luego de intentar descargarlo:
"Las dependencias del paquete no se pueden resolver, Este error podría deberse a que se
necesitan paquetes de software adicionales que faltan o que no son instalables. También podría
ser un conflicto entre paquetes de software que no pueden instalarse juntos.
Detalles> Los siguientes paquetes tienen dependencias incumplidas:
skype: Depends: skype-bin pero es un paquete virtual"

-Desde el terminal:
"~$ sudo apt-get install skype
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
skype : Depende: skype-bin
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos."

A Google Earth:
-Luego de descargar "google-earth-stable_current_amd64.deb" desde la pagina de Google
earth y abrirlo con el Centro de Software:
Mensaje de error: "No se pudo instalar "ia32-libs""

-Desde el terminal: (segun la info que encontre de como instalarlo para 64bit en 3 pasos)
Primero: "~$ wget http://dl.google.com/dl/earth/client/current/google-earth stable_current_amd64.deb
--2012-09-10 08:44:15-- http://dl.google.com/dl/earth/client/current/google-earth-
stable_current_amd64.deb
Resolviendo dl.google.com (dl.google.com)... 173.194.42.2, 173.194.42.14, 173.194.42.9, ...
Conectando con dl.google.com (dl.google.com)[173.194.42.2]:80... conectado.
Petición HTTP enviada, esperando respuesta... 200 OK
Longitud: 25609162 (24M) [application/x-debian-package]
Grabando a: “google-earth-stable_current_amd64.deb”
100%[======================================>] 25.609.162
2012-09-10 08:44:48 (768 KB/s) - “google-earth-stable_current_amd64.deb” guardado
[25609162/25609162]"

Segundo: "~$ sudo dpkg -i google-earth-stable_current_amd64.deb
[sudo] password for elcam225:
Seleccionando paquete google-earth-stable previamente no seleccionado
(Leyendo la base de datos ... 198073 ficheros o directorios instalados actualmente.)
Desempaquetando google-earth-stable (de google-earth-stable_current_amd64.deb) ...
dpkg: problemas de dependencias impiden la configuración de google-earth-stable:
google-earth-stable depende de ia32-libs; sin embargo:
El paquete `ia32-libs' no está instalado.
dpkg: error al procesar google-earth-stable (--install):
problemas de dependencias - se deja sin configurar
Procesando disparadores para menu ...
Procesando disparadores para man-db ...
Procesando disparadores para desktop-file-utils ...
Procesando disparadores para bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Procesando disparadores para gnome-menus ...
Se encontraron errores al procesar:
google-earth-stable"

Tercero (segun el tutorial que lei, este comando es "para resolver algunos problemas y forzar las dependencias no cumplidas"):
~$ sudo apt-get install -f
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Los siguientes paquetes se ELIMINARÁN:
google-earth-stable
0 actualizados, 0 se instalarán, 1 para eliminar y 0 no actualizados.
1 no instalados del todo o eliminados.
Se liberarán 109 MB después de esta operación.
¿Desea continuar [S/n]? s
(Leyendo la base de datos ... 198402 ficheros o directorios instalados actualmente.)
Desinstalando google-earth-stable ...
Procesando disparadores para desktop-file-utils ...
Procesando disparadores para bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Procesando disparadores para gnome-menus ...
Procesando disparadores para man-db ...
Procesando disparadores para menu ...

Y listo! nada mas aparece!...
Según la información que he podido encontrar, llegue a la conclusión que todo tiene que ver con "ia32-libs" ¿alguien puede decirme que es eso?... probé instalarlo desde la terminal y esto me salio:
"~$ sudo apt-get install ia32-libs
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
ia32-libs : Depende: ia32-libs-multiarch
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos."

Después de buscar y buscar y buscar la solución a esto, lo único que encontré fue reinstalar!, y me parece totalmente innecesario, y pienso que no es la única solución...
Espero que al abrir este tema también se pueda ayudar a quienes tuvieron problemas con Skype, con Google Earth y con la "ia32-libs" en su querido Ubuntu 12.04

Disculpen si se hizo muy largo el mensaje, puesto que mi intención es encontrar una solución y tratar de ayudar como se pueda a quienes tengan los mismos problemas, razones por las que abrí este tema... he visto que muchos también tienen problemas con "ia32-libs" que no han podido resolver...

Gracias de antemano al o los benditos Linuxeros y/o Ubunteros que echen un poco de luz a tanta oscuridad, y gracias de antemano a todos los que aporten su granito de arena...

Me voy xq llego tarde al trabajo jajaj :D
Saludos! ;)

Imagen de elcam225
+1
+1
-1

Me da gracia una cosa... le di la vuelta al mundo tratando de resolver esto, y no, ojo!, no fue en vano... gracias a eso llegue a esto: logre resolver tantos inconvenientes (que me impedían instalar Skype, Google Earth, y ahora agrego Wine) que en común tenían fallas con dependencias faltantes, o posibles paquetes erróneos, yo que se!...
En fin que hice fue ir a Orígenes del Software, en Ubuntu 11.10 lo buscan en inicio o como le dicen "dash", y en el 12.04 esta el Centro de Software> Menú Editar> Orígenes del Software y una vez que entran en la primer pestaña "Software de Ubuntu" van a donde dice "Descargar desde" y cambian el servidor que tengan puesto por "Servidor Principal", luego salen y van al "Gestor de Actualizaciones" y le dan en "Comprobar"... a mi me encontró 24 actualizaciones (78 Mb creo) que cuando estaba el servidor anterior (de Argentina), el gestor no me las mostraba, y me decía que estaba todo actualizado... Luego me pidió Reiniciar, y una vez hecho esto... Voilà! Todos, todos mis problemas resueltos! pude instalar todos esos programas, y de una forma que me parece no esta mal recomendar como primer posible solución a este tipo de problemas antes de andar metiendo comando tras comando en la terminal, sin estar muy seguros de que va a pasar... no se que opinen??
Yop ahora toy feliz! :D, tengo mi Ubuntu hecho un tanque de guerra!!! con todo lo que necesito.

Nota: En el caso de Google Earth, al paquete "google-earth-stable_current_amd64.deb" lo deje para el ultimo! lo con abrí con Centro de Software luego de instalar todo, porque no me lo tomaba

Saludos gente ;), espero esto ayude a muchos!

+1
+1
-1

"La ignorancia esclaviza, el conocimiento nos hace libres, la libertad nos hace felices, la felicidad (y sólo eso) nos hace tener éxito en la vida..."

Imagen de danieldlo09
+1
+1
-1

Me has salvado mi estudio.
no habia podido instalar el ciscopackettracer533, porque solo esta para arquitecturas de 32bits pero con esto te debo la vida y mi semestre de u!!! jajaja

+1
+1
-1
Imagen de wdelbar
+1
+1
-1

Funcionó a la perfección esta solución, mi servidor estaba para Colombia. ¡Skype funciona!

+1
+1
-1
Imagen de elcam225
+1
0
-1

Me alegro que les haya sido de utilidad... es una solución sencilla a muchos problemas y en mi opinión, es lo primero a lo que se debe acudir!

+1
0
-1

"La ignorancia esclaviza, el conocimiento nos hace libres, la libertad nos hace felices, la felicidad (y sólo eso) nos hace tener éxito en la vida..."

Imagen de anggelmiguel
+1
0
-1

Pues vamos a ver dijo un ciego, jejeje.

Tengo problemas para instalar el Team Viewer en Ubuntu 12.10 ( teamviewer7 depends on ia32-libs) voy a probar esa solución, y al rato te aviso si funciona. De cualquier manera, gracias! Me hiciste recobrar la esperanza en Ubuntu.

+1
0
-1