No puedo instalar paquetes, ya que no puede borrar kernels antiguos

Imagen de seba24000
0 puntos

Hola, este es mi primera pregunta en este foro, les cuento que tengo ubuntu desde hace un mes y medio, en una particion junto con windows, y lo que me pasa es que al tratar de instalar cualquier paquete, sea por terminal,synaptic o centro de software me trata de borrar los kernels antiguos de linux, por ejemplo me queria bajar el gdebi para abrir los archivos DEB sin el centro de software que tanto me molesta, pero me trata de eliminar los kernels antiguos, y dice que retornaron un codigo de error, ademas al tratar de iniciar con verisones de linux antiguas, me dice file not found:

aqui lo que salio en la consola

seba@seba-Aspire-4741:~$ sudo apt-get install gdebi
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes extras:
gdebi-core
Los siguientes paquetes se ELIMINARÁN:
linux-image-3.2.0-23-generic linux-image-3.2.0-27-generic
linux-image-3.2.0-29-generic
Se instalarán los siguientes paquetes NUEVOS:
gdebi gdebi-core
0 actualizados, 2 se instalarán, 3 para eliminar y 6 no actualizados.
3 no instalados del todo o eliminados.
Necesito descargar 185 kB de archivos.
Se liberarán 445 MB después de esta operación.
¿Desea continuar [S/n]? S
Des:1 http://cl.archive.ubuntu.com/ubuntu/ precise/universe gdebi-core all 0.8.5build1 [159 kB]
Des:2 http://cl.archive.ubuntu.com/ubuntu/ precise/universe gdebi all 0.8.5build1 [26,1 kB]
Descargados 185 kB en 1seg. (112 kB/s)
(Leyendo la base de datos ... 186774 ficheros o directorios instalados actualmente.)
Desinstalando linux-image-3.2.0-23-generic ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.2.0-23-generic /boot/vmlinuz-3.2.0-23-generic
update-initramfs: Deleting /boot/initrd.img-3.2.0-23-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.2.0-23-generic /boot/vmlinuz-3.2.0-23-generic
/usr/sbin/grub-mkconfig: 11: /etc/default/grub: splash: not found
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 127
Failed to process /etc/kernel/postrm.d at /var/lib/dpkg/info/linux-image-3.2.0-23-generic.postrm line 328.
dpkg: error al procesar linux-image-3.2.0-23-generic (--remove):
el subproceso instalado el script post-removal devolvió el código de salida de error 1
Desinstalando linux-image-3.2.0-27-generic ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.2.0-27-generic /boot/vmlinuz-3.2.0-27-generic
update-initramfs: Deleting /boot/initrd.img-3.2.0-27-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.2.0-27-generic /boot/vmlinuz-3.2.0-27-generic
/usr/sbin/grub-mkconfig: 11: /etc/default/grub: splash: not found
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 127
Failed to process /etc/kernel/postrm.d at /var/lib/dpkg/info/linux-image-3.2.0-27-generic.postrm line 328.
dpkg: error al procesar linux-image-3.2.0-27-generic (--remove):
el subproceso instalado el script post-removal devolvió el código de salida de error 1
Desinstalando linux-image-3.2.0-29-generic ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.2.0-29-generic /boot/vmlinuz-3.2.0-29-generic
update-initramfs: Deleting /boot/initrd.img-3.2.0-29-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.2.0-29-generic /boot/vmlinuz-3.2.0-29-generic
/usr/sbin/grub-mkconfig: 11: /etc/default/grub: splash: not found
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 127
Failed to process /etc/kernel/postrm.d at /var/lib/dpkg/info/linux-image-3.2.0-29-generic.postrm line 328.
dpkg: error al procesar linux-image-3.2.0-29-generic (--remove):
el subproceso instalado el script post-removal devolvió el código de salida de error 1
Se encontraron errores al procesar:
linux-image-3.2.0-23-generic
linux-image-3.2.0-27-generic
linux-image-3.2.0-29-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
seba@seba-Aspire-4741:~$

Imagen de seba24000
+1
0
-1

muchas gracias por no ayudarme, mejor pregunto en otro lado

+1
0
-1
Imagen de ZoRrO888
+1
0
-1

Si seria bueno que preguntes o te informes en otro lado si no te contestan aquí, lo único que puedo recomendar es que intentes con apt-get autoremove o apt-get autoclean o ya deperdis un apt-get dist-upgrade, que tal vez ya hiciste o no, no se la verdad espero y uno te sirva y si encuentras la respuesta en otro lado te pido que le pongas como le hiciste para que cualquier otro con tu problema no pase tanto tiempo como tu en espera de una solución.

:)

+1
0
-1

Quis custodiet ipsos custodes