Imagen de jcmangas
+1
+1
-1

Bueno, ponga la solución por si a alguien puede servirle.
Después de probar muchas cosas, tanto desde Ubuntu, como Windows, lo he solucionado.
Probé con los comandos en la consola de windows, que veréis por ahí de :

bootrec /fixmbr
bootrec /fixboot y también
bootrec /rebuildbcd
A algunos les funcionó, a mi no. Después de ésto, no podía entrar, ni en Windows, ni Ubuntu.
Para poder entrar al menos en Ubuntu, metía el SuperGrubDisk2 y le daba a detectar S.O. Cuando los detectaba (Windows loader seguía sin aparecer), entraba en Ubuntu y arreglaba el grub (arranque dual de Ubuntu), con los siguientes comandos:

sudo grub-install /dev/sda
sudo update-grub2

Ya tenía de nuevo Ubuntu.
LA SOLUCIÓN:
Entrar con el disco de instalación de Windows (como en mi caso, no lo tenía, me bajé un disco de arranque de W7 64bits de internet). Cuando cargaba, seleccionaba el teclado español y luego en "herramientas de recuparación" y desde ahí, a la consola de comandos y escribí lo siguiente:

DISKPART
LIST VOLUME
SELECT VOLUME 1 (El número 1 es porque en mi caso, es donde estaba C:, debéis poner el número de volumen, donde esté C:)
ACTIVE
Luego reinicié, varias veces, entré de nuevo en "herramientas de recuperación" y elegí, "Arreglar inicio", o algo así, y por fin empezó a arreglarlo y Eureka, conseguido.
Luego volví a actualizar el grub de Ubuntu y ya detectó el Windows loader y ya está.
Me ha agobiado, pero al fin conseguido.

GRACIAS a todos los que se han molestado, seguiré usando ambos S.O. por diferentes razones.
Suerte !!!!!

+1
+1
-1
Imagen de Goyo
+1
+1
-1

Lo que dices no tiene sentido. Si instalaste Ubuntu desde Windows (Wubi) no es grub sino el cargador de arranque de Windows quien debe ofrecer el arranque dual. a través de la opción de Ubuntu creo que se accede a GRUB pero allí ya no tiene por qué aparecer Windows.

+1
+1
-1