Error LibreOffice al instalar

Imagen de Caneklule
0 puntos

Estimados Ubunteros tengo el siguiente problema:

Tengo ubuntu 10.04.

el problema que presento es al instalar libreoffice en su ultima version me sale el siguiente error

Error: Rompe un conflicto del paquete existente 'libreoffice-debian-menus': libreoffice-debian-menus ( )

como puedo arreglar este error en via comandos al instalarlo me sale la sguiente leyenda.

edmundo@zyana-laptop:~$ sudo apt-get install libreoffice-gnome
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
libreoffice-gnome: Depende: libreoffice-core (= 1:3.5.4-0ubuntu1~lucid1) pero no va a instalarse
Depende: libreoffice-gtk pero no va a instalarse
E: Paquetes rotos

Imagen de EnjoyConde
+1
+1
-1

Puede ser por lo que he comentado ya en varios hilos abiertos como estos:
http://www.ubuntu-es.org/node/173161

http://www.ubuntu-es.org/node/173154

Saludos.

+1
+1
-1
Imagen de Goyo
+1
+1
-1

¿Qué pasa si intentas instalar libreoffice-core?

+1
+1
-1
Imagen de Caneklule
+1
0
-1

No amigo me manda la misma leyenda que puse en el foro ejecutandolo desde terminal

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

... que siguiendo las normas:
1- No abuses de mayúsculas (ya edité el título)
2- Des todos los datos respecto de los problemas.

libreoffice-debian-menus, es un paquete de LibreOffice que se instala cuando se hace una instalación manual de LibreOffice desde los archivos deb bajados de su web. Si es así, antes de instalar una nueva versión de LibreOffice, se debe desinstalar la antigua, todos sus paquetes y archivos de configuraciones.

si es que estas instalando desde los repositorios de Ubuntu, ese paquete te ha quedado de antes, así que desinstala la versión anterior y recién entonces instala la nueva.

+1
0
-1
Imagen de wewe
+1
0
-1

Acabo de intentar instalar Libreoffice en Lucid Lynx. Sigo los pasos indicados en la "wiki de Ubuntu. Cuando escribo:

sudo apt-get install libreoffice

obtengo lo siguiente:

Leyendo lista de paquetes...
Creando árbol de dependencias...
Leyendo la información de estado...
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
libreoffice: Depende: libreoffice-core (= 1:3.5.4-0ubuntu1~lucid1) pero no va a instalarse
Depende: libreoffice-writer pero no va a instalarse
Depende: libreoffice-calc pero no va a instalarse
Depende: libreoffice-impress pero no va a instalarse
Depende: libreoffice-draw pero no va a instalarse
Depende: libreoffice-math pero no va a instalarse
Depende: libreoffice-base pero no va a instalarse
Depende: libreoffice-filter-mobiledev pero no va a instalarse
Depende: libreoffice-java-common (>= 1:3.5.4~) pero no va a instalarse
Recomienda: libreoffice-gnome pero no va a instalarse o
libreoffice-kde pero no va a instalarse
E: Paquetes rotos

He intentado resolver alguna de las dependencias, pero con el mismo resultado (evidentemente, los paquetes de los que dependen cambia, pero la cuestión es que siempre parece haber dependencias no resueltas).

Esto ocurre tanto desde el servidor de España como desde el principal. También ocurre igual si lo intento desde el Centro de Software.

¿Alguien tiene alguna información relevante que aportar? ¿Será mejor instalar LibreOffice descargándolo directamente de la página?

Gracias a todos.

+1
0
-1
Imagen de Gabriel_M
+1
+2
-1

... siempre tengo a Firefox y Libreoffice instalados desde los paquetes de sus sitios, así se actualizan permanentemente, no dependo de los ppa para su actualización y no tengo problemas de bibliotecas incompatibles.

+1
+2
-1
Imagen de wewe
+1
0
-1

Gracias por la sugerencia, Gabriel_M. Voy a hacer lo mismo. Sólo una pregunta, cuando dices "instalados desde los paquetes de sus sitios", ¿te refieres a bajar los archivos .tar, decomprimirlos, e instalarlos, o para que se actualicen solos hay que hacer algo más?

De nuevo, muchas gracias, y un gran saludo.

+1
0
-1
Imagen de Gabriel_M
+1
+1
-1

Si, bajar los paquetes .tar.gz descomprimirlos y en el caso de:

Firefox, simplemente copiar el directorio completo a /opt/ y cambiar
los ejecutables en los lanzadores, y recien entonces desinstalar el instalado
por la distribución. Las actualizaciones se efectuan automáticamente al pulsar
ayuda -- Acerca de Firefox

Libreoffice, desinstalar los paquetes instalados por la distribución, descomprimir
el archivo, copiar todos los .deb a un directorio y ejecutar en el

sudo su
dpkg -i *.deb

Luego en Opciones --- Actualizaciones en línea --Marcar lo preferido
Si es una mejora se instala solo, si es un cambio de versión descarga
los paquetes y requiere nueva instalación manual, se incorpora automáticamente
a los lanzadores.

+1
+1
-1
Imagen de wewe
+1
0
-1

Gracias de nuevo.

Un saludo.

+1
0
-1