Ultimo driver de NVIDIA en Linux Mint y Ubuntu

+1
+1
-1

NVIDIA acaba de sacar la actualización de su driver 304.32 para sistemas UNIX, en la que corrige una vulnerabilidad de la versión anterior del controlador que permitía que cualquier usuario local pudiera escalar privilegios en el sistema y así obtener permisos de root.

La vulnerabilidad que afectaba a las series 195, 256 y 304 de los controladores NVIDIA para Linux ya fue solucionada y está disponible desde ya para los usuarios de sistemas Linux, FreeBSD y Solaris. Si eres usuario de Linux Mint o Ubuntu puedes seguir las instrucciones que te mostraré para actualizar tu controlador de NVIDIA a su versión más reciente.
Instrucciones para instalar el controlador de NVIDIA 304.32 para Linux
Para instalar el controlador 304.32 de NVIDIA en Ubuntu 12.10, 12.04, 11.10 o en Linux Mint 13, debes abrir una nueva ventana del terminal y escribir las líneas:

sudo apt-add-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

Y si usas otro sistema Linux que no soporte la instalación vía PPA, puedes usar los siguientes comandos.

Para ordenadores 32-bit:

cd /tmp
wget -O NVIDIA-Linux-x86-304.32.run http://goo.gl/Q8Wg7
chmod +x NVIDIA-Linux-x86-304.32.run
sudo sh NVIDIA-Linux-x86-304.32.run
Linux 64-bit/amd64

Para ordenadores 64-bit:


cd /tmp
wget -O NVIDIA-Linux-x86_64-304.32.run http://goo.gl/wCSXF
chmod +x NVIDIA-Linux-x86_64-304.32.run
sudo sh NVIDIA-Linux-x86_64-304.32.run

 

Fuente: mylifeLinux.com

Comentarios

Imagen de fluido00

Genial este post, pero tengo una duda, ¿qué significa eso?:

DKMS: install completed.
Setting up nvidia-settings (310.14-0ubuntu1~xedgers~precise2) ...
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/nvidia-settings/ld.so.conf because link group nvidia_settings_conf is broken.
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...