No puedo instalar el paquete LAMP correctamente

Imagen de vegenarie
0 puntos

He seguido el tutorial http://www.howtoforge.com/ubuntu_lamp_for_newbies pero no funciona, primero no encuentro mysql.so en el php.ini, he descomentado lo mas parecido msql.so, pero sigue sin funcionar. Tampoco me iba el phpmyadmin pero leyendo los comentarios he hecho sudo cp -R /usr/share/phpmyadmin /var/www y ya veia el phpmyadmin aunque los archivos php de prueba que puse en /var/www no ejecutaban lo que habia puesto, solo me decia "It works!This is the default web page for this server.The web server software is running but no content has been added, yet.". Al acceder al phpmyadmin me pedia el usuario y contraseña. Al instalar el mysql no puse ninguna contraseña, aunque luego ejecute mysql -u root y luego puse una contraseña con mysql> SET PASSWORD FOR 'root'@'localhost' = PASSWORD('yourpassword');, probe con root y la contraseña puesta y me da error, mire en /etc/phpmyadmin/config-db.php y aparece como usuario phpmyadmin y mi contraseña , probe con eso y me da error "#1045 El servidor MySQL no autorizó su ingreso La conexión para controluser, como está definida en su configuración, fracasó.". He reiniciado apache y mysql y sigue igual. Ahora cuando hago mysql - u root me da access denied y con mysql -u phpmyadmin igual, error tambien usando mysql -u root -p o mysql -u phpmyadmin -p

He probado tambien con sudo apt-get install lamp-server phpmyadmin y no arregla nada. He probado a desinstalar phpmyadmin con sudo apt-get remove --purge phpmyadmin pero me da error tambien, empezando por "No se pudo bloquear /var/lib/dpkg/lock"

He reinstalado el sistema y he probado otra vez a eliminar phpmyadmin y ahora me dice que ejecute sudo dpkg --configure -a, asi lo hago, vuelvo a poner las contraseñas y me vuelve a dar el error
"Se ha producido un error al instalar la base de datos: ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES) "

Imagen de vegenarie
+1
0
-1