Problema con wifi netbook PB DOT S Ubuntu 10.10

Imagen de DARJONACANO78
0 puntos

Hola tengo un problema con mi netbook pb dot s, no me funciona el wifi, vamos que la tarjeta inalambrica no me la reconoce ubuntu 10.10 que hace pocos dias lo instale por consejo de un informático ya que w7 starter no me convencia.
Por lo que he mirado creo que tiene por lo que pone con el comando lspci es Atheros y RTL8101E/RTL8102E.
Me bajé los drivers de la página de packard bell del Atheros 8.0.0.171 pero era para w7 y dudo que funcione.
De todas maneras os paso lo que me devuelven los comandos lspci y iwconfig:

lspci:

00:00.0 Host bridge: Intel Corporation Device 0bf1 (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Device 0be1 (rev 09)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation NM10 Family LPC Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation N10/ICH7 Family SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)
02:00.0 Network controller: Atheros Communications Inc. Device 0032 (rev 01)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5209 (rev 01)

iwconfig:

lo no wireless extensions.
eth0 no wireless extensions.
ppp0 no wireless extensions.

Espero que con esto me podais dar explicación al problema, sino ya iria tirando con mis modems usb del carrefour movil y del vodafone.
Gracias y un saludo.

Imagen de elnetotaca
+1
0
-1

primero lo primero, lo que vas a hacer es, dentro de Ubuntu, abre la terminal y tecleas;

sudo rfkill list all
esto reseteará todos los interruptores de la red, luego resetea y avisa si te funcionó.

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!

Imagen de DARJONACANO78
+1
0
-1

Hola elnetotaca perdona por tardar en contestar pero es que no puedo coger el netbook hasta tarde noche.
He probado lo que me has sugerido y no ha tenido ningún efecto, nada de nada.
Que me sugieres, gracias por adelantado.

+1
0
-1

DANIEL ARJONA CANO

Imagen de elnetotaca
+1
0
-1

Si eso no te funcionó, la segunda parte es;
busca en la pc si tiene algún boton con el que se apaga/enciende la wifi, muchas veces son botones muy pequeños, y es facil moverlos a la posición de apagado.

luego avisas.

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!

Imagen de DARJONACANO78
+1
0
-1

Pues no tiene ningún botón.

+1
0
-1

DANIEL ARJONA CANO

Imagen de elnetotaca
+1
0
-1

entonces en la terminal;

lsmod

pegas aqui el resultado.

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!

Imagen de DARJONACANO78
+1
0
-1

Hola elnetotaca perdona por la tardanza, esto es lo que me sale con el lsmod:

Module Size Used by
ppp_deflate 3726 0
zlib_deflate 19266 1 ppp_deflate
bsd_comp 4791 0
ppp_async 6778 1
crc_ccitt 1351 1 ppp_async
option 13133 2
usb_wwan 9953 1 option
usbserial 33100 7 option,usb_wwan
binfmt_misc 6599 1
parport_pc 26058 0
ppdev 5556 0
snd_hda_codec_realtek 217980 1
snd_hda_intel 22107 2
snd_hda_codec 87552 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 5040 1 snd_hda_codec
snd_pcm 71475 2 snd_hda_intel,snd_hda_codec
snd_seq_midi 4588 0
snd_rawmidi 17783 1 snd_seq_midi
snd_seq_midi_event 6047 1 snd_seq_midi
snd_seq 47174 2 snd_seq_midi,snd_seq_midi_event
snd_timer 19067 2 snd_pcm,snd_seq
snd_seq_device 5744 3 snd_seq_midi,snd_rawmidi,snd_seq
uvcvideo 55847 0
snd 49006 13 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
videodev 43098 1 uvcvideo
psmouse 59033 0
v4l1_compat 13359 2 uvcvideo,videodev
serio_raw 4022 0
video 18712 0
soundcore 880 1 snd
snd_page_alloc 7120 2 snd_hda_intel,snd_pcm
output 1883 1 video
lp 7342 0
parport 31492 3 parport_pc,ppdev,lp
usbhid 36882 0
hid 67742 1 usbhid
usb_storage 40172 0
ahci 19013 0
libahci 21667 3 ahci
r8169 36489 0
mii 4425 1 r8169

A ver que me puedes decir.
Gracias.

+1
0
-1

DANIEL ARJONA CANO

Imagen de elnetotaca
+1
0
-1

vamos a hacer algo mas;

en la terminal;

nm-tool

iwconfig

rfkill list all

lsmod | grep iwl

sudo cat /var/log/syslog | grep -e wl -e firmware -e wpa -e eht1 -eth0 -e etork | tail -n55

corre esos comandos, y pegas aqui todos y cada uno de los resultados.

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!

Imagen de DARJONACANO78
+1
0
-1

Ok, ahora lo hago.
nm-tool:

NetworkManager Tool

State: connected

- Device: eth0 -----------------------------------------------------------------
Type: Wired
Driver: r8169
State: unavailable
Default: no
HW Address: xxxxxxx

Capabilities:
Carrier Detect: yes
Speed: 10 Mb/s

Wired Properties
Carrier: off

- Device: ttyUSB0 [CARREFOUR MOVIL connection] --------------------------------
Type: Mobile Broadband (GSM)
Driver: option1
State: connected
Default: yes

Capabilities:

IPv4 Settings:
Address: xxxxxxxxx
Prefix: xxxxxx
Gateway: xxxxxxx

DNS: xxxxxxx
DNS: xxxxxxx

(es que no me fio meter los numeros aqui)

iwconfig:

lo no wireless extensions.

eth0 no wireless extensions.

ppp0 no wireless extensions.

rfkill list all:
no salió nada

lsmod | grep iwl:
tampoco salió nada

sudo cat /var/log/syslog | grep -e wl -e firmware -e wpa -e eht1 -eth0 -e etork | tail -n55:
TAMPOCO SALIO NADA

Como lo ves?.

+1
0
-1

DANIEL ARJONA CANO

Imagen de elnetotaca
+1
0
-1

pero al parecer tienes que instalar la versión mas nueva de el driver;

bajas ese archivo AQUI

luego en la terminal;

sudo apt-get install build-essential

echo “blacklist r8169″ >> /etc/modprobe.d/blacklist.conf

ahora descomprime el archivo que bajastes con el driver
abre una terminal dentro de el directorio que descomprimistes el driver y tecleas;

make clean modules

cuando el proceso termine, tecleas;

make install

depmod -a

insmod ./src/r8168.ko

mkinitramfs -o /boot/initrd.img-`uname -r` `uname -r`

echo “r8168″ >> /etc/modules

reseteas tu pc, y con esto tienes!
saludos.

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!

Imagen de DARJONACANO78
+1
0
-1

Perdona pero he seguido linea a linea, letra a letra y nada de nada tio.
Me sabe mal darte faena.
Si no tienes otra idea da igual ya me miraré un wifi usb que sea compatible y ya está.
Total las que tengo vistas valen entre 10 a 15 euros, no es mucho.
Pero de todas formas si tienes alguna sugerencia me lo comentas.
Gracias y un saludo.

+1
0
-1

DANIEL ARJONA CANO

Imagen de elnetotaca
+1
0
-1

donde o como abristes la terminal???
ya que para que todo esto te funcione, tienes que abrir la terminal en el directorio donde está el archivo que bajastes.
saludos

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!

Imagen de DARJONACANO78
+1
0
-1

La carpeta donde descargué los archivos lo tengo en Descargas, como abro terminal en ese directorio?, yo abri terminal normalmente en el directorio personal y luego con cd fui al directorio de descargas y al directorio donde estaban los archivos que bajé y descomprimí, y después seguí tus pasos y nada.

+1
0
-1

DANIEL ARJONA CANO