error al instalar xen y python !!!

Imagen de vale_N
0 puntos

Hola buenas soy nuevo por aqui y la verdad bastante desesperado.
Os cuento, me he bajado el xen 4.2.0 lo he descomprimido y he hecho el ./configure, al hacerlo me ha dado un error porque no tenia python.
He ido a la web de python y me he bajado la version 2.7.3 la he descomprimido he hecho el configure, el make y el make install y todo correcto me lo ha instalado sin problemas, ahora viene mi rompecabezas.
He vuelto a hacer el configure en la carpeta xen y me da este error:

checking for PyArg_ParseTuple in -lpython2.7... no
configure: error: Unable to find a suitable python development library

http://postimage.org/image/63gu9cijx/

como lo puedo solucionar? Alguien que sepa que puede ser??

Ahh por cierto tambien he probado con el comando sudo apt-get install ubuntu-xen-server
y la respuesto ha sido esta:
E: No se ha podido localizar el paquete ubuntu-xen-server

He probado tambien con los siguientes comandos:
Ejecutando pkg-config --cflags --libs python en consola me dice esto:
-I/usr/local/include/python2.7 -L/usr/local/lib -lpython2.7

Por lo tanto el archivo -lpython2.7 si lo tengo, lo he intentado añadir en el configure de esta forma ./configure PREPEND_LIB="/usr/local/lib/-lpython2.7" pero me sigue dando el mismo error, he probado con comillas sin comillas, separando -lypthon2.7 de lib... tambien he probado esto ./configure PREPEND_INCLUDES=/usr/local/include/python2.7 y esto otro ./configure LDFLAGS=-L"/usr/local/lib/-lpython2.7" y nada de nada no me funciona me sigue dando el mismo error en el mismo sitio.

Por lo que he buscado en internet PyArg_ParseTuple es como una funcion, es decir, en el lenguaje de programacion de python cuando se programa y queremos parsear o lanzar excepcion o algo asi se utiliza el PyArg_ParseTuple.
Con lo que supongo que python me deberia haber instalado esa funcion o ese metodo cuando se instaló el propio python 2.7.3, no es un archivo que pueda descargarme y meterlo en /python/lib por ejemplo, por lo tanto como lo consigo? He reinstalado mil veces el python y he probado con varios 2.6,2.3,2.7 y nada me sigue petando en el mismo sitio.

Saludos y muchas gracias de antemano.

Imagen de Goyo
+1
0
-1

me he bajado el xen 4.2.0 lo he descomprimido y he hecho el ./configure, al hacerlo me ha dado un error porque no tenia python.

No, el error es que no tienes la biblioteca de desarrollo de python. Instala python-dev.
Aunque realmente creo que te conviene más instalar los paquetes precompilados de xen.

+1
0
-1
Imagen de vale_N
+1
0
-1

Buenas Goyo, gracias por tu respuesta. Ya he instalado el python-dev y python-all-dev y nada sigue sin funcionar me sigue dando el mismo error. A que te refieres con instalar los paquetes precompilados? A que los instala desde el centro de software de ubuntu? Desde ahí ya le di y no me encuentra nada relacionado con xen bueno si un paquete que es lenguaje de alto nivel pero que ya tenia instalado.

Un saludo y gracias.

+1
0
-1
Imagen de Goyo
+1
0
-1

A que te refieres con instalar los paquetes precompilados?

Pues los que necesites de estos, supongo:
http://packages.ubuntu.com/source/quantal/xen

Probablemente no vas a encontrar aquí mucha gente con experiencia en compilar xen. Si realmente quieres hacerlo así sería más fácil encontrar soporte en la propia comunidad de xen. Una búsqueda por google sugiere que el problema que estás teniendo es un bug en el script de configuración, aunque no lo veo claro.

+1
0
-1