[AYUDA] Me he cargado el grub, portátil con UEFI

Imagen de flashQarl
0 puntos

Buenas noches!

Resulta que hace poco tiempo me compré un portátil (ASUS) y por lo visto lleva UEFI en vez de la clásica BIOS.

Después de informarme del funcionamiento de este sistema (UEFI), hice lo siguiente:
- Formateé todo el disco entero con GParted (hize nueva tabla de particiones, formato GPT).
- Instalé Windows (64bits).
- Instalé Ubuntu 12.10 (64bits).

El disco duro se quedó con la siguiente estructura:
- sda1: Partición para el UEFI (FAT32)
- sda2: Partición que genera Windows de recuperación (desconocida)
- sda3: Partición de Windows 7 (NTFS)
- sda4: Swap para Linux (linux-swap)
- sda5: Ubuntu 12.10 (EXT4)

Una vez realicé los pasos anteriores el portátil cargaba el grub perfectamente pero no aparecía Windows. La forma para entrar a Windows era meterme en la BIOS y seleccionarlo directamente.
Como podía entrar a los dos sistemas sin problemas (Windows a penas lo uso) y andaba pillado de tiempo, dejé para más adelante el tema de añadir Windows 7 al grub para tener un arranque dual más "accesible".

Hoy que tenía tiempo me he puesto a buscar información para añadir Windows 7 al grub, he probado muchas cosas y he terminado cargándome el grub.

El portátil trata de cargar el grub pero dice que nada, que no se puede iniciar (no recuerdo exactamente lo que pone, si fuese necesario tomo una foto) y me deja abierto una especie de terminal que pone y puedo meter comandos (no funciona nada de lo que he probado, excepto "ls" jaja).
He metido "rescatux" a un pendrive para tratar de recuperarlo y utilizando la opción de cargar desde HDD si que he conseguido acceder al grub y desde ahí arrancar Ubuntu.
He intentado repararlo desde Ubuntu y nada de nada, parece ser que el problema está en el UEFI (que no encuentra o no quiere encontrar el grub).

Llevo toda la tarde probando cosas y no hay manera ¿Alguien me echa un cable?
Muchas graciass!!

Imagen de diemillo
+1
+1
-1

Inicia con Ubuntu
Entra en la consola , hazte root con el comando
sudo su
pulsa intro y escribe la contraseña (no se verá en pantalla)
Despues ve ejecutando estos comandos
grub-mkconfig -o /boot/grub/grub.cfg
grub-install –recheck /dev/sda
sudo update -grub2
sudo grub-install /dev/sda
Suerte

+1
+1
-1
Imagen de flashQarl
+1
+1
-1

He reparado el grub desde un LiveCD de Ubuntu 12.10 haciendo lo siguiente:
$ sudo mount /dev/sda5 /mnt
$ sudo apt-get install grub-efi
$ sudo grub-install /mnt/boot/efi

Creo que han sido esos parámetros y esos comandos, no estoy seguro 100% pero creo que sí.
¿Por qué no me añade Windows 7 al grub?

Un saludo!

+1
+1
-1