me da error al intentar actualizar de ubuntu 10.10 a 11.04- he encontrado una posible solucion, me podriais decir si esta bien

Imagen de fur
fur
0 puntos

Buenas tardes:
Soy novato en este mundo. estoy intentando actualizar mi ubuntu 10.10 a 11.04 y me sale el siguiente error:
W:no se puede conseguir: http://extras.ubuntu.com/ubuntu/dists/natty/binary-i386/packages.gz404

Y algunos archivos de E:indize nose pueden descargar (en este apartado me dice que seran sustituidos por los ya existentes o que lo omitira.

Pero en definitiva no me deja continuar con la actualizacion, y para poder usar mi modem usb necesito actualizarlo.
Muchas gracias

Posible solucion:

Hola que tal, a mi tambien me sucedio el error y no podía abrir instalar nada desde el centro de software, Synaptic y terminal, al parecer es por unas entradas antiguas en las listas de los paquetes, pero con lo siguiente se soluciona:
Borramos las entradas

$ sudo rm /var/lib/apt/lists/* -vf

Al actualizar baja las nuevas entradas y paquetes.

$ sudo apt-get update

Y ahora podemos actualizar paquetes.

$ sudo apt-get upgrade