Problema RAM

Imagen de fructuu
0 puntos

Hola :))), este es mi primer post en este foro. Acabo de instalar linux ubuntu 11.10 hace un par de días y todo perfecto, pero mi problema va relacionado con la memoria.
Soy estudiante de informática y me piden que haga pruebas con sistemas. Para ello he descargado vmware y virtualbox.

Ahora viene el problema:

No sé por qué mi memoria va aumentando cada vez mas sin sentido alguno... Tengo una máquina virtual en virtualbox con 512 Mb de ram y el sistema cuando se inicia me suele ocupar unos 600-700Mb.
Ahora, cuando empiezo instalar la máquina la RAM cada vez aumenta más.

Hasta llegar a ocupar 3Gb con:

Ubuntu 11.10, una máquina virtual XP con 512MB de ram y un par de alpicaciones mas (skype y terminal).

Es esto normal?
Os dejo los comandos top y free -m para que veais.

total used free shared buffers cached
Mem: 3885 3049 836 0 31 1675
-/+ buffers/cache: 1342 2543
Swap: 3953 0 3953

top - 19:38:06 up 1:02, 1 user, load average: 0.18, 0.34, 0.64
Tasks: 183 total, 1 running, 182 sleeping, 0 stopped, 0 zombie
Cpu(s): 1.5%us, 1.2%sy, 0.0%ni, 97.1%id, 0.0%wa, 0.0%hi, 0.2%si, 0.0%st
Mem: 3979140k total, 3157256k used, 821884k free, 33952k buffers
Swap: 4048892k total, 0k used, 4048892k free, 1722728k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
6796 adrian 20 0 785m 609m 573m S 5 15.7 9:34.27 VirtualBox
1732 adrian 20 0 374m 97m 20m S 2 2.5 1:31.81 skype
1070 root 20 0 68676 44m 11m S 1 1.2 3:44.06 Xorg
1713 adrian 20 0 237m 131m 31m S 1 3.4 2:35.94 compiz
6625 adrian 20 0 33128 9560 5620 S 1 0.2 0:09.06 VBoxSVC
8441 adrian 20 0 2844 1172 860 R 1 0.0 0:00.13 top
756 root 20 0 0 0 0 S 0 0.0 0:04.04 kworker/2:2
6440 root 20 0 0 0 0 S 0 0.0 0:02.67 kworker/1:1
6605 adrian 20 0 166m 64m 31m S 0 1.7 0:17.18 VirtualBox
6620 adrian 20 0 16588 4536 2600 S 0 0.1 0:06.62 VBoxXPCOMIPCD
1 root 20 0 3348 1824 1248 S 0 0.0 0:05.09 init
2 root 20 0 0 0 0 S 0 0.0 0:00.00 kthreadd
3 root 20 0 0 0 0 S 0 0.0 0:00.22 ksoftirqd/0
6 root RT 0 0 0 0 S 0 0.0 0:00.00 migration/0
7 root RT 0 0 0 0 S 0 0.0 0:00.00 migration/1
9 root 20 0 0 0 0 S 0 0.0 0:00.14 ksoftirqd/1

Creo que el problema es de la caché que va aumentando sin parar... He probado con:

sync ; echo 0 > /proc/sys/vm/drop_caches
sync ; echo 1 > /proc/sys/vm/drop_caches
sync ; echo 2 > /proc/sys/vm/drop_caches
sync ; echo 3 > /proc/sys/vm/drop_caches

para liberar la caché, pero se vuelve a llenar...

Gracias por las respuestas :))))))))))

Imagen de elnetotaca
+1
0
-1

En primer lugar que instales Ubuntu 12.04, es la versión mas estable.
la 11.10 es muy conocida por estar plagada de muchos errores que nunca fueron corregidos.

intenta con la 12.04 y nos avisas como te va.
Saludos

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!

Imagen de fructuu
+1
0
-1

Lo hice, en un primer momento instalé ubuntu 12.04, al ser "nuevo" pensé que el problema venia a raiz de aqui y que seria un bug que no estaria corregido, por eso me pasé a 11.10.
Pero el problema sigue y no encuentro solución.

Por cierto,
con el comando top, me dice que tengo 3.3gb de ram usandose, en cambio si abro el system monitor me dice que tengo 1.3.... El caso es que cuando llega a 3.8 me empieza a usar swap y me relentiza mucho la máquina...

total used free shared buffers cached
Mem: 3979140 3310000 669140 0 37432 1869140

gracias por contestar :))

+1
0
-1
Imagen de fructuu
+1
0
-1

total used free shared buffers cached
Mem: 3979140 3310000 669140 0 37432 1869140

+1
0
-1
Imagen de Gabriel_M
+1
+1
-1

.... Xubuntu Quantal 64 bits.
Con Firefox conectado en este momento al sitio, y corriendo en virtualbox de 1024 ram y 128 video a Xubuntu Raring 64 bits, con Firefox y Brasero, tanto el monitor del sistema como conky me informan un consumo de 1.7 de ram y 357 de swap, generalmente sin virtualbox estoy entre 420 y 520 de ram y 0 swap, en un athlon II 245.

+1
+1
-1