Hasta hoy funcionaba. Ahora no puede ser ni instalado: aMule

Imagen de mobutu
0 puntos

Un corte en el fluido eléctrico me ha dejado el aMule paralítico; con buena conexión, ID Alta, pero sin moverse un bit. "Bueno. No pasa nada. Lo reinicio y si sigue callado, desinstalación, re-instalación..."

Pero me es imposible instalarlo, ni desde el Centro de software de Ubuntu, ni desde synaptic, porque

¡LAS DEPENDENCIAS DEL PAQUETE NO SE PUEDEN RESOLVER!

Llevo todo el día buscando la solución y no encuentro nada que resuelva el problema. Hasta he instalado amule_2.0.0rc7-ubuntu1_i386.deb. Con éxito, pero no arranca (dicen que hay que eliminar "muleLock", pero tampoco encuentro muleLock). Con aMule-2.3.1.tar.bz2 tampoco hay manera: falta no sé que wxWidgets que tampoco se instala porque no encuentra ta-ta-ta-tá y sin eso el ./configure no rula.

Desde que instalé Lucid Lynx (10.04) casi no tengo problemas. Hasta hoy que cascó aMule.

¿Alguien conoce a alguien que sabe algo? Pues le beso las manos. Pero de migrar a Unity, ni hablar. Eh!

Gracias. Gracias.

Imagen de tecnicodelinux
+1
0
-1

Solución:
paso 1:sudo su
paso 2: password del usuario(password que entras en ubuntu.)
Paso 3: Sudo apt-get remove amule
Paso 4: Sudo apt-get install amule
ya me contaras , suerte.

+1
0
-1
Imagen de mobutu
+1
0
-1

Esto el lo que me dice el terminal en el Paso 4:

root@usuario-desktop:/home/usuario# sudo apt-get install amule
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
amule: Depende: libgeoip1 (>= 1.4.7~beta6+dfsg) pero 1.4.6.dfsg-17 va a ser instalado
Depende: libwxgtk2.8-0 (>= 2.8.12) pero 2.8.10.1-0ubuntu1 va a ser instalado
Recomienda: amule-wxcas pero no va a instalarse
E: Paquetes rotos
root@usuario-desktop:/home/usuario#

He pensado que quizá /home/usuario/.aMule (que seguía en su sitio) estaba estorbando toda la operación. Lo he renombrado y he vuelto a intentar el Paso 4 con idéntico fracaso. El aMule que tenía instalado era una versión antigua (la que ofrecen en le Centro de Software de Ubuntu. Muchas veces en las actualizaciones automáticas viene una de amule, pero nunca me deja por no sé qué historia de los repositorios.

Muchas gracias.

+1
0
-1

Mobutu Linux User #338331#

Imagen de Goyo
+1
0
-1

amule: Depende: libgeoip1 (>= 1.4.7~beta6+dfsg) pero 1.4.6.dfsg-17 va a ser instalado

Habría que ver de dónde ha salido esa versión de amule que estás tratando de instalar, la que está en los repositorios oficiales de lucid requiere libgeoip1 (>= 1.4.6.dfsg)
http://packages.ubuntu.com/lucid/amule

O si quieres instalar la versión de los repositorios oficiales:

sudo apt-get install amule=2.2.6+debian0-7

Creo que es así.

+1
0
-1
Imagen de mobutu
+1
0
-1

La versión de los repositorios oficiales sigue dando los problemas de dependencias, archivos rotos, etc.
Me he bajado la que propones en tu enlace: amule-2.2.6.orig. Pero parece que es para 64 bits. También me he descargado amule_2.3.1-1.debian.tar-gz. En la carpeta "debian" que produce el desempaquetado na hay ningún archivo que me oriente cómo llevar a cabo la instalación. Estos son los archivos que contiene (no copio tres carpetas más que aparecen):
/amule.docs
/amule.install
/amule.manpages
/amule.menu
/amule.preinst
/amule-32.xpm
/amule-common.install
/amule-daemon.default
/amule-daemon.init
/amule-daemon.install
/amule-daemon.manpages
/amule-daemon.README.Debian
/amuled_home_wrapper.sh
/amule-gnome-support.install
/amule-utils.install
/amule-utils.manpages
/amule-utils.preinst
/amule-utils-gui.install
/amule-utils-gui.manpages
/amule-utils-gui.menu
/changelog
/compat
/control
/copyright
/README.source
/rules
/watch

Creo que lo mejor será reinstalar Ubuntu totalmente. No sé si la misma versión o dar el salto a la última, porque Unity es bastante porculera.

Muchas gracias, en todo caso.

+1
0
-1

Mobutu Linux User #338331#

Imagen de Goyo
+1
0
-1

Me he bajado la que propones en tu enlace: amule-2.2.6.orig. Pero parece que es para 64 bits. También me he descargado amule_2.3.1-1.debian.tar-gz.

Me has interpretado mal, no propongo que te bajes ningún archivo de ahí y menos esos que dices. El enlace era para que pudieras comprobar las dependencias del paquete oficial, que no son las mismas que te pide a ti. En particular depende de una versión distinta de libgeoip1.

+1
0
-1
Imagen de tecnicodelinux
+1
0
-1

solucion 2:

rm ~/.aMule/muleLock

+1
0
-1
Imagen de mobutu
+1
0
-1

Cuando creía que podía deberse a muleLock. No dio resultado. Ahora que no está aMule, ni se deja instalar, menos todavía. Aunque yo he vuelto a probar. (todo lo que no sé de informática lo relleno con magia potagia).

Muchas gracias por tu amabilidad.

+1
0
-1

Mobutu Linux User #338331#

Imagen de cuentos
+1
0
-1

Posiblemente al quere instalar amule, que dices :
Hasta he instalado amule_2.0.0rc7-ubuntu1_i386.deb., que no se de donde lo descargastes rompieste el sistema de dependencias. Ubuntu 10.4 creo que trae synaptic, y este tiene una funcion de arreglar paquetes rotos, trata primero con este.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de mobutu
+1
0
-1

También probé con synaptic. Y con la opción de reparar paquetes, sin ningún resultado.

Preferiría cerrar este hilo para que no se convierta en una madeja de preguntas, pero no sé cómo hacerlo.

Lo único que hice fue desistalar amule e intentar instalarlo otra vez. Siempre usando el Centro de software ubuntu. ¿La razón de esta maniobra? Periódicamnte aparecían en la lista de actualizaciones algunos archivos o paquetes de amule, pero nunca se podían instalar por no sé que problema de seguridad o de repositorios.
Asumo mis muchas limitaciones y las pocas de Ubuntu

+1
0
-1

Mobutu Linux User #338331#

Imagen de Goyo
+1
0
-1

Lo único que hice fue desistalar amule e intentar instalarlo otra vez.

No, también añadiste algún repositorio que contiene la versión de amule que te está dando problemas.

+1
0
-1