Permisos CUPS y configuración de Epson Stylus SX235W por USB

Imagen de mamaicas
0 puntos

Hola a todos. Creía haber publicado ya esta pregunta pero no la veo así que vuelvo a lanzarla (perdonarme si aparece duplicada)

Necesito ayuda para configurar la impresora, llevo ya muchos días intentándolo y no sé que hacer.

Tengo instalado Ubuntu 12.10 sobre un portatil DELL XPS

He instalado y desinstalado muchas veces todo, por lo que cuento la situación actual.

Conecto la impresor a un USB y voy a “Impresoras”. Pulso “Añadir”. Me aparece la impresora detectada como Epson Stylus SW235 (4E583 …)
Pulso “adelante” y busca controladores. Me ofrece: epson-201108w, epson-escpr y Controlador local.

Primero elijo “ epson-201108w” acepto la licencia y pulso adelante. Me pide que elija un controlador pero mi impresora no aparece en la lista. He probado a elegir la SX215 y la SX510 y falla con las dos. En la parte de controladores elijo el que pone “SX215 – CUPS+Gutenprint v5.2.9. Pulso adelante. Pulso aplicar. Pulso imprimir página de prueba y da el error “Se ha producido un error en CUPS durante la operación: «client-error-not-found».

Luego la impresora se queda instalada en estado “inactivo” y con el botón de imprimir página de prueba deshabilitado. Cuando mando algo a imprimir no da error pero no imprime.

En el log de cups dice lo siguiente:
E [06/Dec/2012:07:50:45 +0100] Unable to open "/usr/share/cups/mime": Permission
denied
E [06/Dec/2012:07:50:45 +0100] Unable to open "/usr/share/cups/mime": Permission
denied
E [06/Dec/2012:07:50:45 +0100] cupsdLoadBanners: Unable to open banner directory
"/usr/share/cups/banners": No such file or directory
W [06/Dec/2012:07:50:45 +0100] CreateProfile failed: org.freedesktop.ColorManage
r.AlreadyExists:profile id 'EPSON-Epson-Stylus-SX235-Gray..' already exists
W [06/Dec/2012:07:50:45 +0100] CreateProfile failed: org.freedesktop.ColorManage
r.AlreadyExists:profile id 'EPSON-Epson-Stylus-SX235-RGB..' already exists
W [06/Dec/2012:07:50:45 +0100] CreateDevice failed: org.freedesktop.ColorManager
.AlreadyExists:device id 'cups-EPSON-Epson-Stylus-SX235' already exists
E [06/Dec/2012:08:49:45 +0100] [cups-driverd] Unable to open PPD directory "/usr
/share/cups/model": Permission denied
E [06/Dec/2012:08:49:45 +0100] [cups-driverd] Unable to open PPD directory "/usr
/share/ppd": Permission denied
E [06/Dec/2012:08:50:46 +0100] [cups-driverd] Unable to open PPD directory "/usr
/share/cups/model": Permission denied
E [06/Dec/2012:08:50:46 +0100] [cups-driverd] Unable to open PPD directory "/usr
/share/ppd": Permission denied

Como veis muchos problemas de permisos que no sé como solucionar. El contenido de la carpeta /usr/share/cups es el siguiente:
miguelangel@elDellSalon:~$ ls -l /usr/share/cups/
total 352
-rw-r--r-- 1 root root 331836 jul 11 14:30 calibrate.ppm
drwxr-xr-x 2 root root 4096 oct 15 21:44 data
drwxr-xr-x 7 root root 4096 dic 4 23:52 doc-root
drwxr-xr-x 2 root root 4096 dic 4 23:52 mime
drwxr-xr-x 2 root root 4096 oct 15 21:44 model
drwxr-xr-x 2 root root 4096 dic 4 23:52 ppd-updaters
drwxr-xr-x 5 root root 4096 dic 4 23:52 templates

He desinstalado e instalado varias veces CUPS pero el problema de permisos permanece.

Si elijo controlador local o epson-escpr me falla también, me aparece una lista de impresoras, no está la mia y elijo la Stylus 215 y al imprimir página de prueba da el siguiente error: Se ha producido un error en CUPS durante la operación: «client-error-not-found».

¿Alguna pista para solucionar el problema?

Saludos

Imagen de mamaicas
+1
0
-1

Sigo intentándolo sin éxito he añadido permisos 660 a la carpeta templates pero sigue sin funcionar.

+1
0
-1