Gestor de actualizaciones inactivo por error en "source list"

Imagen de RJanark
0 puntos

Buenos días.

Llevo ya un par de años con Ubuntu, y hace un par de semanas me instalaron la última versión de Linux MInt. No sé nada de programación, y es la primera vez que se me presenta un problema de este tipo.

He seguido los pasos que sugiere la guía del foro y no he encontrado respuesta específica, ni en google ni en los varios foros que hay en la red.

Mi Gestor de actualizaciones no logra actualizarse, cada vez que pruebo me aparece esto:

E:Malformed line 10 in source list /etc/apt/sources.list (URI parse)

Buscando en la red encontré cómo ver cuál es la línea 10. Ésta lee así en gedit:

deb-src http_//archive.canonical.com/precisa partner

Según he visto, esta línea está mal escrita. Lo que no sé es cómo debería de ser para que no me dé error. Encontré otros con el mismo error, pero en otras líneas, ninguna en la línea 10.

Alguien sabe cómo solucionar el problema?

Imagen de .doc
+1
+1
-1

debe ser 'precise', en vez de 'precisa' ¿no? (en todo caso, esa línea 'deb-src....' se refiere a los 'fuentes' de los paquetes, que no es necesario descargarlos para que funcionen, así que puedes 'comentarla' (poner una almohadilla (#) delante de la línea, incluso en todas las que comiencen por 'deb-src...'), para no tenerla en cuenta, y así no te saltará el error... y no pasa nada)

+1
+1
-1
Imagen de RJanark
+1
0
-1

Muchísimas gracias! Coloqué la almohadilla en esa línea y en las siguientes dos, las últimas, y todo se resolvió.

+1
0
-1
Imagen de .doc
+1
0
-1

bueno, esta es la solución del tipo 'muerto el perro, se acabo la rabia'. Pero siempre es conveniente investigar el por qué de las cosas

No se qué contendrían esas otras líneas que dices que también has 'comentado', pero habría que saber si la famosa linea 10 que indicabas la ha escrito, o la has pasado aquí con un copiar+pegar. Si es esto último, acabo de darme cuenta de que también había otro error (aparte del 'precisa') en esto: no es 'deb-src http_//...' sino 'deb-src http://...' (o sea... con 'dos puntos', en vez del guión bajo).

+1
0
-1