tengo un desastre de permisos

Imagen de drewdty
0 puntos

bueno me presento soy nuevo en el foro pero llevo mas de dos años tonteando con ubuntu
hasta hoy no habia necesitado preguntar poque leyendo he ido trasteando leyedo en el foro , gogleando y saliendo del bache a trompazos pero:
hoy ya no puedo mas me explico. tengo la version 11.10
el problema es con los permisos, no tengo permiso ni en home ni undisco duro ntfs de datos en home al darle permisos con chmod va bien reinicio y otravez sin permisos he probado con ntfsconf editando el famoso fstab el pysdm y lo que me mosqea mas es que con la version 12. 10 este problema no lo tengo es mas no tengo que montar eldisco de datos al inicio puedo compartir todos mis discos ala primera pero tengo problemas añ utilizar algunas aplicaciones wine inportantes para mi y paso de me ter guindos y tener parte del disco desperdiciado con ese SO
necesito vuestra ayuda
ha he reintalado el sistema desde cero unas 10 veces en una semana todo un record :(

Imagen de .doc
+1
0
-1

no se en qué líos te habrás metido con el 11.10 y el chmod, como muy bien dices (y dices que te pasaba en un 12.10) no necesitar dar permisos para entrar como usuario en tu /home, y para montar una partición NTFS.

Lo único que se me ocurre es que tu usuario no esté incluido en el grupo 'sudoers', pero esto es fácil de arreglar, edita, como root, el archivo /etc/sudoers y añade, al final, estas líneas (sustituyendo, por supuesto, 'doc' (lo que pongo es mi caso) por tu nombre de usuario
#includedir /etc/sudoers.d
doc ALL=(ALL) ALL
Defaults !authenticate

+1
0
-1
Imagen de drewdty
+1
0
-1

sigue igual doc una cosa si monto el disco manualmente ( eliminando la linea del fstab que habiapuesto ) tengo los permisos pero automaticamente no
en cambio tu solucion para la carpeta /home no me ha ido bien y lo tengo asi:

# User privilege specification
root ALL=(ALL:ALL) ALL

# Members of the admin group may gain root privileges
%admin ALL=(ALL) ALL

# Allow members of group sudo to execute any command
%sudo ALL=(ALL:ALL) ALL

#includedir /etc/sudoers.d
toni ALL=(ALL) ALL
Defaults !authenticate
solo necesito como montar el disco ntfs al iniciar con los permisos y que mevuelva los permisos de /home
gracias por tu poronta respuesta

+1
0
-1
Imagen de .doc
+1
0
-1

si lo que quieres es que la partición NTFS se te monte automáticamente al iniciar el ordenador, echa un vistazo a esto, por si te sirve de algo (es para Debian, pero en Ubuntu funciona igual)
http://comoserdebianitaynomorirenelintento.blogspot.com.es/2012/04/arran...

+1
0
-1
Imagen de drewdty
+1
0
-1

uffff he seguido lo que me explica el enlace de forma grafica y el fstab mta el disco correctamente pero solo root tienepermisos sobre el he intentado con sudo nautilus para cambiarlos pero no me deja tengo el fstab de la siguiente manera
mira si puede ser algo de ahi porfa
proc /proc proc nodev,noexec,nosuid 0 0
#Entry for /dev/sdb2 :
UUID=26bf2b2d-e06c-40ea-980b-8cd4417860ec / ext4 errors=remount-ro 0 1
#Entry for /dev/sdb3 :
UUID=061ca167-be47-4ef8-ac86-587605a80804 /home ext4 defaults 0 2
#Entry for /dev/sdb1 :
UUID=4fc34d43-0b7a-4715-a799-ec0a9d3985fe none swap sw 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
/dev/sda1 /media/datos ntfs-3g defaults,locale=es_ES.utf8,umask=0,UID=...,GID=... 0 0

tambien lo he probado poniendo en uuid y lo mismo
que desastre dios mio
no tendra nada que ver si el disco este en maestro o esclavo? ya no se que pensar en la version 12.10 va bien y aqui no

+1
0
-1
Imagen de .doc
+1
0
-1

pues no tengo ni idea, pero haz una cosa: abre una consola en Ubuntu, teclea (o copia y pega)
sudo fdisk -l
y copia aquí lo que te salga (así veremos cómo tienes tus dos discos y cómo está el tema del arranque)

+1
0
-1
Imagen de Alcruz
+1
0
-1

Si no quieres liarte con el fstab , te recomiendo instalar "disk-manager"
http://ftp.debian.org/debian/pool/main/d/disk-manager/disk-manager_1.1.1...
es de los repos de Debian, pero funciona muy bien en Ubuntu
Luego ejecuta
sudo disk-manager
ya ya podrás elegir en forma gráfica las partocopnes que quieres se monten al inicio.

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

es ¿Que has reinstalado 10 veces en la semana? Ubuntu 11.10 o Ubuntu 12.10, ¿con cual de las dos versiones tienes el problema de las particiones NTFS y de los permisos?

por que en ninunga versión necesitabas hacer cambio alguno para esas cosas, puedes acceder como usuario normal a la partición NTFS.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de drewdty
+1
0
-1

bueno doc este es el fdisk-l
Dispositivo Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 63 156296384 78148161 7 HPFS/NTFS/exFAT

Disco /dev/sdb: 203.9 GB, 203927027200 bytes
255 cabezas, 63 sectores/pista, 24792 cilindros, 398294975 sectores en total
Unidades = sectores de 1 * 512 = 512 bytes
Tamaño de sector (lógico / físico): 512 bytes / 512 bytes
Tamaño E/S (mínimo/óptimo): 512 bytes / 512 bytes
Identificador del disco: 0x8f47cac6

Dispositivo Inicio Comienzo Fin Bloques Id Sistema
/dev/sdb1 2048 4098047 2048000 82 Linux swap / Solaris
/dev/sdb2 * 4098048 45199359 20550656 83 Linux
/dev/sdb3 45199360 221040639 87920640 83 Linux
alcruz ya lo he instalado y el ntfsutils tambien y otro que no me acuerdo como se llama sympex o algo asi , el problema silo monto yo manual tengo permisos pero al montarlo automaticamente solo root puede acceder dice que no soy propietario y no puedo compartir archivos en red.

Jose Luis 1320 ya no son 10, utilizo la version 11.10 que es la problematica que es la que mejor me va con wine la version 12.10 y mint14 me detecta y monta y me da permisos pero me dan problemas con wine, la version 10.10 tambien me funcionaba editando fstab pero nose que paso ya llevo tiempo usando ubuntu( bueno unos dos años) pero esto se me escapa ahora mismo se me monta el disco ^datos^ pero no meda permiso de usuario parapoder compartir ni con samba ni editando smb
se que cuando de con ello sera una chorrada como siempre

+1
0
-1
Imagen de drewdty
+1
0
-1

bueno visto lo visto se me ha estropeado el pc y todo de tanto reiniciar no se que le pasa pero se reinicia solo nada mas encender estoy en otro pc por supuesto, el tema lo he solucionado cambiando de sistema operativo
gracias doc por el tiempo dedicado ....

+1
0
-1