no puedo actualizar al kernel 3.2.0.36 en Xubuntu 12.04 (solucionado)

hola amigos

Cuando intento del kernel 3.2.0.35 al 3.2.0.36 me da un error y no puedo actualizar el kernel. H probado tanto con apt como como aptitude. El error que me da es el siguiente:
sudo apt-get upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Calculando la actualización... Listo
0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
3 no instalados del todo o eliminados.
Se utilizarán 0 B de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]?
Configurando linux-image-3.2.0-36-generic (3.2.0-36.57) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
The link /initrd.img is a dangling linkto /boot/initrd.img-3.2.0-36-generic
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-36-generic /boot/vmlinuz-3.2.0-36-generic
update-initramfs: Generating /boot/initrd.img-3.2.0-36-generic

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-3.2.0-36-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.2.0-36-generic.postinst line 1010.

dpkg: error al procesar linux-image-3.2.0-36-generic (--configure):
el subproceso instalado el script post-installation devolvió el código de salida de error 2
dpkg: problemas de dependencias impiden la configuración de linux-image-generic:
linux-image-generic depende de linux-image-3.2.0-36-generic; sin embargo:
El paquete `linux-image-3.2.0-36-generic' no está configurado todavía.
dpkg: error al procesar linux-image-generic (--configure):
problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de linux-generic:
linux-generic depende de linux-image-generic (= 3.2.0.36.43); sin embargo:
El paquete `linux-image-generic' no está configurado todavía.
dpkg: error al procesar linux-generic (--configure):
problemas de dependencias - se deja sin configurar
No se escribió un informe «apport» porque el mensaje de error indica que es un mensaje de error asociado a un fallo previo.
No se escribió un informe «apport» porque el mensaje de error indica que es un mensaje de error asociado a un fallo previo.
Se encontraron errores al procesar:
linux-image-3.2.0-36-generic
linux-image-generic
linux-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

alguien sabe que esta fallando?

Imagen de Gabriel_M
+1
0
-1

Parece que no tienes espacio libre
ejecuta en una terminal

sudo su
apt-get clean
apt-get autoremove
apt-get update
apt-get dist-upgrade
+1
0
-1
Imagen de jccall80
+1
0
-1

gracias por la ayuda. el problema esta solucionado.

tenia la partición boot casi llena y por esto me daba error. He borrado un kernel y el problema se ha solucionado.

+1
0
-1