Error de dependencias rotas

Imagen de fraj123
0 puntos

Hola soy re novato usando ubuntu y he querido instalar piklab siguiendo el sgte tutorial
http://www.youtube.com/watch?v=U1nQSrW31yc

Copiando el sgte codigo

# agregar los repositorios de kde
sudo add-apt-repository ppa:kubuntu-ppa/backports
sudo apt-get update

# descargar paquetes deb
wget archive.ubuntu.com/ubuntu/pool/main/q/qt-x11-free/libqt3-mt_3.3.8-b-8ubuntu3_i38­6.deb
wget http://launchpadlibrarian.net/68040450/kdelibs-data_3.5.10.dfsg.1-5ubunt......
wget http://launchpadlibrarian.net/68495846/libavahi-qt3-1_0.6.30-0ubuntu2_i3...
wget http://launchpadlibrarian.net/35166252/liblua50_5.0.3-4_i386.deb
wget http://launchpadlibrarian.net/35166254/liblualib50_5.0.3-4_i386.deb
wget http://launchpadlibrarian.net/68040451/kdelibs4c2a_3.5.10.dfsg.1-5ubuntu......
wget http.us.debian.org/debian/pool/main/p/piklab/piklab_0.15.7-1_i386.deb

#instalar paquetes deb
sudo apt-get install kdelibs5-data sdcc gputils

sudo dpkg -i kdelibs-data_3.5.10.dfsg.1-5ubuntu2_all.deb
sudo dpkg -i libqt3-mt_3.3.8-b-8ubuntu3_i386.deb
sudo dpkg -i libavahi-qt3-1_0.6.30-0ubuntu2_i386.deb
sudo dpkg -i liblua50_5.0.3-4_i386.deb
sudo dpkg -i liblualib50_5.0.3-4_i386.deb
sudo dpkg -i kdelibs4c2a_3.5.10.dfsg.1-5ubuntu2_i386.deb
sudo dpkg -i piklab_0.15.7-1_i386.deb

Pero al finalizar todo y tratar de abrir piklab me dice q existe un error y q posiblemente sea por dependecias incompletas y en la terminal me sale el sgte error al tratar de instalar o desinstalar algun otro programa

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Tal vez quiera ejecutar «apt-get -f install» para corregirlo.
Los siguientes paquetes tienen dependencias incumplidas:
libavahi-qt3-1 : Depende: libjpeg62 (>= 6b1) pero no está instalado
Depende: libqt3-mt (>= 3:3.3.8-b) pero no es instalable
piklab : Depende: kdelibs4c2a (>= 4:3.5.9) pero no es instalable
Depende: libqt3-mt (>= 3:3.3.8b) pero no es instalable
Recomienda: libusb-dev pero no está instalado
E: Dependencias incumplidas. Pruebe de nuevo usando -f.

Imagen de hipericus
+1
0
-1

¿has probado a tratar de resolver esas dependencias? En el mismo texto que te devuelve te da la posible solución:

Tal vez quiera ejecutar «apt-get -f install» para corregirlo.

Abre terminal,

sudo apt-get -f install

mete la contraseña, y enter, y a ver que pasa.....

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

¿Que versión de Ubuntu estas usando?
¿Por que la necesidad de agregar el repositorio backports de KDE?

¿y que razón hay para hacer esto?

sudo apt-get install kdelibs5-data sdcc gputils

sudo dpkg -i kdelibs-data_3.5.10.dfsg.1-5ubuntu2_all.deb
sudo dpkg -i libqt3-mt_3.3.8-b-8ubuntu3_i386.deb
sudo dpkg -i libavahi-qt3-1_0.6.30-0ubuntu2_i386.deb
sudo dpkg -i liblua50_5.0.3-4_i386.deb
sudo dpkg -i liblualib50_5.0.3-4_i386.deb
sudo dpkg -i kdelibs4c2a_3.5.10.dfsg.1-5ubuntu2_i386.deb
sudo dpkg -i piklab_0.15.7-1_i386.deb

El hacer la instalación de paquetes de esta manera causa serios problemas...

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro