(Solucionado)Quiero instalar banshee

Imagen de preguntonnovato
0 puntos

Hola!, aunque pongo esto en el hilo de principiantes en realidad no lo soy. Llevo ya cerca de cuatro años con Ubuntu. Yo estaba muy cómodo en 10.04, pero un día falló y aproveché la oportunidad para cambiarme a a Ubuntu 12.04 LTS,en el que sí soy nuevo.

Pues todo muy bien hasta que quise instalar banshee, que es una de las cosas que más uso. Sé que se puede porque lo he visto, pero no se cómo, y al intentar instalarlo desde el Centro de Software no me deja instalar nada porque me tira lo siguiente:

No se pueden instalar ni desintalar elementos hasta que se repare el catálogo de paquetes. ¿Quiere repararlo ahora?
Una vez que el Gesotr de Actualizaciones haya finalizado las reparaciones puede cerrarlo y volver a la tienda.

Y cuando me voy al gestor de actualizaciones me dice:

El paquete de sistema está roto
Compruebe si está usando repositorios de terceros. En tal caso, desactívelos, ya que son una fuente habitual de problemas.
Posteriormente, ejecute el siguiente comando en un terminal: apt-get install -f
Los siguientes paquetes tienen dependencias incumplidas:

libperl5.14: Depends: perl-base (= 5.14.2-6ubuntu2.1) pero 5.14.2-6ubuntu2.2 está instalado

Los desactivo. Y al querer hacer lo que me pide desde la terminal me dice lo siguiente:

E: No se pudo abrir el fichero de bloqueo «/var/lib/dpkg/lock» - open (13: Permiso denegado)
E: No se encontró un archivo de réplica «/var/lib/dpkg/»
Asíque ya me harté y decidí instalarlo desde la terminal, que me dice esto:
Los siguientes paquetes tienen dependencias incumplidas:
banshee : Depende: libwebkitgtk-1.0-0 (>= 1.7.5) pero no va a instalarse
Depende: mono-runtime (>= 2.10.1) pero no va a instalarse
Depende: libdbus-glib1.0-cil (>= 0.5) pero no va a instalarse
Depende: libdbus1.0-cil (>= 0.7) pero no va a instalarse
Depende: libgconf2.0-cil (>= 2.24.0) pero no va a instalarse
Depende: libgdata1.9-cil (>= 1.9.0.0) pero no va a instalarse
Depende: libgkeyfile1.0-cil pero no va a instalarse
Depende: libglib2.0-cil (>= 2.12.10-1ubuntu1) pero no va a instalarse
Depende: libgtk-sharp-beans-cil pero no va a instalarse
Depende: libgtk2.0-cil (>= 2.12.10-1ubuntu1) pero no va a instalarse
Depende: libgudev1.0-cil (>= 0.1) pero no va a instalarse
Depende: libmono-addins0.2-cil (>= 0.6) pero no va a instalarse
Depende: libmono-cairo4.0-cil (>= 2.10.1) pero no va a instalarse
Depende: libmono-corlib4.0-cil (>= 2.10.1) pero no va a instalarse
Depende: libmono-posix4.0-cil (>= 2.10.1) pero no va a instalarse
Depende: libmono-sharpzip4.84-cil (>= 1.0) pero no va a instalarse
Depende: libmono-system-core4.0-cil (>= 2.10.3) pero no va a instalarse
Depende: libmono-system-xml4.0-cil (>= 1.0) pero no va a instalarse
Depende: libmono-system4.0-cil (>= 2.10.7) pero no va a instalarse
Depende: libmono-zeroconf1.0-cil (>= 0.9.0) pero no va a instalarse
Depende: libnotify0.4-cil (>= 0.4.0~r2998) pero no va a instalarse
Depende: libtaglib2.0-cil (>= 2.0.4.0) pero no va a instalarse
Recomienda: banshee-extension-soundmenu (= 2.4.1-3ubuntu1~precise2) pero no va a instalarse
libperl5.14 : Depende: perl-base (= 5.14.2-6ubuntu2.1) pero 5.14.2-6ubuntu2.2 va a ser instalado
E: Dependencias incumplidas. Intente «apt-get -f install» sin paquetes (o especifique una solución).

En resúmen, un error tras otro que terminan llevándome a un bucle de errores sin fín. Ya estoy que no sé que hay que hacer, y si alguien me puede ayudar cuanto antes mejor.

Imagen de preguntonnovato
+1
0
-1

En serio ¿nadie?

+1
0
-1

Lobo malo, El silencio caerá, la única canción en el bosque es el río, Hello Stonehenge!
http://mynichijou.wordpress.com

Imagen de Gabriel_M
+1
0
-1

... lee y respeta las normas, no seas impaciente: Recuerda que esto es un foro de ayuda mutua entre usuarios, no un servicio técnico. Al hacer una consulta estás pidiendo un favor, no tienes derecho a exigir una respuesta ni a imponer condiciones.
Prueba abrir una terminal.
Editar el archivo sources.list y dejar solo repositorios para precise.
Luego ejecutar

sudo su
apt-get update
dpkg --configure -a
apt-get install -f
apt-get autoremove
apt-get clean
add-apt-repository ppa:banshee-team/ppa
apt-get update
apt-get install banshee
apt-get autoclean
+1
0
-1
Imagen de preguntonnovato
+1
0
-1

Muchas gracias, perdona mi impaciencia pero es que ya estaba que me subía por las paredes. Probaré lo que me has dicho con los repositorios

+1
0
-1

Lobo malo, El silencio caerá, la única canción en el bosque es el río, Hello Stonehenge!
http://mynichijou.wordpress.com

Imagen de preguntonnovato
+1
0
-1

Bueno, al menos ahora ya se ha corregido parte del error pero ahora tira un error de GPG:

W: Error de GPG: http://packages.medibuntu.org precise InRelease: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 2EBC26B60C5A2783

Y cuando quiero hacerlo funcionar con "gpg --keyserver subkeys.pgp.net --recv-key 0C5A2783 && gpg -a --export $PUBKRY | sudo apt-key add"

Me dice:
gpg: /root/.gnupg: directorio creado
gpg: creado un nuevo archivo de configuración `/root/.gnupg/gpg.conf'
gpg: AVISO: las opciones en `/root/.gnupg/gpg.conf' no están aún activas en esta ejecución
gpg: anillo «/root/.gnupg/secring.gpg» creado
gpg: anillo «/root/.gnupg/pubring.gpg» creado
gpg: solicitando clave 0C5A2783 de hkp servidor subkeys.pgp.net
gpg: /root/.gnupg/trustdb.gpg: se ha creado base de datos de confianza
gpg: clave 0C5A2783: clave pública "Medibuntu Packaging Team " importada
gpg: no se encuentran claves totalmente fiables
gpg: Cantidad total procesada: 1
gpg: importadas: 1
gpg: no se puede abrir «»: No existe el archivo o el directorio

Y esto no me había pasado antes ¿qué tengo que hacer?

+1
0
-1

Lobo malo, El silencio caerá, la única canción en el bosque es el río, Hello Stonehenge!
http://mynichijou.wordpress.com

Imagen de preguntonnovato
+1
0
-1

Bien, ya conseguí una forma de solucionarlo, que aunque es para lubuntu también sirve para ubuntu http://erlitrimoreno.blogspot.com.es/2012/10/medibuntu-error-de-gpg-en-l..., y ya consigo actualizar normal desde la terminal, pero al intentar instalar banshee con sudo apt-get install banshee me dice lo siguiente:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Tal vez quiera ejecutar «apt-get -f install» para corregirlo:
Los siguientes paquetes tienen dependencias incumplidas:
banshee : Depende: libwebkitgtk-1.0-0 (>= 1.7.5) pero no va a instalarse
Depende: mono-runtime (>= 2.10.1) pero no va a instalarse
Depende: libdbus-glib1.0-cil (>= 0.5) pero no va a instalarse
Depende: libdbus1.0-cil (>= 0.7) pero no va a instalarse
Depende: libgconf2.0-cil (>= 2.24.0) pero no va a instalarse
Depende: libgdata1.9-cil (>= 1.9.0.0) pero no va a instalarse
Depende: libgkeyfile1.0-cil pero no va a instalarse
Depende: libglib2.0-cil (>= 2.12.10-1ubuntu1) pero no va a instalarse
Depende: libgtk-sharp-beans-cil pero no va a instalarse
Depende: libgtk2.0-cil (>= 2.12.10-1ubuntu1) pero no va a instalarse
Depende: libgudev1.0-cil (>= 0.1) pero no va a instalarse
Depende: libmono-addins0.2-cil (>= 0.6) pero no va a instalarse
Depende: libmono-cairo4.0-cil (>= 2.10.1) pero no va a instalarse
Depende: libmono-corlib4.0-cil (>= 2.10.1) pero no va a instalarse
Depende: libmono-posix4.0-cil (>= 2.10.1) pero no va a instalarse
Depende: libmono-sharpzip4.84-cil (>= 1.0) pero no va a instalarse
Depende: libmono-system-core4.0-cil (>= 2.10.3) pero no va a instalarse
Depende: libmono-system-xml4.0-cil (>= 1.0) pero no va a instalarse
Depende: libmono-system4.0-cil (>= 2.10.7) pero no va a instalarse
Depende: libmono-zeroconf1.0-cil (>= 0.9.0) pero no va a instalarse
Depende: libnotify0.4-cil (>= 0.4.0~r2998) pero no va a instalarse
Depende: libtaglib2.0-cil (>= 2.0.4.0) pero no va a instalarse
Recomienda: banshee-extension-soundmenu (= 2.4.1-3ubuntu1~precise2) pero no va a instalarse
libperl5.14 : Depende: perl-base (= 5.14.2-6ubuntu2.1) pero 5.14.2-6ubuntu2.2 va a ser instalado
E: Dependencias incumplidas. Intente «apt-get -f install» sin paquetes (o especifique una solución).

Y luego al querer actualizar con el Gestor de Actualizaciones me dice:

El paquete de sistema está roto

Compruebe si está usando repositorios de terceros. En tal caso, desactívelos, ya que son una fuente habitual de problemas.
Posteriormente, ejecute el siguiente comando en un terminal: apt-get install -f
Detalles
Los siguientes paquetes tienen dependencias incumplidas:

libperl5.14: Depends: perl-base (= 5.14.2-6ubuntu2.1) pero 5.14.2-6ubuntu2.2 está instalado

Y ahora sí que no veo solución posible

+1
0
-1

Lobo malo, El silencio caerá, la única canción en el bosque es el río, Hello Stonehenge!
http://mynichijou.wordpress.com

Imagen de LyingB
+1
0
-1

colocar aquí el contenido de tu sources.list?

Es probable que estés usando repositorios de otras versiones de Ubuntu.

+1
0
-1


Agrega al final del título del post (solucionado) si has arreglado tu problema.

Imagen de preguntonnovato
+1
0
-1

# deb cdrom:[Ubuntu 12.04.1 LTS _Precise Pangolin_ - Release i386 (20120817.3)]/ precise main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://archive.ubuntu.com/ubuntu precise main restricted
deb-src http://archive.ubuntu.com/ubuntu precise main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu precise-updates main restricted
deb-src http://archive.ubuntu.com/ubuntu precise-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu precise universe
deb-src http://archive.ubuntu.com/ubuntu precise universe
deb http://archive.ubuntu.com/ubuntu precise-updates universe
deb-src http://archive.ubuntu.com/ubuntu precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://archive.ubuntu.com/ubuntu precise multiverse
deb-src http://archive.ubuntu.com/ubuntu precise multiverse
deb http://archive.ubuntu.com/ubuntu precise-updates multiverse
deb-src http://archive.ubuntu.com/ubuntu precise-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu precise-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu precise-backports main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu precise-security main restricted
deb-src http://archive.ubuntu.com/ubuntu precise-security main restricted
deb http://archive.ubuntu.com/ubuntu precise-security universe
deb-src http://archive.ubuntu.com/ubuntu precise-security universe
deb http://archive.ubuntu.com/ubuntu precise-security multiverse
deb-src http://archive.ubuntu.com/ubuntu precise-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu precise main
deb http://archive.ubuntu.com/ubuntu precise-proposed restricted main multiverse universe
deb-src http://extras.ubuntu.com/ubuntu precise main

Este es todo el sources.list

+1
0
-1

Lobo malo, El silencio caerá, la única canción en el bosque es el río, Hello Stonehenge!
http://mynichijou.wordpress.com

Imagen de Goyo
+1
0
-1

libperl5.14: Depends: perl-base (= 5.14.2-6ubuntu2.1) pero 5.14.2-6ubuntu2.2 está instalado

Pega la salida de este comando:
apt-cache policy libperl5.14

+1
0
-1
Imagen de preguntonnovato
+1
0
-1

Muchas gracias. Funcionó! Jamás pensé que esto me fuese a pasar con mi querido ubuntu. Bueno, gracias por ayudarme

+1
0
-1

Lobo malo, El silencio caerá, la única canción en el bosque es el río, Hello Stonehenge!
http://mynichijou.wordpress.com

Imagen de Goyo
+1
0
-1

No, ese comando no puede hacer que nada funcione. Solo proporciona información que me pareció que sería útil. Habrá sido otra cosa.

+1
0
-1
Imagen de preguntonnovato
+1
0
-1

Pues, amigo, hizo que las cosas empezaran a andar. Pero ahora no, http://www.ubuntu-es.org/node/176366

+1
0
-1

Lobo malo, El silencio caerá, la única canción en el bosque es el río, Hello Stonehenge!
http://mynichijou.wordpress.com