Compartir Internet via Wi-Fi

Imagen de flagg327
0 puntos

El tema es el siguiente:

Tengo un Adaptador USB inalámbrico 802.11n ENUWI-NX2 de Encore (más info al final). En Windows 7 podía compartir mi conexión a Internet cableada a través de éste dispositivo, tal cual una emisora wi-fi con el programa Connectify.

¿Como podría hacer lo mismo en Ubuntu 12.10?
¿Cómo saber si el adaptador está bien instalado?

Saludos.

info: http://www.encore-usa.com/ar/product/ENUWI-NX2

Imagen de gledof
+1
0
-1

el sistema reconoce la interface wifi cuando la conectas y chequear si detecta otras redes cercanas. Despues entra a la configuracion de red y en la solapa de "inalambrica" configura la interface como Ad-Hoc y asi otras computadoras podran salir a internet a traves de esta PC.

+1
0
-1

Saludos.----

Imagen de flagg327
+1
0
-1

me pasa lo siguiente. Sin el adaptador conectado, navego normal a través de mi conexión cableada. Si en algún momento conecto el adaptador, empiezo a tener problemas:

- No cargan las páginas de ningún navegador.
- El applet de Network Manager se vuelve tonto, no me deja tocar nada.
- El terminal, ejecute lo que ejecute, se queda pensando sin hacer nada.
- Si reinicio el sistema el applet de Networ Manager desaparece o aparece en una versión super limitada que solo muestra las dos conexiones (cableada, inalámbrica) y nada más.

En cuanto lo desconecto todo vuelve a la normalidad, excepto el applet...

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

.... el adaptador wi-fi con IP estática para que actue como gateway, sin gateway para que no interfiera con la conexion a internet.
Esto lo haces en el archivo /etc/network/interfaces
Lo editas y al final le agregas la configuración, con estas líneas, donde
debes cambiar wlan0 por la que corresponde a tu dispositivo wifi

    # Wireless card
    auto wlan0
    iface wlan0 inet static
    madwifi-base wifi0
    madwifi-mode adhoc
    wireless-essid MiRed
    wireless-key s:12345
    address 192.168.4.1
    netmask 255.255.255.0
    post-up /etc/network/share_internet || true

Donde

auto wlan0 -------- Esta interfaz se inicia con el sistema en forma automática.
iface wlan0 inet static ---------  Se configura de manera estática.
madwifi-base wifi0 ---------- Este es un dispositivo que se muestra cuando se hace un ifconfig.
madwifi-mode adhoc --------- Cambiarse el modo a adhoc
wireless-essid ------------ El nombre de la red
wireless-key ------------ Contraseña de la red, para que un ordenador con Windows pueda conectarse a esta red la contraseña debe tener exactamente 5 o 10 caracteres.
address ------------ Dirección IP asignada manualmente
netmask ----------- Máscara de red correspondiente
post-up /etc/network/share_internet || true ---- Ejecución de un script para cargar el modulo de iptables_nat,  configurar el nateo y  activarlo.

El script debe tener algo similar a:

    #!/bin/bash
    modprobe iptable_nat
    iptables -t nat -A POSTROUTING -o $IFACE -j MASQUERADE
    echo 1 > /proc/sys/net/ipv4/ip_forward
    exit 0 
+1
0
-1
Imagen de flagg327
+1
0
-1

tengo el problema de que al meter el adaptador, todo la conexión comienza a funcionar mal... como soluciono eso?

ésto es lo que me muestra el archivo /etc/networks/interfaces cuando no tengo el adaptador wi-fi conectado

auto lo
iface lo inet loopback

+1
0
-1