Problema con Drivers AMD! D:

Imagen de trust17
0 puntos

Buenos días, tengo un problema desde ayer por culpa de una estupidez que hice.

Tengo Ubuntu 12.10 en un portátil y instalé los drivers privativos de AMD (y Catalyst), la versión 12 y pico que tenía desde hace medio año(todo bien). Yo quería actualizar a la 13.1 que salió hace nada, pero llevo todo el día y lo único que he conseguido es forzar la instalación (al querer instalar me pedía que quitara el driver fglrx viejo e instalara la nueva versión), yo pensé después de pruebas y cabrear-me (soy un poco nuevo en esto), a lo mejor si lo fuerzo se mete encima del otro y funciona, respuesta clara y rotunda: NO.
Así solo he conseguido que no me arranque “casi” el Ubuntu, que hice? Como funcionaba la terminal con atajo del teclado, seguí unos comandos que encontré en un blog para desinstalar y volver a poner todo como estaba antes, y se supone que ha funcionado y estoy con los drivers abiertos que venía de serie. De momento funciona si, pero se han “roto” algunos paquetes de Ubuntu, me pide si quiero repararlos y no funciona, me da error, me dice algo del error del fglrx, y algo de que los vuelva a instalar o que están corruptos (o que dependen de otros y por eso no se deja hacer).
En la torre ya no te cuento, para intentar instalar la gráfica he instalado los drivers privativos y nada, forcé la instalación por probar (me pedía instalar el fglrx, lo hice y nada, seguía igual) y adiós Ubuntu, ni la terminal se me abre… (como lo instalé ayer no me cuesta nada volverlo a poner) pero en el portátil es algo que me “jode” más…
En resumen, estoy buscando como loco y no encuentro soluciones, o no funcionan, a lo mejor alguien me puede echar una mano!

Un ejemplo de error:

XXXXXXXXX~$ sudo apt-get install libgl1-mesa-glx:i386[sudo] password for albert:
Leyendo lista de paquetes… Hecho
Creando árbol de dependencias
Leyendo la información de estado… Hecho
libgl1-mesa-glx:i386 ya está en su versión más reciente.
Tal vez quiera ejecutar «apt-get -f install» para corregirlo:
Los siguientes paquetes tienen dependencias incumplidas:
fglrx-amdcccle : Depende: fglrx
fglrx-dev : Depende: fglrx
E: Dependencias incumplidas. Intente «apt-get -f install» sin paquetes (o especifique una solución).

Error en reparar los paquetes corruptos:
http://www.foro.ubuntu-guia.com/file/n4028807/repararu.jpg

installArchives() failed: (Reading database …
(Reading database … 5%
(Reading database … 10%
(Reading database … 15%
(Reading database … 20%
(Reading database … 25%
(Reading database … 30%
(Reading database … 35%
(Reading database … 40%
(Reading database … 45%
(Reading database … 50%
(Reading database … 55%
(Reading database … 60%
(Reading database … 65%
(Reading database … 70%
(Reading database … 75%
(Reading database … 80%
(Reading database … 85%
(Reading database … 90%
(Reading database … 95%
(Reading database … 100%
(Reading database … 249739 files and directories currently installed.)
Unpacking fglrx (from …/fglrx_2%3a9.012-0ubuntu1~xedgers~quantal1_amd64.deb) …
/usr/share/ati/fglrx-uninstall.sh: 32: /usr/share/ati/fglrx-uninstall.sh: cannot create /etc/ati/fglrx-uninstall.log: Directory nonexistent

[Warning] Uninstall : inst_path_default or inst_path_override
does not exist in /etc/ati. This suggests that the AMD driver
is not installed, the AMD driver is only partially installed,
or the current AMD driver installed is an older version than the
one this script was designed for. Both files listed above are
required for determining where installed files are located.
To force uninstallation of the driver by guessing where the
uninstallation files are located, set the force option
re-run /usr/share/ati/fglrx-uninstall.sh (this is not recommended).

dpkg: error processing /var/cache/apt/archives/fglrx_2%3a9.012-0ubuntu1~xedgers~quantal1_amd64.deb (–unpack):
subprocess new pre-installation script returned error exit status 1
No apport report written because MaxReports is reached already
Errors were encountered while processing:
/var/cache/apt/archives/fglrx_2%3a9.012-0ubuntu1~xedgers~quantal1_amd64.deb
dpkg: dependency problems prevent configuration of fglrx-dev:
fglrx-dev depends on fglrx; however:
Package fglrx is not installed.
Package fglrx-updates which provides fglrx is not installed.

dpkg: error processing fglrx-dev (–configure):
dependency problems – leaving unconfigured
dpkg: dependency problems prevent configuration of fglrx-amdcccle:
fglrx-amdcccle depends on fglrx; however:
Package fglrx is not installed.
Package fglrx-updates which provides fglrx is not installed.

dpkg: error processing fglrx-amdcccle (–configure):
dependency problems – leaving unconfigured

Un saludo y gracias