Problema para instalar o desinstalar programas por algo relacionado al grub

Imagen de Spacenoids
0 puntos

Resulta que se me presento hace cosa de un mes el problema con el grub despues de la instalacion del windows 8 y mi version de ubuntu. Logre solucionarlo leyendo otro tema del foro pero hara cosa de una horas que no puedo instalar y desinstalar nada usando el centro de software. Cuendo lo abro aparece este mensaje.

El paquete de sistema esta roto

Compruebe si está usando repositorios de terceros. En tal caso, desactívelos, ya que son una fuente habitual de problemas.
Posteriormente, ejecute el siguiente comando en un terminal: apt-get install -f
Detalles: Los siguientes paquetes tienen dependencias incumplidas:

grub-pc: Depends: grub2-common (= 1.99-21ubuntu3.4) pero 1.99-21ubuntu3.7 está instalado
Depends: grub-pc-bin (= 1.99-21ubuntu3.4) pero 1.99-21ubuntu3.7 está instalado

En el terminal puse:

apt-get install -f y me salio este mensaje aun mas extenso.

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
lib32gcc1 dkms libcurl3-gnutls:i386
Utilice «apt-get autoremove» para eliminarlos.
Se instalarán los siguientes paquetes extras:
grub-pc
Se actualizarán los siguientes paquetes:
grub-pc
1 actualizados, 0 se instalarán, 0 para eliminar y 121 no actualizados.
1 no instalados del todo o eliminados.
Se necesita descargar 0 B/140 kB de archivos.
Se utilizarán 0 B de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? s
dpkg: problemas de dependencias impiden la configuración de grub-pc:
grub-pc depende de grub2-common (= 1.99-21ubuntu3.4); sin embargo:
La versión de `grub2-common' en el sistema es 1.99-21ubuntu3.7.
grub-pc depende de grub-pc-bin (= 1.99-21ubuntu3.4); sin embargo:
La versión de `grub-pc-bin' en el sistema es 1.99-21ubuntu3.7.
dpkg: error al procesar grub-pc (--configure):
problemas de dependencias - se deja sin configurar
No se escribió un informe «apport» porque el mensaje de error indica que es un mensaje de error asociado a un fallo previo.
Se encontraron errores al procesar:
grub-pc
E: Sub-process /usr/bin/dpkg returned an error code (1)

Espero, como siempre, que me puedan ayudar, gracias anticipadas. =)