Mensaje de "ERROR" tras apagón actualizando OS.

Imagen de Jsx
Jsx
0 puntos

Hola,

Actualizando mi Ubuntu 10.04 a 12.04, he sufrido un apagón (se ha soltado el cable de alimentación del portátil, y mi bateria no funciona). Al reiniciar, en el panel superior, aparece una señal de "prohibido" (tipo señal de tráfico). Al clickar sobre esta aparece el siguiente mensaje. Abro el gestor de paquetes, y el de actualización pero aparecen mensajes de error. No puedo continuar la actualización.

<" E: La asignación dinámica MMap no tiene más espacio. Por favor, incrementa el valor de «APT::Cache-Limit». El valor actual es: 25165824 (man 5 apt.conf)
E: Ocurrió un error mientras se procesaba virtuoso-opensource (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_universe_binary-i386_Packages
E: Las listas de paquetes o el archivo de estado no se pueden analizar sintácticamente o abrir.
E: _cache->open() failed, please report.

W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ precise/partner Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_precise_partner_binary-i386_Packages)
W: Unable to munmap ">

Al abrir el gestor de paquetes, y el de actualización aparecen mensajes de error. No puedo continuar la actualización.

(Equipo):

Toshiba Sattelite L20 - 101.
Procesador Intel. 1.7 Ghz.
Ram. 2Gb (DDR2)
HD. 500 Gb.

Imagen de Gabriel_M
+1
0
-1

Desmonta las particiones del disco interno y corre sobre ellas fsck

sudo su
fsck /dev/sda1 -a

Monta luego la partición, busca el directorio /var/lib/apt/lists/
y borra su contenido no el directorio
Reinicia del disco interno, abre una terminal y ejecuta

sudo su
dpkg --configure -a
apt-get install -f
apt-get update
apt-get dist-upgrade
apt-get clean
+1
0
-1
Imagen de Jsx
+1
0
-1

Acabo de abrir terminal, he puesto:
> sudo apt-get aupdate
la respuesta es:
> Leyendo lista de paquetes... ¡Error!
W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ precise/partner Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_precise_partner_binary-i386_Packages)
E: La asignación dinámica MMap no tiene más espacio. Por favor, incrementa el valor de «APT::Cache-Limit». El valor actual es: 25165824 (man 5 apt.conf)
E: Ocurrió un error mientras se procesaba robotfindskitten (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_universe_binary-i386_Packages
W: Unable to munmap
E: No se pudieron analizar o abrir las listas de paquetes o el archivo de estado

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

sudo su
nano /etc/apt/sources.list

Elimina todo su contenido
Pega este

deb http://archive.ubuntu.com/ubuntu precise main restricted
deb-src http://archive.ubuntu.com/ubuntu precise restricted main multiverse universe #Added by software-properties
deb http://archive.ubuntu.com/ubuntu precise universe
deb http://archive.ubuntu.com/ubuntu precise multiverse
deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner
deb http://extras.ubuntu.com/ubuntu precise main
deb-src http://extras.ubuntu.com/ubuntu precise main
deb http://security.ubuntu.com/ubuntu/ precise-security restricted main multiverse universe
deb http://archive.ubuntu.com/ubuntu precise-updates restricted main multiverse universe
deb http://archive.ubuntu.com/ubuntu precise-proposed restricted main multiverse universe
deb http://archive.ubuntu.com/ubuntu precise-backports restricted main multiverse universe

Guarda el archivo (Control + O)
Cierra nano (Control + X)
Continua ejecutando en la misma terminal

apt-get update
apt-get dist-upgrade
dpkg --configure -a
reboot

Una vez reiniciado con precise, en una terminal ejecuta

sudo su
apt-get autoremove
apt-get clean
+1
0
-1
Imagen de Jsx
+1
0
-1

Una ultima cosa antes de comenzar ¿es recomendable hacer una copia de seguridad de los documentos durante el proceso, o no se hace necesario?
Muchas gracias, de verdad.
Un saludo grande.

+1
0
-1
Imagen de Jsx
+1
0
-1

Ahora entiendo lo que estoy haciendo. Perdon, por que laultima pregunta no venia al caso. Y gracias (de nuevo). ;)

+1
0
-1
Imagen de Jsx
+1
0
-1

Tras hacer lo que comentas, he resuleto parcialemnte el problema. Lo que ha ocurrido ha sido que se ha actualizado la lista de repositorios sin problemas salvo que al final me ha dicho que algunos paquetes no habian podido ser descargados. Me ha sugerido hacer un "update", lo he hecho pero nada. Tras reiniciar el equipo he iniciado el gestor de aplicaciones para ver que había, y me ha salido que tan solo me permite una actualizacion parcial de todo el sistema debido a que faltan paquetes. La he iniciado y enseguida me ha salido un aviso de fallo. . Y debajo, en el box: ""Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/c/chardet/python-chardet_2.0.... El tamaño difiere""

¿Que puedo hacer ahora? Gracias.

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

... terminal:

sudo su
apt-get clean
apt-get autoremove
apt-get install -f
dpkg --configure -a
apt-get update
apt-get dist-upgrade
+1
0
-1
Imagen de Jsx
+1
0
-1

Tras ejecutar

"apt-get update",

y me sale:

Descargados 1322kB en 3seg. (387kB/s)
Leyendo lista de paquetes... Hecho
""W: Error de GPG: http://extras.ubuntu.com precise Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 16126D3A3E5C1192""

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Es una simple falta de llave pública, si todo funciona bien, una vez completada la actualización, busca en el foro que hay muchos post al respecto de como actualizar la llave publica de un repositorio.

+1
0
-1
Imagen de Jsx
+1
0
-1

Muchas gracias Gabriel, te voy a hacer caso.

Un saludo muy cordial.

+1
0
-1
Imagen de vicente trigos flores
+1
0
-1

Hola buenas tardes espero que me puedas ayudar soy inexperto y al intentar actualizar adobe flash algo hice mal
y me salio el siguiente error

E:Line 1 too long in source list /etc/apt/sources.list.d/medibuntu.list.

y no de deja ni abrir ni actualizar

muchas gracias espero respuesta

+1
0
-1
Imagen de vicente trigos flores
+1
0
-1

este es el archivo gedit y no se cual es lalinea 1 ni que ni como borrar gracias
# deb cdrom:[Ubuntu 11.10 _Oneiric Ocelot_ - Release i386 (20111012)]/ oneiric main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://archive.ubuntu.com/ubuntu precise main

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu precise-updates main

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu precise universe
deb http://archive.ubuntu.com/ubuntu precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu oneiric partner
# deb-src http://archive.canonical.com/ubuntu oneiric partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu precise main
deb-src http://extras.ubuntu.com/ubuntu precise main
deb http://security.ubuntu.com/ubuntu/ precise-security universe main

+1
0
-1
Imagen de .doc
+1
0
-1

hombre, por lo que yo se, adobe flash dejó de dar soporte a Linux, y no veo claro que te puedas actualizar y, segundo, los repositorios de medibuntu hace años que no existen así que puedes borrar lo de 'medibuntu.list' del archivo /etc/apt/sources.list.d
(tendrás que hacerlo con privilegios de root)

+1
0
-1
Imagen de vicente trigos flores
+1
0
-1

Buenos dias perdona mi ignorancia pero me podrias explicar paso a paso como hacerlo
lo siento perdona las molestias

+1
0
-1
Imagen de vicente trigos flores
+1
0
-1

cuando me refiero a QUE NO PUEDO ACTUALIZAR es que no me deja actualizar el gestor de e actualizaciones cuando las hay y me sale la señal de prohibido con el mensaje de error en linea 1

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

a- gedit, es una aplicación, editor de textos, los archivos reciben nombres propios, en este caso el archivo de texto abierto por gedit se llama sources.list.

b- el archivo /etc/apt/sources.list, salvo que es antiguo y tiene mezcla de versiones de Ubuntu Precise y Oneiric, no tiene errores, los errores estan en el archivo medibuntu.list, que es un archivo perteneciente a un repositorio obsoleto.

c- para eliminarlo, abre una terminal y ejecuta en ella:

exec sudo -i
rm /etc/apt/sources.list.d/medibuntu.list

Sugerencia: actualiza a la versión 16.04.2, baja la iso, grábala en un dvd/usb e instálala.

+1
0
-1
Imagen de vicente trigos flores
+1
0
-1

Muchisimas gracias todo perfecto ahora solo me queda la duda de que el pluging shockwave flash me dice de que es vulnerable y debe ser actualizado de ahi me surgio el problema que me has solucionado como hago para eliminarlo de la lista de plugins mi problema es que cuando quiero ver o editar un video en youtube me dice que debo actualizar dicho pluging mi version de ubuntu por si no te la comente antes es la 12.04 TLS

Muchas gracias por todo

+1
0
-1