Java, o actualizador

Imagen de philema
0 puntos

Resulta que no me deja reproducir ningun video, ni juegos ni nada desde internet y dice "no es posible cargar complemento" supongo que alguna actualización o algo, trato de actualizar y hace algunos dias no me deja actualizar con el gestor de actualizaciones me aparece

El paquete de sistema está roto

Compruebe si está usando repositorios de terceros. En tal caso, desactívelos, ya que son una fuente habitual de problemas.
Posteriormente, ejecute el siguiente comando en un terminal: apt-get install -f

detalles

Los siguientes paquetes tienen dependencias incumplidas:

grub-pc: Depends: grub2-common (= 1.99-21ubuntu3.4) pero 1.99-21ubuntu3.7 está instalado
Depends: grub-pc-bin (= 1.99-21ubuntu3.4) pero 1.99-21ubuntu3.7 está instalado

alguna solución?

Imagen de LyingB
+1
+1
-1

El primer problema muy probablemente se deba a que no tienes instalado el paquete que contiene el plugin de java para el navegador.

Debes instalar icedtea-web desde el Centro de Software.

El segundo problema es autoexplicativo: Tienes un paquete que no se puede instalar bien.

Desde terminal tecelea:

sudo apt-get update
sudo apt-get autoremove
sudo apt-get clean
sudo apt-get install -f

Si tras el último comando te sigue saltando el error teclea lo siguiente:

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d

Y pega la salida acá.

+1
+1
-1


Agrega al final del título del post (solucionado) si has arreglado tu problema.

Imagen de philema
+1
0
-1

SALIDA:
deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse
camilo@ubuntu:~$ ls /etc/apt/sources.list.d
google-chrome.list libreoffice-ppa-lucid.list.save
google-chrome.list.distUpgrade medibuntu.list
google-chrome.list.save medibuntu.list.save
google-talkplugin.list ubuntu-wine-ppa-precise.list
libreoffice-ppa-lucid.list winehq.list
libreoffice-ppa-lucid.list.distUpgrade

la verdad es que me estaba funcionando todo normalmente y de un momento a otro me dejo de funcionar, LOS complementos de java Ya estaban instalados

+1
0
-1
Imagen de LyingB
+1
0
-1

Tienes repositorios de versiones diferentes (Parece que estás usando Precise y tienes repositorios de terceros de Lucid).

Ve al centro de software de Ubuntu y configura los orígenes de software, en la pestaña de otro software desmarca todas las casillas, vuelve a recargar las listas de paquetes e intenta a volver a hacer el sudo apt-get install -f.

En cuanto a lo de Java desconozco a qué pueda deberse si dices tener el plugin instalado ¿Si revisas en los plugins del navegador te lo detecta y está habilitado?

+1
0
-1


Agrega al final del título del post (solucionado) si has arreglado tu problema.

Imagen de philema
+1
0
-1

"no se puede instalar ni desistalar elementos hasta que repare el catalogo de paquetes ¿quiere repararlo ahora"

le doy reparar pero sale error y luego sale una ventana que se cerro inesperadamente, no se en el firefox funciona bien el java

+1
0
-1
Imagen de philema
+1
0
-1

dpkg: problemas de dependencias impiden la configuración de grub-pc:
grub-pc depende de grub2-common (= 1.99-21ubuntu3.4); sin embargo:
La versión de `grub2-common' en el sistema es 1.99-21ubuntu3.7.
grub-pc depende de grub-pc-bin (= 1.99-21ubuntu3.4); sin embargo:
La versión de `grub-pc-bin' en el sistema es 1.99-21ubuntu3.7.
dpkg: error al procesar grub-pc (--configure):
problemas de dependencias - se deja sin configurar
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
Se encontraron errores al procesar:
grub-pc
E: Sub-process /usr/bin/dpkg returned an error code (1)

creo que hay dice el problema.... ya he intentado lo anterior y sigue dando este error

+1
0
-1