[Solucionado] Instalar mono en Ubuntu 12.04 (Precise)

Imagen de Liberto
0 puntos

Hola amigos:

Quería consultaros donde puedo conseguir e instalar mono en mi distribución de Ubuntu, ya que necesito usar un programa desarrollado mono.

El tema es que, como ya sabréis, mono ya no está incluido en el 12.04.

¿Qué se puede hacer?.

Un saludo

Imagen de gato2707
+1
0
-1

Dirás que no está instalado por defecto, pero aún está en los repos

en una terminal:

$sudo apt-get install mono-complete

+1
0
-1

Saludos desde México
Mi Web: El Gato con Linux

Imagen de routerdark
+1
0
-1

muchas gracias

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

O al menos una parte de mono, no todo el entorno de desarrollo que es más grande. Eso es por que Ubuntu ya no incluye por defecto al programa "Tomboy" que usaba unas librerías de mono.

Pero puedes instalarlo como te indica el compañero gato.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Liberto
+1
0
-1

No sé si lo estoy haciendo bien...

Instalé mono mediante el comando que puso Gato.

Cuando intento instalar el programa paint.mono a través de un paquete .deb (haciéndolo con Gdebi) la respuesta que me da Gdebi es:

"Error: la dependencia no se puede satisfacer: accessibility1.0-cil"

¿Qué quiere decir esto?

+1
0
-1

Trabajamos en empleos que odiamos, para comprar mierda que no necesitamos...

Imagen de Jose Luis 1320
+1
0
-1

Yo te aconsejo que instales paint-mono de los repositorios de Ubuntu, si existe claro.

de otra manera usa el .deb, pero debes satisfacer las dependencias que te indica.

sudo apt-get install accesibility1.0-cil

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Liberto
+1
0
-1

Aquí encontré el repositorio:

https://launchpad.net/~xmlich02/+archive/ppa

Añadí al archivo sources.list

deb http://ppa.launchpad.net/xmlich02/ppa/ubuntu lucid main
deb-src http://ppa.launchpad.net/xmlich02/ppa/ubuntu lucid main

Para añadir esto como fuente de software del sistema (serían para Lucid 10.04)

Pero me quedé ahí, no sé como terminar de instalarlo.

¿Cuál sería el siguiente paso?

+1
0
-1

Trabajamos en empleos que odiamos, para comprar mierda que no necesitamos...

Imagen de Liberto
+1
0
-1

Bueno, ya encontré la solución.

Fue así:

1-Ví los detalles de cada paquete.

2-Elegí la versión más actualizada (paint-mono - 3.0.63-9), la descargué e instalé el archivo .deb resultante con dgkp.

Luego hay que teclear Ctrl+F2 y escribir paintdotnet

Y listo!

Instalado mono y la aplicación paint.mono

Mil gracias a los dos.

+1
0
-1

Trabajamos en empleos que odiamos, para comprar mierda que no necesitamos...

Imagen de Jose Luis 1320
+1
0
-1

Mejor instala el .deb que descargaste. Puesto que el repositorio de lucid te va a traer serios problemas de dependencias en el sistema.

los paquetes de lucid son más antiguos que los de precise (la versión que estas usando actualmente).

Ahora ya que solucionaste el problema, vuelve a editar el archivo /etc/apt/sources.list y borra las líneas que agregaste. No las necesitas.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Liberto
+1
0
-1

El tema es que no encuentro repositorio para precise, solo Lucid, Jaunty, Intrepid y Hardy. ¿Hay alguno más recomendable que otro?

+1
0
-1

Trabajamos en empleos que odiamos, para comprar mierda que no necesitamos...

Imagen de Jose Luis 1320
+1
0
-1

significa que ese software no esta empaquetado para precise, ese repositorio quedó en estado letárgico o abandonado, por que no han empaquetado para versiones más nuevas de Ubuntu.

En este caso instala el .deb más reciente de la web oficial.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Liberto
+1
0
-1

Exacto, el programa fue medio abandonado. Y sí, contiene algunos errores que estoy intentando modificar con los programadores de su época. Igualmente mil gracias por la ayuda.

+1
0
-1

Trabajamos en empleos que odiamos, para comprar mierda que no necesitamos...