Dual Monitor con placa PCI

Imagen de chonybmx
0 puntos

Buenos días. Soy relativamente nuevo en esto de las X en ubuntu.

Estoy con un problema de monitores. Actualmente tengo un monitor conectado a la placa On-Board funcionando sin problemas.
Coloque una placa de video extra - PCI - para configurar dual monitor, el hecho es que no me reconoce el segundo monitor, es decir el que esta conectado a la placa PCI. La placa PCI funciona perfecto.

CPU
| |__ ON BOARD __ Monitor-1_1440x900 (Funciona Ok.)
|
|___ Placa PCI ____Monitor-2_1024x768 (No muestra señal)

No se si debo configurar el segundo monitor en el xorg o me lo detecta automáticamente.
Ya probé agregarlo pero lo único que logre fue desconfigurar la pantalla principal.

¿De que forma puedo saber cual monitor es cada uno?? ej cual es VGA-0 y cual VGA-1 por ej.

Version: ubuntu 10.04

jony@cfh ~$ uname -a
Linux cfh 2.6.32-45-generic #102-Ubuntu SMP Wed Jan 2 21:53:06 UTC 2013 i686 GNU/Linux

Acá dejo un screen de las propiedades del monitor.
http://www.subeimagenes.com/img/pantallazo-543325.png

------------------ LSPCI ---------------------

jony@cfh ~$ lspci
00:00.0 RAM memory: nVidia Corporation MCP61 LPC Bridge (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Link Control
01:06.0 VGA compatible controller: Cirrus Logic GD 5446 (rev 45)

VGAs
00:0d.0 VGA compatible controller: nVidia Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)
01:06.0 VGA compatible controller: Cirrus Logic GD 5446 (rev 45)

------------ driver para dicha placa ----------

xserver-xorg-video-cirrus

----------------- Xorg.conf -----------------

jony@cfh ~$ cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder75) Thu Apr 22 11:44:23 PDT 2010
#
Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection
#
Section "Files"
EndSection
#
Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection
#
Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection
#
Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
# HorizSync 28.0 - 33.0
# VertRefresh 43.0 - 72.0
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection
#
Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection
#
Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "UseEdid" "False"
Option "MetaModes" "1440x900 +0+0"
SubSection "Display"
Depth 24
Modes "1440x900" "1600x900" "1024x768" "800x600"
EndSubSection
EndSection

----------- xrandr del monitor que funciona (LCD On-Board) ---------

jony@cfh ~$ xrandr
Screen 0: minimum 320 x 175, current 1440 x 900, maximum 1440 x 900
default connected 1440x900+0+0 0mm x 0mm
1440x900 50.0*
1024x768 51.0 58.0 59.0 60.0 61.0
1360x768 52.0 53.0
1152x864 54.0 55.0 56.0 57.0
960x540 62.0
840x525 63.0 64.0
832x624 65.0
800x600 66.0 67.0 68.0 69.0 70.0
800x512 71.0
720x450 72.0
720x400 73.0
680x384 74.0 75.0
640x512 76.0
640x480 77.0 78.0 79.0 80.0 81.0
640x400 82.0
640x350 83.0
576x432 84.0 85.0 86.0 87.0
512x384 88.0 89.0 90.0 91.0 92.0
416x312 93.0
400x300 94.0 95.0 96.0 97.0 98.0
360x200 99.0
320x240 100.0 101.0 102.0 103.0
320x200 104.0
320x175 105.0

----------- LSHW -------------


jony@cfh ~$ sudo lshw -C video
#
*-display UNCLAIMED
description: VGA compatible controller
product: GD 5446
vendor: Cirrus Logic
physical id: 6
bus info: pci@0000:01:06.0
version: 45
width: 32 bits
clock: 33MHz
configuration: latency=0
resources: memory:da000000-dbffffff(prefetchable) memory:dffff000-dfffffff memory:dfffe000-dfffefff memory:dffe0000-dffe7fff(prefetchable)
*-display
description: VGA compatible controller
product: C61 [GeForce 7025 / nForce 630a]
vendor: nVidia Corporation
physical id: d
bus info: pci@0000:00:0d.0
version: a2
width: 64 bits
clock: 66MHz
capabilities: pm msi bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:23 memory:de000000-deffffff memory:c0000000-cfffffff(prefetchable) memory:dd000000-ddffffff memory:dfec0000-dfedffff(prefetchable)