Desaparecen barras lateral y superior [Solucionado]

Imagen de jri2594
0 puntos

Hola, hace poco que estoy con ubuntu, tengo el 12.10 si no me equivoco, mi idea era dejar de usar windows, pero desde luego ubuntu cada dia me da una sorpresa y no precisamente buena, hoy me an desaparecido la barra lateral y superior.

Lo ultimo que hice fue intentar instalar el guitar pro y instale algunas dependencias, no se si tendra algo que ver.

El caso es que me he visto unos cuantos temas del foro y de otros sitios en los que explican posibles soluciones, pero ninguna funciona.

De momento he improvisado como solución "$ gnome-panel" en la terminal, que me saca las barras de ubuntu clasicas, la superior y la inferior, pero solo mientras tengo ese terminal abierto.

Quiero volver a recuperar la barra lateral y la superior que venian con mi ubuntu 12.10

Muchas Gracias por adelantado.

Os dejo unas lineas de la terminal que igual ayudan:

javi@javi-MS-7728:~$ unity –reset
El programa «unity» no está instalado. Puede instalarlo escribiendo:
sudo apt-get install unity
javi@javi-MS-7728:~$ sudo apt-get install unity
[sudo] password for javi:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
unity : Depende: libunity-core-6.0-5 (= 6.8.0-0ubuntu2) pero 6.12.0-0ubuntu0.2 va a ser instalado
Depende: unity-common (= 6.8.0-0ubuntu2) pero 6.12.0-0ubuntu0.2 va a ser instalado
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

PD: probe a instalar las dependencias libunity-core-6.0.5 y unity-common, pero como si nada sigue dando el mismo error

Imagen de Goyo
+1
0
-1

Además de instalar algunas dependencias desinstalaste unity y ubuntu-desktop. Tendrías que ser más cuidadoso.

Pega aquí la salida de este comando:
apt-cache policy libunity-core-6.0-5

+1
0
-1
Imagen de jri2594
+1
0
-1

En primer lugar muchas gracias por responder y ayudar.

Aqui dejo los resultados del terminal:

javi@javi-MS-7728:~$ apt-cache policy libunity-core-6.0-5
libunity-core-6.0-5:
Instalados: 6.12.0-0ubuntu0.2
Candidato: 6.12.0-0ubuntu0.2
Tabla de versión:
*** 6.12.0-0ubuntu0.2 0
100 /var/lib/dpkg/status
6.8.0-0ubuntu2 0
500 http://es.archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages

+1
0
-1
Imagen de Goyo
+1
0
-1

Creo que lo más sencillo va a ser desinstalar las versiones exóticas de libunity-core-6.0-5 y unity-common y después instalar ubuntu-desktop.
sudo apt-get purge libunity-core-6.0-5
sudo apt-get purge unity-common
sudo apt-get install ubuntu-desktop

+1
0
-1
Imagen de jri2594
+1
0
-1

Ejecute los tres comandos, los dos primeros funcionan bien pero el tercero da algun error, y siguen sin aparecer las barras:

javi@javi-MS-7728:~$ sudo apt-get purge libunity-core-6.0-5
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Los siguientes paquetes se ELIMINARÁN:
libunity-core-6.0-5*
0 actualizados, 0 se instalarán, 1 para eliminar y 25 no actualizados.
Se liberarán 1.056 kB después de esta operación.
¿Quiere continuar [S/n]? s
(Leyendo la base de datos ... 215108 ficheros o directorios instalados actualmente.)
Desinstalando libunity-core-6.0-5 ...
Purgando ficheros de configuración de libunity-core-6.0-5 ...
Procesando disparadores para libc-bin ...
ldconfig deferred processing now taking place
javi@javi-MS-7728:~$ sudo apt-get purge unity-common
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Los siguientes paquetes se ELIMINARÁN:
unity-common* unity-lens-applications*
0 actualizados, 0 se instalarán, 2 para eliminar y 25 no actualizados.
Se liberarán 999 kB después de esta operación.
¿Quiere continuar [S/n]? s
(Leyendo la base de datos ... 215102 ficheros o directorios instalados actualmente.)
Desinstalando unity-lens-applications ...
Purgando ficheros de configuración de unity-lens-applications ...
Desinstalando unity-common ...
Purgando ficheros de configuración de unity-common ...
Procesando disparadores para libglib2.0-0:i386 ...
Procesando disparadores para libglib2.0-0:amd64 ...
javi@javi-MS-7728:~$ sudo apt-get install ubuntu-desktop
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
ubuntu-desktop : Depende: unity pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
javi@javi-MS-7728:~$

+1
0
-1
Imagen de Goyo
+1
0
-1

Trata de instalar unity directamente para ver qué dependencias son.
sudo apt-get install unity

+1
0
-1
Imagen de jri2594
+1
0
-1

ya lo consegui solucionar, al instalar unity daba error por la dependencia libunity-core-6.0-5 al instalar esta dependencia daba error por otra dependencia, no recuerdo su nombre, al instalar esa dependencia tambien daba error, asi que hice purge de esa dependencia y la pude instalar bien, luego hice purge del libunity-core-6.0-5 y lo volvi a instalar sin problemas, y finalmente installe de nuevo unity.

Ya habia intentado lo de instalar unity, pero no me dejaba por esas dependencias, que tambien intente instalar pero no me dejaba, al final consegui solucionarlo gracias al comando purge que me recomendaste, y que no conocia.

Muchas gracias por toda la ayuda, sin ella habria tenido que reinstalar el ubuntu completo.

Gracias.

+1
0
-1